LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-19-2005, 10:54 PM   #1
jstoner
LQ Newbie
 
Registered: May 2005
Posts: 13

Rep: Reputation: 0
Unhappy no audio in SUSE 9.2


I am running SUSE 9.2 on a Shuttle sb61 with a P4 and 512M RAM, with a sound chip described as "828011EB/ER (ICH5/ICH5R) AC97 aucdio Controller" in YAST. Its status is "Running" and when I go into the volume control thing and click "test." it plays a symphonic trill.

When I go into Amarok or any app that makes noise, no sound is produced.

I went to the SUSE site, and tried the instructions on theknowledge base page entitled "Muted Sound Card." (this is my first post here, it won't let me post the URL)

Its instructions are these:

1. Make sure all mixer applications have been unloaded. If not, you should see a speaker icon on the tray beside the clock in the lower right corner. In this case, right-click it and select Quit from the context menu.
2. If the question [Should KAMix start automatically immediately after you log in?] pops up when closing the mixer, confirm with Yes and skip to steps 13 and 14 of these instructions.
3. Start the YaST Control Center and select Software -> Install and Remove Software.
4. Search for "kdemultimedia".
5. Right-click the package kdemultimedia3-mixer then select Delete from menu that opens.
6. Press Accept in the lower right corner.
7. Finish the YaST Control Center.
8. Open a console (e.g., press [Alt]+[F2] and run the command konsole.
9. Enter the command su - in the console.
10. Enter the administrator's (root) password when prompted to do so. No characters (asterisk or similar) are displayed when typing it.
11. Execute the following commands in the given order:
* rcalsasound stop
* rm /etc/asound.state
* rcalsasound start
* alsactl store
12. Log the root user out of the console by pressing [Ctrl]+[D].
13. Enter the command kamix &.
14. Confirm the pop-up message [KDEInit could not start "CheckHardware".].
15. Close the console by pressing [Ctrl]+[D].

I got as far as "Enter the command kamix &." kamix does not seem to be on my system or in the install cds. There seems to be some confusion as to which kamix I should use--there are a couple of them.

I tried "gamix" and it said

May 19, 2005 @ 06:27:04PM: ~
[jstoner@dsl017-024-108]> gamix
probe.c 40: No ALSA device.
main.c 44: Can not make mixer.

There was something I did when I first got suse, following instructions from some suse support page. I can't recall what it was.

My audio is still not working. Any recommendations?

Last edited by jstoner; 05-19-2005 at 10:58 PM.
 
Old 05-20-2005, 12:24 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
You may need to install the alsa-utils package and run "alsaconf" as root. Also, make sure that you are a member of the Audio group. ( However, if you heard a sound from the KDE Sound server setup as a regular user, you probably already are. ) One other thing to do is to bring down the server timeout period to 1 or 2 seconds. If you have used a program like "xine" make sure the sound isn't muted there. For some reason the xine program volume settings are persistant in SuSE.

You can restart alsa, or reload the settings using "rcalsasound" as root. Also, the initial alsa sound settings are stored in a configuration file in /etc. I don't remember off hand the exact name of the file. Alsa may have it's own subdirectory in /etc with an alsa.conf file int the directory, so try either /etc/alsa or /etc/alsa/alsa.conf.
The settings in this file are loaded in when you boot up.

Last edited by jschiwal; 05-20-2005 at 12:39 AM.
 
Old 05-20-2005, 08:41 PM   #3
jstoner
LQ Newbie
 
Registered: May 2005
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by jschiwal
You may need to install the alsa-utils package and run "alsaconf" as root.
I don't see "alsa-utils" in the yast software install dialog, but alsaconf is installed. Again, it plays the same symphonic trill when I run through its process.

Quote:
Also, make sure that you are a member of the Audio group. ( However, if you heard a sound from the KDE Sound server setup as a regular user, you probably already are. )
I did do that. Anytime I've heard a peep out of this distro, it was as root. (Yast asks for root PW when I start it, so I assume I'm running as root. alsaconf runs as root too.)

Quote:
One other thing to do is to bring down the server timeout period to 1 or 2 seconds.
I tried this, it might break amarok, or break it worse. I don't see the sound wave play in the visualization, and it's as silent as ever.

Quote:
If you have used a program like "xine" make sure the sound isn't muted there. For some reason the xine program volume settings are persistant in SuSE.
I checked that. The sound isn't muted. Do you control volume through the mixer in KDE? I can't seem to start one on this box.

Quote:
You can restart alsa, or reload the settings using "rcalsasound" as root.
I think I did this as part of the process outlined above. I tried again, it didn't seem to help.

When I look for an alsa process I don't find anything:

May 20, 2005 @ 07:25:08PM: /home/jstoner
[root@dsl017-024-108]# ps -ef | grep alsa
root 31117 26438 0 19:25 pts/11 00:00:00 grep alsa

Is that the right string to search on?

Quote:
Also, the initial alsa sound settings are stored in a configuration file in /etc. I don't remember off hand the exact name of the file. Alsa may have it's own subdirectory in /etc with an alsa.conf file int the directory, so try either /etc/alsa or /etc/alsa/alsa.conf.
The settings in this file are loaded in when you boot up.
May 20, 2005 @ 07:30:58PM: /home/jstoner
[root@dsl017-024-108]# find /etc -name alsa*
/etc/alsa.d
/etc/init.d/alsasound
/etc/hotplug/usb/alsasound.usermap
/etc/hotplug/usb/alsasound

alsasound.usermap might be a config file, the others are scripts.
 
Old 05-21-2005, 01:45 AM   #4
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
I had a very similar problem tonight in Suse 9.2.
I just went back into Yast to check the settings.
The module wasn't loading or had some sort of error.

I just deleted my current setup and started over.
I did the exact same thing I did the first time and it worked.

I went back to the desktop opened Kmix and checked the levels.
I started XMMS. Loaded some Mp3's off hda, and I was listening to music again.

I hope any of this helps.
Blair
 
Old 05-21-2005, 02:28 AM   #5
jstoner
LQ Newbie
 
Registered: May 2005
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by DeadPenguin
I had a very similar problem tonight in Suse 9.2.
I just went back into Yast to check the settings.
The module wasn't loading or had some sort of error.

I just deleted my current setup and started over.
I did the exact same thing I did the first time and it worked.


what do you mean by "deleted my current setup?" What did you delete? can you list the steps?

Quote:
I went back to the desktop opened Kmix and checked the levels.
I started XMMS. Loaded some Mp3's off hda, and I was listening to music again.
I can't seem to find KMix. The first time I tried to deal with this, I may have uninstalled it. How do I figure out which package it's in?

I hope any of this helps.
Blair
[/QUOTE]

I think this is getting me closer.
 
Old 05-21-2005, 03:58 AM   #6
Sc0pE
Member
 
Registered: Aug 2004
Location: Northern Ireland
Distribution: Suse 9.3
Posts: 46

Rep: Reputation: 15
i had this problem in suse 9.2 aswell i just ran alsaconf in the konsole as root and followed the steps and it worked but i didn't know how to save the file so every reboot i had to do it was no biggie though cause i didn't reboot often
 
Old 05-21-2005, 12:15 PM   #7
jstoner
LQ Newbie
 
Registered: May 2005
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Sc0pE
i had this problem in suse 9.2 aswell i just ran alsaconf in the konsole as root and followed the steps and it worked but i didn't know how to save the file so every reboot i had to do it was no biggie though cause i didn't reboot often
I did that too, and it didn't work.
 
Old 05-21-2005, 11:57 PM   #8
jstoner
LQ Newbie
 
Registered: May 2005
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
I can't seem to find KMix. The first time I tried to deal with this, I may have uninstalled it. How do I figure out which package it's in?
Ah, reconstruction of steps. On the advice of a Novell support guy, I uninstalled kdemultimedia3-mixer, when I first started having this problem months ago. So I reinstalled it, and it still doesn't work.

I also tried switching to Gnome, and that didn't work either.

My patience with SUSE is running out. If any of you SUSE partisans want to stop me from switching back to Redhat, I need this to work soon, and I need printing to work too. ( I have a thread about that under hardware.)

My impression of SUSE so far: prettier than Redhat, but flakier, with crappier support. I'd be happy to be proved wrong.
 
Old 05-22-2005, 12:38 AM   #9
jstoner
LQ Newbie
 
Registered: May 2005
Posts: 13

Original Poster
Rep: Reputation: 0
OK, I think I can distill this into three WTF? inducing lines of shell command:

May 21, 2005 @ 11:30:08PM: ~
[jstoner@dsl017-024-108]> sudo /usr/sbin/rcalsasound stop
Password:
Shutting down sound driver done
May 21, 2005 @ 11:30:29PM: ~
[jstoner@dsl017-024-108]> sudo /usr/sbin/rcalsasound start
Starting sound driver: intel8x0 done
Restoring the previous sound setting done
May 21, 2005 @ 11:30:36PM: ~
[jstoner@dsl017-024-108]> gamix
probe.c 40: No ALSA device.
main.c 44: Can not make mixer.
May 21, 2005 @ 11:30:47PM: ~
[jstoner@dsl017-024-108]>

WTF?
 
Old 05-22-2005, 03:29 AM   #10
Sc0pE
Member
 
Registered: Aug 2004
Location: Northern Ireland
Distribution: Suse 9.3
Posts: 46

Rep: Reputation: 15
when you run alsaconf does it say building database etc and give you're intel sound card after thats done you should hear a test of sound, after that i ran alsamixer and changed the sound levels...if not im not sure here was my original post on this subject awhile back http://www.linuxquestions.org/questi...hreadid=291884
or upgrade to suse 9.3 that fixed my problem
 
Old 05-22-2005, 12:50 PM   #11
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
By deleted current setting-

Control Center -> Yast2 modules -> Hardware -> Sound ->click the Admin button---enter root password. -> I saw the AC97 was already configured. I went through to see if I could fine tune the settings. It said the module had an error loading. I then went back and deleted the configured AC97. I then checked add sound card. The onboard sound was found again. I went through the config. When I was done I went to KMix under Multimedia->Volume Control->KMix.
I just wanted to check and make sure the output was not muted.
It was not. I then fired up XMMS and it worked.

I have used alsaconfig, but I have had a hard time getting the settings to stick. It was just easier to do in Yast for me. In Slackware I use alsaconfig and it works fine.

As for Suse I think it depends on the hardware you use to how "flaky" it is. Install was a breeze on both computers I am running it on.(a dell 600m laptop, and a homemade AMD anthlon XP 2600+)
On the laptop I have had a hard time with wireless and setting up a samba share. Both problems will be easily fixed if I find the time.

As for support you could always buy the 9.3 pro and get online support via their portal. But, I have found all the support I have ever needed here.

Suse is a solid entry level distro. Mandrake(mandriva) is a solid substitute. Fedora Core 3 is another good alternative.

I hope any of this helps. Sorry it took so long to get back to you.

Good Luck,
Blair

Last edited by DeadPenguin; 05-22-2005 at 12:52 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10.0 audio worldgnat Linux - Hardware 20 08-24-2005 06:32 PM
SuSE 9.1 audio meamyou SUSE / openSUSE 6 05-15-2005 02:40 PM
suse 9.2 audio problems after YOU tjracer66 Linux - Hardware 0 01-12-2005 09:16 PM
5.1 audio in suse 9.1 ntisoldtech SUSE / openSUSE 2 11-14-2004 02:58 AM
SuSE 8.1 Audio lado Linux - Software 0 04-14-2003 03:15 AM


All times are GMT -5. The time now is 12:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration