LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-28-2004, 10:57 PM   #1
elf-assassin
LQ Newbie
 
Registered: May 2004
Location: new york
Distribution: Suse 9
Posts: 17

Rep: Reputation: 0
no 3d acceleration with my ATI Radeon 9600 XT


Ok i am a new to linux. I installes suse 9.0 but had support issues so i am running mandrake 10 official. I have a very good new 128 mb ati radeon video card and i can even run an open Gl screen saver properly and when i ran suse 9 it said no 3d acceleration. so i do i go about fixing this.
 
Old 05-29-2004, 12:55 AM   #2
teedog
LQ Newbie
 
Registered: May 2004
Distribution: Gentoo
Posts: 2

Rep: Reputation: 0
Do you have the ATI drivers installed? v3.9.0 was just released so you could try that. Here's an excellent FAQ for ATI Radeons (with some Gentoo-specific info):
http://odin.prohosting.com/wedge01/g...adeon-faq.html
It should be pretty much the same for other distro's though.
 
Old 05-29-2004, 05:51 AM   #3
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
More excellent How-Tos:

ATI Radeon Linux How-To

Driver patches - Rage3D Discussion Area

ATI Radeon Howto

Hope this helps.
 
Old 05-29-2004, 09:48 PM   #4
elf-assassin
LQ Newbie
 
Registered: May 2004
Location: new york
Distribution: Suse 9
Posts: 17

Original Poster
Rep: Reputation: 0
i went to the ati site but it says to download the driver for you xfree86 version and if you dont know download and run check.sh . i dled it and when i click on it nothing happens and i have the permissions set for exec. im back to running suse 9.0 now.
 
Old 05-30-2004, 06:55 AM   #5
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
You have to run it in a terminal, so you can see the output.
 
Old 05-31-2004, 07:25 PM   #6
elf-assassin
LQ Newbie
 
Registered: May 2004
Location: new york
Distribution: Suse 9
Posts: 17

Original Poster
Rep: Reputation: 0
ok i ran everything the way ati said to run it and when i finished with the fglrxconfig and answered all the questions i checked the fglrxinfo and it says mesa not ati...what do i do now
 
Old 06-01-2004, 05:34 AM   #7
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Try restarting the X server (reboot, log out, CTRL-ALT-Backspace) so it uses the new settings instead of the old ones, which are still loaded into memory.
 
Old 06-01-2004, 05:56 AM   #8
postmaik
Member
 
Registered: May 2004
Location: @ Lake Constance, Germany
Distribution: FC3, Kernel 2.6.10
Posts: 46

Rep: Reputation: 15
After rebooting the system was everything alright then?
Just asking 'cause I had the same problem. And to fix that I had to do something else...
 
Old 06-01-2004, 11:14 AM   #9
elf-assassin
LQ Newbie
 
Registered: May 2004
Location: new york
Distribution: Suse 9
Posts: 17

Original Poster
Rep: Reputation: 0
ok you lost me...after i finished running fglrxconfig in the konsole what would you like me to type or do from there...sorry i new at this
 
Old 06-01-2004, 11:22 AM   #10
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Quote:
Try restarting the X server (reboot, log out, CTRL-ALT-Backspace)
Either reboot, log out and back in, or use CTRL+Alt+Backspace to restart the X (graphical display) server. At the moment, it is using the settings that it read from before you changed the drivers. The X environment must be restarted in order to re-read the settings and use the new ones.

Rebooting will restart the X server. So will logging out. Holding down the CTRL+ALT+Backspace keys will also restart the X server, but is usually only used in case of emergencies such as a hard lockup.
 
Old 06-02-2004, 02:06 AM   #11
postmaik
Member
 
Registered: May 2004
Location: @ Lake Constance, Germany
Distribution: FC3, Kernel 2.6.10
Posts: 46

Rep: Reputation: 15
Yeah... one moment. In SuSE 9 I had to do the following:
Before restarting anything, try copying the XF86Config-4 by typing (as root)

cd /etc/X11
cp XF86Config-4 XF86Config

That will copy the config file and name it XF86Config. I don't know, what is wrong in SuSE, but that worked for me.
After you did this you can restart your computer so that fglrx module is restarted as well and not only the X server...

Hope you will have success...
 
Old 06-02-2004, 03:00 AM   #12
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
fglrxconfig gives you a choice as to what to name the file when you're finished configuring and you want to save. /etc/X11/XF86Config-4 is just one of 4 possiblilities that various distros use for the main XFree86 configuration file.

The original standard location was /etc/XF86Config. At some point either XFree86 or the distros decided that it would be logical to move the file into /etc/X11, so then the config might be either in /etc/XF86Config or /etc/X11/XF86Config. During the introduction of XFree86 version 4, apparently there were enough fundamental differences between that and version 3 that some distributions (which offered both versions) felt the need to distinguish between the version 3 and version 4 configuration files, so depending on which version you had installed, the file would be either XF86Config (if version 3) or XF86Config-4. This resulted in the configuration file being variously named and located under different distros: you might have

/etc/XF86Config
/etc/XF86Config-4
/etc/X11/XF86Config
/etc/X11/XF86Config-4

Now some distros are dropping the -4 part, since not so many people run older versions of XFree86, and even if they did, there's no need to distinguish the config files anymore, and some are also moving the config file back to base /etc/. Some, however, continue to go with what they feel their users are used to.

In any case, this is the likely reason that fglrxconfig gives you a choice of filenames and locations to save to; if you choose "no" when it gives you /etc/X11/XF86Config-4, it will ask if you then want to save to /etc/X11/XF86Config; if you say "no" to that, it will ask you if you want to save to /etc/XF86Config instead, and if you say "no" to that, it will ask you to type in a path and filename that you want to save to.

So while there's nothing wrong with copying the final configured file to the correct location, I'd just like to point out that if you had looked in /etc/ and /etc/X11 in the first place, and knew the correct filename, you could have saved the file to the proper location originally without having to fix it later.

Just so you know for the future .
 
Old 06-02-2004, 03:13 AM   #13
postmaik
Member
 
Registered: May 2004
Location: @ Lake Constance, Germany
Distribution: FC3, Kernel 2.6.10
Posts: 46

Rep: Reputation: 15
Yah man,
you're so right! I'm sorry, but I wanted to help elf-assassin with feeling what he did and telling him what to do in the next step as I did until it worked for me. Fixing it later was easier to explain because it's faster to rerun fglrxconfig.
But thanks for the story...
Hopefully it helped to fix the problem.
 
Old 06-03-2004, 11:34 AM   #14
elf-assassin
LQ Newbie
 
Registered: May 2004
Location: new york
Distribution: Suse 9
Posts: 17

Original Poster
Rep: Reputation: 0
OK guys nothing is working...i reran the fglrxconfig and when it finished i logged out then back in and it still saying mesa..I even tryed it again and did the copy thing postmaik said...nothing still mesa...This is driving me nuts i have a real nice card that i can use.. I like linux alot so i dont wanna have to go back to a dual boot with windows just so i can play games...thers gotta be a way to fix this
 
Old 06-03-2004, 01:55 PM   #15
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
How did you install the fglrx drivers? Have you followed any of the HOW-TO's linked above? The Mesa drivers should have been overwritten by the ATI drivers. The fact that they weren't may be a problem-- but it may also not be true. I seem to have heard reports of fglrxinfo reporting Mesa incorrectly under certain circumstances, but offhand I don't remember what those circumstances are, sorry .

Could you post:

1. the output of dmesg (please reboot beforehand; we want to know if the fglrx module is even loading at startup);

2. the output of lsmod |grep fglrx after you have booted, which will tell us if the module is currently loaded;

3. the contents of the XFree86 configuration file you are using... and is this the only one you have? It may be that you've configured a file that is not being used, as per my post above;

That ought to be enough to start the deeper search as to the cause of this problem.... be glad I don't know more about SuSE internals, or I'd ask for a couple of other config files as well .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radeon 9600. Want 3d acceleration. bigmetalrabbit Linux - Distributions 3 10-10-2005 04:33 PM
SUSE 9.2 ATI Radeon 9600 need to enable 3D acceleration scrondle Suse/Novell 14 04-01-2005 11:22 PM
3D Acceleration with ATI Radeon 9600 jawaking00 Linux - Hardware 2 03-06-2004 06:41 PM
radeon 9600 3d acceleration not working scarryharry Linux - Hardware 9 02-07-2004 12:50 PM
No 3d Acceleration with ATI Radeon 9600 debian junkie Linux - Hardware 12 01-29-2004 04:07 PM


All times are GMT -5. The time now is 06:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration