LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No 12 hour format available in gnome clock (UK English) (http://www.linuxquestions.org/questions/linux-newbie-8/no-12-hour-format-available-in-gnome-clock-uk-english-829922/)

solitaira 09-02-2010 06:31 AM

No 12 hour format available in gnome clock (UK English)
 
Very simple question but very frustrating as none of the other threads/bug reports/whatever have had quite the same problem. I want gnome clock to display the time in 12 hour format. The suggested solution is something like right-click the clock -> Preferences and somewhere there will be an option to choose 12/24 hour time. Problem is I don't have that option.

The help has a note that 12 hour time "is not shown if your session language does not use the 12 hour clock" but this really shouldn't be a problem? My language/locale/city, everything I can think of, it's all some variation of en_GB, UK English, Brisbane, Australia: all places which should allow the option of 12 hour clock! So why don't I have that option?

I'm so frustrated about this, so my heartfelt thanks go to anyone who can help.

DavidMcCann 09-02-2010 12:23 PM

Try the Applications menu for System tools - Configuration editor. If you don't have it, install gconf-editor. There you can click successively on apps - panel - applets - clock - prefs and change the entry for "format" to "12-hour". NB here and in the examples below, you may find "clock" is called "clock_screen0".

Alternatively, edit ~/.gconf/apps/panel/applets/clock/prefs/%gconf.xml and ensure it contains
<entry name="format" mtime="1283439736" schema="/schemas/apps/clock_applet/prefs/format" type="string">
<stringvalue>12-hour</stringvalue>
</entry>
(the number may be different in your file)

Thirdly, you could use the command
gconftool-2 -t string -s /apps/panel/clock/prefs "12-hour"


PS It's a good idea to show your distro in your profile: gnome is not exactly the same in all of them.

solitaira 09-02-2010 05:10 PM

Thanks for all those suggestions. I went through all of them but they all already do say 12-hour time in the relevant entries. I still don't see an option in the GUI gnome clock preferences to change to 12-hour time, which is sort of making me think the clock or the panel or something has a different idea of what my locale is and so it's defaulting to what it thinks my region uses? But that's just a wild guess in the dark and I can't see anything in gnome configuration editor that seems even vaguely relevant to that.

PS Thanks for the tip about the distro thing, as you can now see it's opensuse 11.3 :) sorry for not stating that in advance.

DavidMcCann 09-03-2010 12:07 PM

If ~/.gconf/apps/panel/applets/clock/prefs/%gconf.xml says you've got a 12 hour clock and you haven't, that's a bug: report it to Suse.

DavidMcCann 09-05-2010 04:47 PM

I should have suggested another possible solution: use the configuration editor, set the format to "custom", and then you can enter a custom format six lines above; I have
%R %a %d/%m

Find the parameters with "man date"; you'll probably want to include %r.


All times are GMT -5. The time now is 07:49 PM.