LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2013, 10:07 AM   #1
kevinpatel
LQ Newbie
 
Registered: Jan 2013
Posts: 1

Rep: Reputation: Disabled
nistnet installation problem


Hi

I get error during nistnet installation.

./configure run successfully
But during Make command
ERROR:

test -e include/linux/autoconf.h -a -e include/config/auto.conf || (
\
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf
are missing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to
fix it."; \
echo; \
/bin/false)
mkdir -p /home/work/src/nistnet-3.0a/kernel/.tmp_versions ; rm -f
/home/work/src/nistnet-3.0a/kernel/.tmp_versions/*
make -f scripts/Makefile.build obj=/home/work/src/nistnet-3.0a/kernel
scripts/Makefile.build:46: *** CFLAGS was changed in
"/home/work/src/nistnet-3.0a/kernel/Makefile". Fix it to use
EXTRA_CFLAGS. Stop.
make[2]: *** [_module_/home/work/src/nistnet-3.0a/kernel] Error 2
make[2]: Leaving directory `/usr/src/kernels/2.6.25.3-18.fc9.i686'
 
Old 01-10-2013, 12:52 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,921

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by kevinpatel View Post
Hi
I get error during nistnet installation.

./configure run successfully
But during Make command
ERROR:

test -e include/linux/autoconf.h -a -e include/config/auto.conf || (
\
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf
are missing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to
fix it."; \
echo; \
/bin/false)
mkdir -p /home/work/src/nistnet-3.0a/kernel/.tmp_versions ; rm -f
/home/work/src/nistnet-3.0a/kernel/.tmp_versions/*
make -f scripts/Makefile.build obj=/home/work/src/nistnet-3.0a/kernel
scripts/Makefile.build:46: *** CFLAGS was changed in
"/home/work/src/nistnet-3.0a/kernel/Makefile". Fix it to use
EXTRA_CFLAGS. Stop.
make[2]: *** [_module_/home/work/src/nistnet-3.0a/kernel] Error 2
make[2]: Leaving directory `/usr/src/kernels/2.6.25.3-18.fc9.i686'
Ok...so when it told you:
Quote:
Run 'make oldconfig && make prepare' on kernel src to fix it.
...did you DO IT?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nistnet.2.0.12c installation problem ahmed_alzahrani Linux - Software 1 06-08-2006 03:45 PM
Nistnet installation kiran_challa Linux - Newbie 1 07-07-2005 02:01 PM
problems with Nistnet Installation kiran_challa Linux - General 1 07-05-2005 08:33 AM
Problems with Nistnet Installation kiran_challa Linux - Newbie 1 07-05-2005 08:33 AM
Problem with Nistnet Installation kiran_challa Linux - Software 0 07-05-2005 04:55 AM


All times are GMT -5. The time now is 10:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration