LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-21-2004, 12:19 PM   #1
badgolfer73
LQ Newbie
 
Registered: May 2004
Location: outside boston
Distribution: Slackware 9.1
Posts: 14

Rep: Reputation: 0
NIC Settings not holding thru reboot slackware9.1


hello all,

I am a professional Windows AD guy who is liking his new linux box so far, but I have a noob question on NICs....I have just finished installing Slackware 9.1 on one of my laptops, and learned a lot on the way. It is up and running fine, and I was able to install my Cabletron (now Cisco) Roamabout wireless card using the native wireless support in the 9.1 build. The problem that I am having is that after I go and config the NIC and the wireless using ifconfig and iwconfig, everything is fine until I reboot- then I lose all the settings, and have to re-enter them-a neat little "net-security" thing to be sure, but a royal P-I-A nonetheless....am I missing something stupid? Is there an actual file that I should be manually editing with the proper info? Also, for anyone who is familiar with the wireless in slack9.1, is there any way to keep the encryption key from being stored in plain text?

thx in advance
 
Old 05-21-2004, 01:59 PM   #2
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
For your network settings, the file to look at is

/etc/rc.d/rc.inet1.conf

That's where you can set your default settings.

For the wireless settings, I created a file in the same location called

rc.wireless

It's a simple script that sets my default settings (WEP included).

For your last question, I'm not sure what you mean by "storing the WEP key in plain text"
Where are you storing it?
You'll notice that running iwconfig as user will not actually display the encryption key, whereas it will display when run as root. You'll have to have the key stored in the startup script if that's how you want to run things. One thing you could do is set the permissions on rc.wireless so only root can read or write to it, but it's still executable.

Hope that helps get you going. Hope you continue to enjoy Slack!
 
Old 05-21-2004, 02:32 PM   #3
badgolfer73
LQ Newbie
 
Registered: May 2004
Location: outside boston
Distribution: Slackware 9.1
Posts: 14

Original Poster
Rep: Reputation: 0
Sounds good. I will try your suggestions. As for the encryption, I answered my own question when I logged out of root and back on as user...doh

thx- I will post my successes or failures....
 
Old 05-21-2004, 03:34 PM   #4
badgolfer73
LQ Newbie
 
Registered: May 2004
Location: outside boston
Distribution: Slackware 9.1
Posts: 14

Original Poster
Rep: Reputation: 0
good to go! was able to admin the NIC thru inet1.conf...created a script called rc.wireless, but for some reason could not get it to work at bootup, so I just added those entries to rc.local, and that is working until I can figure out a better way.

thx again. Being a new Linux user, these forums have been great!
 
Old 05-21-2004, 04:43 PM   #5
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
If I remember, I made a call to the rc.wireless script right from rc.inet1, but the rc.local works just the same.

 
Old 05-22-2004, 08:44 AM   #6
badgolfer73
LQ Newbie
 
Registered: May 2004
Location: outside boston
Distribution: Slackware 9.1
Posts: 14

Original Poster
Rep: Reputation: 0
thx. I think then that I will leave it in rc.local for now. BTW, you know of any issues with wireless encryption using Linux? running into an issue where my linux box cannot get past the encryption approval on my router- triple checked the enc-string, and re-verified on my other wireless devices (another laptop, desktop, and TiVo), and all work. Further, the enc string that I am using to test is the same one that we use at work, which worked on my linux box yesterday, but will not work at home. if you turn encryption off, it picks up an IP fine......
 
Old 05-22-2004, 10:43 PM   #7
badgolfer73
LQ Newbie
 
Registered: May 2004
Location: outside boston
Distribution: Slackware 9.1
Posts: 14

Original Poster
Rep: Reputation: 0
thx again super......I was able to fix my wireless, and figured that I would post in case someone else runs into it. When i run iwconfig eth{adapter] key ..... in slackware 9.1, and I specify the key number, the key number needs to be appended after the enc string, even though the man page says it can be before. I also needed to turn off encryption (iwconfig eth{adapter} enc off) before specifying any of this, and re-activate after. Also, since the card cannot get an address on boot, it will go "down"..you will need to run ifconfig eth{adapter} up...Since I run on multiple wireless nets, I created a few config scripts, one for each net that I run (home, work, family) that will change the essid, key number and enc string depending on which net. If you do this, however ,make sure that you change perms on the files to allow execution, but not editing, as you will need to store the enc strings in there.
anyway, I am sure that there are cleaner ways to do it, but conmsidering I have only been running linux for 5 days, and I got it to work, I am psyched...
 
Old 05-23-2004, 01:05 AM   #8
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
I must not have noticed before, but it sounds like you're talking about a PCMCIA wireless adapter. Am I right?

If that be the case, there is a very easy way to deal with multiple network "profiles" using the cardctl command.

Take a look at these two files:

/etc/pcmcia/network.opts
/etc/pcmcia/wireless.opts

They are pretty self-explanatory. You can specify network and wireless settings for multiple networks/APs and simply change "schemes" by the command

cardctl scheme scheme name

Also, if you are using the two pcmcia config files, you can remove your settings from /etc/rc.d/rc.inet1.conf as they are not needed there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Settings get reset on reboot xymian Debian 3 02-23-2005 05:53 AM
Graphics Acceleration Settings Not Holding inescapeableus Linux - Software 0 12-04-2004 10:28 PM
hdparm settings after reboot Crashed_Again Linux - General 1 03-04-2004 07:43 AM
Can't get xawtv to keep settings on reboot BlankFrank Linux - Software 0 02-27-2004 02:53 PM
Help w/ NIC install Slackware9 m3kgt Linux - Newbie 8 10-27-2003 01:58 PM


All times are GMT -5. The time now is 02:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration