LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-08-2004, 09:50 PM   #1
SupRspi
LQ Newbie
 
Registered: Jun 2004
Location: Canada
Distribution: Mandrake so far...
Posts: 3

Rep: Reputation: 0
NIC Problem Mandrake vs. XP


Hey All,

I installed Mandrake 10 CE, and apart from other problems (which I will give their own thread) I have a big problem with my onboard NIC.

I have two harddrives, identical Maxtor 80Gb drives. I have winxp pro on one, and mandrake 10 CE on the other, choosing my boot through bios boot order.

Since I installed mandrake, my onboard NIC does not work in WinXP. On powering on the computer, I have no link light. If I boot into WinXP I get the helpfull little XP bubble in my system tray that lets me know that "a network cable is unplugged".

However, when I boot into mandrake, I have no link light either. Once the boot process starts, it runs through a bunch of checks, one of which is "init ethernet adapter eth0" or something, which it says Failed in red in the left hand column. Once I am into KDE though, my link light pops on and I have full connectivity.

The wierd thing is I cannot find settings in my bios to disable/enable my onboard NIC (Broadcom 4401 I think) and I don't have a link light until mandrake does it's voodoo.

Anybody have a clue how to fix this?
 
Old 06-09-2004, 09:15 AM   #2
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Can you post an output of dmesg ? Actually the part related to eth0.

Dmesg contains all the messages that are logged during the start-up process.

Do you use DHCP or static IP addresses ?
If you use DHCP try static IP address.

What is the output of:

ifconfig

cat /etc/sysconfig/network
cat /etc/sysconfig/network-scripts/ifcfg-eth0

What kernel level do you have ?

I know that the kernel levels below 2.6.6 have their problems with DHCP.

Therefore I suggest you go to kernel 2.6.7-rc2.

Last edited by Vlad-A; 06-09-2004 at 10:12 AM.
 
Old 06-09-2004, 10:49 AM   #3
SupRspi
LQ Newbie
 
Registered: Jun 2004
Location: Canada
Distribution: Mandrake so far...
Posts: 3

Original Poster
Rep: Reputation: 0
OK - here is selected parts of dmesg
Quote:
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
and

Quote:
Broadcom 4401 Ethernet Driver bcm4400 ver. 3.0.7 (10/31/03)
PCI: Enabling device 00:09.0 (0004 -> 0006)
PCI: Assigned IRQ 5 for device 00:09.0
eth0: Broadcom BCM4401 100Base-T found at mem de000000, IRQ 5, node addr 00e018e4de66
Quote:
PCI: Enabling device 00:0e.0 (0004 -> 0005)
PCI: Assigned IRQ 10 for device 00:0e.0
bcm4400: eth0 NIC Link is Up, 100 Mbps full duplex
I use DHCP, and don't have trouble getting an ip address in linux. Just since I installed linux I don't get a link between my onboard NIC and my router during boot up (like I used to) or in WinXP (also like I used to.)

output of ifconfig:
Quote:
[suprspi@localhost suprspi]$ ifconfig
bash: ifconfig: command not found
am I doing something wrong here?

and

Quote:
[suprspi@localhost suprspi]$ cat /etc/sysconfig/network
NETWORKING=yes
[suprspi@localhost suprspi]$ cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=dhcp
NETMASK=255.255.255.0
ONBOOT=yes
MII_NOT_SUPPORTED=no
NEEDHOSTNAME=yes
Now I have to get dressed and get to work - I'll check back on this later. Thanks for the help Vlad.

Cheers,
SupRspi
 
Old 06-09-2004, 11:42 AM   #4
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Boot with boot option
noapic

If this does not help then:

Login as root.

ifconfig
or
/sbin/ifconfig

Since you have 2 cards: There must be also
/etc/sysconfig/network-scripts/ifcfg-eth1

First make a backup of the ifcfg-eth0 and ifcfg-eth1 files.

cd /etc/sysconfig/network-scripts
cp ifcfg-eth0 ifcfg-eth0.bak
cp ifcfg-eth1 ifcfg-eth1.bak

Modify the parameters in both files (ifcfg-eth0 and ifcfg-eth1) like folowing

MII_NOT_SUPPORTED=yes
NEEDHOSTNAME=no

You may also add (I do not know if Mandrake recognizes this)
DHCP_HOSTNAME=name

where "name" is the name of your server.

You may also add to your /etc/sysconfig/network
HOSTNAME=name

again name is the name of your server.

*Delete* the NETMASK entry in *both* files (so ifcfg-eth0 and ifcfg-eth1)
Since you are usig DHCP you do not need a NETMASK Entry.

As for the XP Problem:

Try to delete the Ethernet Adapter in the Hardware Manager reboot Windows XP.

Last edited by Vlad-A; 06-09-2004 at 03:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake as gateway/firewall -Problem bringing up two NIC zhex900 Linux - Networking 6 06-01-2005 09:24 PM
2 External Nic, 1 Internal Nic Router Problem trevanda Linux - Networking 0 10-13-2004 02:20 AM
Mandrake 10.0 CE Broadcom NIC problem jrg Mandriva 1 05-07-2004 09:33 PM
Mandrake 9.1 & NIC problem VadimAzov Linux - Networking 1 07-21-2003 02:48 AM
Mandrake 9.0 Problem with NIC BkBond12 Linux - Hardware 1 01-10-2003 09:17 PM


All times are GMT -5. The time now is 01:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration