LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-04-2004, 04:05 PM   #1
Lostin Linux 99
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Rep: Reputation: 0
NIC Card Inactive


RH9 - Non-GUI Need Help! I have a firewall box that stopped connecting to the net for some reason. Network status says both cards are configured but only 1 is active. If I try to access the card as root user I get "permission denied" msg. Changed root passwords but still no luck! Read somewhere that removing both cards, re-booting, then installing cards again & re-booting will reactivate. I am leary of this method where permissions were denied in accessing them thru "ifcfg"
Any suggestions??
 
Old 11-04-2004, 04:11 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
How are you trying to access the NIC?
 
Old 11-04-2004, 04:16 PM   #3
Lostin Linux 99
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Original Poster
Rep: Reputation: 0
I'm not sure I understand the question. I used the following command: /etc/sysconfig/network-scripts/ifcfg-eth1 & Rec'd -bash: "repeat command": Permission denied
 
Old 11-04-2004, 04:22 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
That is a configuration file, not a script or appliction. Just edit the file with a text editor if you need to change the IP address etc then run:
ifconfig eth1 up

Then to see if it is up you can run:
ifconfig
 
Old 11-04-2004, 04:31 PM   #5
Lostin Linux 99
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Original Poster
Rep: Reputation: 0
The reason I was trying to access the configuration was to ensure it was set to activate on boot-up. What stumps me is how to activate it if Linux sees it as configured?? If it configured correctly and set to activate at boot-up then a bad card perhaps??
 
Old 11-04-2004, 04:42 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Do you have this line in your config (if the option says "no" then change it to yes):
ONBOOT=yes
 
Old 11-04-2004, 04:48 PM   #7
Lostin Linux 99
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Changing the setting is done via a text editor like "vi" ??

Also, I just entered : ifconfig eth1 up and rec'd "No Such Device"
It seemed to accept the same command for eth0 with no retort.
Does this indicate a nic problem?
 
Old 11-04-2004, 04:52 PM   #8
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
It is either a nic or driver problem. Do you see eth1 listed in:
dmesg | grep -i eth

What kind of nic is it?
lspci

Do you have a driver loaded for it?
lsmod
 
Old 11-04-2004, 05:01 PM   #9
Lostin Linux 99
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Ran ifconfig eth1
eth1: error in fetching interface info: device not found

Ran dmesg....
8139too Fast Ethernet driver 0.9.26
divert: allocating divert_bkl for eth0
eth0: D-Link DFE-538TX
...plus other eth0 stuff ....nothing about eth1

ps: I didn;t setup the box .... just started learning Linux this am ... appreciate the help!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 NIC Card Not Working! 3com 3c501 NIC. Mustard010 Linux - Networking 16 08-15-2007 03:22 AM
Inactive Network card mheymann Linux - Networking 1 11-04-2005 08:00 AM
NIC card 1_8_7 Slackware 10 02-18-2005 07:37 PM
nic card shania Linux - Newbie 7 10-31-2003 05:46 PM
NIC defaults to Inactive SelbyG Linux - Networking 4 01-24-2003 09:19 AM


All times are GMT -5. The time now is 12:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration