LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-01-2013, 10:34 AM   #1
LittleMaster
Member
 
Registered: Jun 2012
Posts: 100
Blog Entries: 1

Rep: Reputation: Disabled
NFS - unknown partitions problem in Ubuntu 12.04 Lucid Lynx


Ubuntu server fails to start up due to unknown partition exists in fstab .Required Suggestion

How can i check the unknown partition in fstab ? Whether any sort of package is available to find out unknown partition in fstab and remove them ?

Last edited by LittleMaster; 03-01-2013 at 10:37 AM.
 
Old 03-01-2013, 10:43 AM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,602

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
You need to show the fstab file.

NFS doesn't have partitions... which implies a typographic error in formatting.
 
Old 03-03-2013, 11:07 AM   #3
LittleMaster
Member
 
Registered: Jun 2012
Posts: 100
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Mounted the share /prod/apps/tomcat as first entry in fstab and then /prod/apps , /prod.While server rebooted Since /prod/apps/tomcat is being a first entry in fstab fails to load,Since it missed /prod/apps & /prod.How can i scan such parameter.

How can i define the linux to mount as / first , /prod second . /prod/apps third, /prod/apps/tomcat fourth.Even fstab mounting order is wrong

#cat /etc/fstab

/dev/hda2 / ext2 defaults 1 1
/dev/hdb1 /home ext2 defaults 1 2
/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
/dev/fd0 /media/floppy auto rw,noauto,user,sync 0 0
proc /proc proc defaults 0 0
/dev/hda1 swap swap pri=42 0 0
semantic:/prod/apps/tomcat /prod/apps/tomcat nfs defaults 0 0
semantic:/prod/apps/ /prod/apps/ nfs defaults 0 0
semantic:/prod/ /prod/ nfs defaults 0 0

 
Old 03-03-2013, 12:09 PM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,869

Rep: Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247
The file you need to edit for nfs is /etc/exports. Not knowing exactly what you are trying to do, the only thing I could suggest is to use the Search function on the upper right of this page for nfs, /etc/exports file as there are numerous threads on nfs.
 
Old 03-03-2013, 07:19 PM   #5
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,602

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
If it isn't mounting properly, then systemd is screwing up again.

You can try adding the option "_netdev" (as in "defaults,_netdev") to see if that helps. It is supposed to tell systemd that the mount requires the network to be functional before it attempts to mount. The problem is that systemd has poor information as to whether the network IS functional.

It assumes it is ready when NetworkManager starts... unless there is also "NetworkManager-wait-online.service" is also enabled... but then it depends on NetworkManager to know when the network is ready... and if the network depends on DHCP, that also may be incorrect.

systemd is over designed, and somewhat stupid at the same time.

And very poor at handling complex networks with more than one interface (I had to give up on it entirely because it would screw up the default route depending on which interface it brings up first).

Last edited by jpollard; 03-03-2013 at 07:21 PM.
 
Old 03-03-2013, 08:37 PM   #6
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
The /etc/exports file will be on the server serving out these shares. Note also that you can only mount those which are being explicitly exported; you can't just specify sub-paths just because you want a separate mount of each one.
IOW, check with the server and match them.
Also, for debugging purposes, use the noauto option on the client in fstab and mount them manually.
 
Old 03-04-2013, 11:56 AM   #7
LittleMaster
Member
 
Registered: Jun 2012
Posts: 100
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
I have not given more information at previous post .Adding some more info

Nas Server -Reboot 00:00:00
Nfs client -Reboot 00:00:00

Nas1 :Bringed up at 00:10:00 /prod/apps/tomcat -->Nas1
Nas2 :Bringed up at 00:11:00 /prod/apps --> Nas2
Nas3 :Bringed up at 00:12:00 /prod -->Nas3 .Since Nas3 up at 00:12 .Due to Nas2 & Nas1 mounting fails since it could not found nas1 mounting /prod mounted take place


We have maintanence take place on all server on every month 00:00:00.At these period we rebooting Nas Server & nfs client.Due to nfs client fails to loads due to Nas Server takes some more time to get turned on .


I'm looking for failover attempt to be taken for these mounting in fstab.I tried of using defaults_netdev.But no success at all.

nas1:/prod/apps/tomcat /prod/apps/tomcat nfs defaults,_netdev 0 0 --->whether there is options like Sleep (or) failover time attempt which i can mentioned over in fstab .

nas2:/prod/apps/ /prod/apps/ nfs defaults,_netdev 0 0
Quote:

I tried out below commands in fstab .But no success at all
nas3:/prod/ /prod/ nfs defaults,_netdev fetchattempts=10,sleep=10 0 0

mount -t nfs -o backupvolfile-server=volfile_server2,fetchattempts=2,log-level=WARNING,log-file=/var/log/failover.log semantic:/prod/apps/tomcat /prod/apps/tomcat

Last edited by LittleMaster; 03-04-2013 at 12:34 PM.
 
Old 03-04-2013, 03:38 PM   #8
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,602

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
"defaults,_netdev fetchattempts=10,sleep=10" needs a comma after _netdev
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with event sounds in ubuntu lucid-lynx. (may be related to canberra-gtk-play) vhasun Ubuntu 2 11-28-2013 01:02 PM
LXer: Puppy 5.1 codename Lucid is out- Now is compatible with Ubuntu 10.04 Lucid Lynx package LXer Syndicated Linux News 0 08-15-2010 03:20 PM
IPv6 problem(ubuntu lucid lynx)? djstava Linux - Networking 0 06-01-2010 09:59 PM
LXer: What’s New in Ubuntu 10.04 Lucid Lynx LXer Syndicated Linux News 0 04-29-2010 04:10 AM
LXer: 15 Beautiful Wallpapers from Ubuntu Artwork Pool for Ubuntu 10.04 Lucid Lynx LXer Syndicated Linux News 0 02-23-2010 01:11 PM


All times are GMT -5. The time now is 10:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration