LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-06-2006, 11:39 PM   #1
Chundo
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Rep: Reputation: 0
NFS shareing doesnot work.


Gurus,
I am trying a NFS file share between a PC104 (client) embedded PC, and desktop(Server) linux, both are running Debain 2.4.27.

The Server has the following IP 192.168.0.101, client has an IP of 192.168.0.23.
I build the kernel for the client with nfs options.

When I try to share the nfs share by
mount -t nfs -o rw 92.168.0.101/home/myself /mnt/test,

following error happens.
locked_up: makesock failed error =-5

On the server side etc/export has been updated with the following

/home/myself 192.168.0.23/24(rw)

For your info, my SBC has a minimal root file system;
With following in /sbin Ping, chmod, ls, cp, kill, touch, rm, cat bash, mount, umount and ps.

Do I have to have more nfs related files on the client?, if yes; what other files have to be on the client.
Btw. Ping works good from both sides and I can telnet from client to server.

Thanks in advance.

Last edited by Chundo; 11-06-2006 at 11:46 PM.
 
Old 11-07-2006, 01:15 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
What do your logs tell you or indicate? Usually they're pretty verbose when attempting NFS mounts.
 
Old 11-08-2006, 09:11 PM   #3
Chundo
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Original Poster
Rep: Reputation: 0
when I looked at the server syslog I found following:

lpd restarted..
/etc/exports No ;sync' or 'async' assuming default behavior as 'sync'
installing knfsd
rpc.statd
statd running as root chown /var/lib/nfs/sm to choose different user
usr/sbin/cron CRON)INFO (pidfile fd =3)
usr/sbin/cron CRON)INFO (STARTUP) (fork ok)
usr/sbin/cron CRON)INFO (pidfile fd =3)

Regards
 
Old 11-09-2006, 08:54 AM   #4
linuxjamil
Member
 
Registered: Dec 2005
Distribution: Fedora Core 5, Sun Solaris 8
Posts: 122

Rep: Reputation: 15
Arrow

mount -t nfs -o rw 92.168.0.101/home/myself /mnt/test-----------------


i think u not make like this mistake.....but check it if it occurs.....92 it will be 192
 
Old 11-10-2006, 01:00 PM   #5
Chundo
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the reply. That was a typo in my initial thread, the IP address are setup as you suggested.
I think the problem is somewhere else. Since my root file system on the SBC is minimal, I do not have the nfs related deamons in my sbin, for instance portmap, rpc.locked etc. I copied those from my server to my client
with associated lib. but now when I run /sbin/portmap it complains about the GLIBc version conflicts.

Thanks and Regards.
 
Old 11-11-2006, 04:07 AM   #6
linuxjamil
Member
 
Registered: Dec 2005
Distribution: Fedora Core 5, Sun Solaris 8
Posts: 122

Rep: Reputation: 15
Angry samba

Plz differ between user and share level secirity in samba server.........................
 
Old 11-11-2006, 04:13 AM   #7
linuxjamil
Member
 
Registered: Dec 2005
Distribution: Fedora Core 5, Sun Solaris 8
Posts: 122

Rep: Reputation: 15
Wink Nfs

What i know in RedHat or Fedora is that i will get minimumm one instance of following daemons related to NFS

rpc.statd
rpc.lockd
rpc.mountd
rpc.portmap
rpc._______

when i verify my NFS while pressing the command rpcinfo -p.......but i dont know in debian what are commands which should be run to maintain a NFS connectivity...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GNU global source code tagging system doesnot work on cygwin! tuxfood Linux - Software 0 06-28-2006 05:50 AM
system-config-packages doesnot work in RHEL 4 tuxfood Red Hat 0 12-13-2005 01:19 AM
Sound doesnot work anshulkothari Slackware - Installation 1 02-01-2004 07:46 PM
modem ADSL from sapo (Portugal) doesnot work in Suse9.0 lepton Linux - Distributions 0 11-16-2003 01:54 PM
RHN9 - Gnome crash, KDE doesnot work vijlovely Linux - Newbie 2 07-13-2003 08:03 AM


All times are GMT -5. The time now is 02:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration