LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   NFS/Samba Ownership on Red Hat 6.3 (http://www.linuxquestions.org/questions/linux-newbie-8/nfs-samba-ownership-on-red-hat-6-3-a-4175439044/)

Stannley 11-27-2012 09:34 PM

NFS/Samba Ownership on Red Hat 6.3
 
Hi

I am experiencing an issue with NFS and/or Samba on Red Hat 6.3.

I have an NFS share mounted from our DEV machine to the QA machine called transfers. A user created a folder on the DEV machine via a Samba share and the permissions / ownership were set correctly on that machine.

On the QA machine the contents of the transfer folder have incorrect ownership - the user is correct but the group is incorrectly showing as nobody instead of domain users. See below:

Code:

drwxrwxr-x. 8 proivck    nobody        4.0K Nov 28 11:20 .
drwxr-xr-x. 5 proiv      domain users  4.0K Oct 29 11:34 ..
-rw-rw-r--. 1 proivck    nobody        221K Sep 13 10:01 aug2012.vpx
-rw-rw-r--. 1 simon.tann nobody        1.3M Oct 30 09:32 ccn_for_v7.vpx
-rw-rw-r--. 1 proivck    nobody        693K Oct 12 13:28 ccn_v7.vpx
drwxrwxr-x. 3 proivck    nobody        4.0K Sep  3 10:28 dev
drwxrwxr-x. 2 simon.tann nobody        4.0K Nov 28 09:18 lastimp
-rw-rw-r--. 1 proivck    nobody        662K Sep  3 10:29 npost1_from_qa2.vpx
drwxrwxr-x. 3 proivck    nobody        4.0K Sep  3 10:28 qa
drwxrwxr-x. 3 proivck    nobody        4.0K Nov 27 13:45 release
-rw-rw-r--. 1 proivck    nobody        221K Sep 13 10:32 sep2012.vpx
drwxrwxr-x. 2 proivck    nobody        4.0K Sep 12 15:32 shared_data
-rw-rw-r--. 1 proivck    nobody        725K Sep  3 10:28 taps8437.vpx
-rw-rw-r--. 1 proivck    nobody      1008K Sep  3 10:29 taps8459.vpx
drwxrwxr-x. 2 proivck    nobody        4.0K Sep  3 10:29 tmp

where proivck is a local user and simon.tann is my network user.

If I shown a file in the transfer folder to have the domain users group it does not return an error but remains as nobody.

I am able to create files in the transfer folder from windows explorer but cannot delete them afterwards and they have the nobody group.

Files I create in my home directoy via windows explorer are created with the correct group, as are files in other samba shares.

Does anyone know what to change and where to get the client machine to recognise the group correctly?

Cheers

Simon

shivaa 11-29-2012 07:48 AM

Simon, did you check, is there SGID set on transfer folder on QA machine? Once check permissions of transfer folder and see if there's "s" set in group's permission column on tranfer folder. Also check what's transfer folder's group.

Stannley 11-30-2012 12:14 AM

Quote:

Originally Posted by shivaa (Post 4839530)
Simon, did you check, is there SGID set on transfer folder on QA machine? Once check permissions of transfer folder and see if there's "s" set in group's permission column on tranfer folder. Also check what's transfer folder's group.

Hi Shiva

The permissions on DEV for the transfer folder are as follows:

Code:

drwxrwxr-x.  8 proivck domain users 4.0K Nov 28 11:20 transfer
As you can see, I have not set SGID.

Cheers

Simon

Stannley 11-30-2012 03:09 AM

I have gotten this working - it appears to have been a problem with the domain in idmap although I do not know why - both machines are in the same domain so I should not have had to override the default setting. I have now set the domain and it is working correctly.

Thanks

Simon


All times are GMT -5. The time now is 08:05 PM.