LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-03-2009, 10:15 AM   #1
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Rep: Reputation: 16
Nfs and thumbs.db:encryptable files


Hey there.
I have NFS share on my linux server.
When i access this share trough windows i see Linux made some files called "thumbs.db: encryptable".
Found a page telling me to use a -R option but not how or where to use this option.
Here you have the URL of that page.
http://prabhanjan-panigrahi.blogspot...1_archive.html
Done some google´ng but nothing usable came up
Anybody here who had the same problem and solved it ?
 
Old 10-03-2009, 04:55 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 209Reputation: 209Reputation: 209
Quote:
Originally Posted by Deluka View Post
When i access this share trough windows i see Linux made some files called "thumbs.db: encryptable".
It is not Gnu/Linux that creates these files. They are created by winblows when you access directories with images in them.

Use the search facility on your winblows box to find all thumbs.db files on the nfs share and delete them.

If I recall correctly, to stop these files appearing again disable the thumbnail caching option in winblows.
 
Old 10-03-2009, 09:12 PM   #3
ArfaSmif
Member
 
Registered: Oct 2008
Location: Brisbane Australia
Distribution: Always back to Fedora
Posts: 267

Rep: Reputation: 54
Windows makes these files - not Linux. Use the following command on Linux to find and remove all of these files :-

# find /path/to/nfs/share -name thumbs.db -exec rm -f '{}' \;
 
Old 10-05-2009, 01:52 AM   #4
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
Thanx for the feedback.
But still the problem remains.
When i move a complete dir from win to lin it happens again.
I don't think windows makes these files.
The names are illegal on NTFS.
So my quistion remains how makes these files and how can i stop it.
 
Old 10-05-2009, 02:00 AM   #5
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 209Reputation: 209Reputation: 209
They are created by winblows. These files are normally hidden on winblows. Change your folder options in winblows to unhide files and you will see them.
 
Old 10-05-2009, 02:09 AM   #6
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
Thx for the fast response Nexus
Just to make it clear the name is 'thumbs.db:encryptable'.
I now that windows makes the thumbs.db files but those are not the problem.
The problem is the ':' in the name 'thumbs.db:encryptable'. and those are only found in the NFS share.
From the creation time i see that there made even if no clients have mounted or accessed the share. And using a ':' is illegal under NTFS. So i have a hard time believing that windows would make these.

Last edited by Deluka; 10-05-2009 at 02:11 AM.
 
Old 10-07-2009, 01:34 PM   #7
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
Well i still have the same problem.
Also find out that windows7 those not allow that you disable thumb caching.
at least not in a normal way.
Those anybody have a idea ?
 
Old 10-07-2009, 01:42 PM   #8
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,336

Rep: Reputation: 231Reputation: 231Reputation: 231
NTFS sucks, it has a huge security hole with those multiable streams
to the point where i use fat32 when installing windows -- i dont need no virus lurking in the text files
 
Old 10-07-2009, 01:52 PM   #9
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
Well i really don't have the option to change all of my clients to Linux or Macos. So i'm stuck with windows. But like i said before i don't think that windows is to blame here. It those allot of stupid things but adding illegal symbols to a file name thats is even for MS way to stupid.
 
Old 10-07-2009, 03:55 PM   #10
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 209Reputation: 209Reputation: 209
Quote:
Originally Posted by Deluka View Post
But like i said before i don't think that windows is to blame here.
If you insist. Just google thumbs.db:encryptable and you'll see it's a problem that exists between winblows and network folders.

There's a solution here: http://social.technet.microsoft.com/...a-5b74dcf59c20 and another one here: http://www.velocityreviews.com/forum...tabledata.html and another one here (which you have to pay for to see the solution!!): http://www.experts-exchange.com/Othe..._21360103.html

There are many more postings about this issue should none of the above help.
 
Old 10-14-2009, 10:33 AM   #11
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
Well it seems like your right Nexus windows is making these files.
Windows uses these to keep information about what thumbs belong to withs file and where they the order is of the files on none fat/ntfs file systems.
Disabling the caching of thumbs fixed it.
Just one problem under win7 you don't have the option anymore to disable this. Under folder option that is.
After some looking around using google i found the next trick.

Find the following key in your reg. using regedit.
Code:
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
And change the value to
Code:
"NoThumbnailCache"=dword:00000001
Hope this post helps anybody else
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Permissions error while copying files on NFS, but only on some files caggles Linux - Networking 1 07-30-2009 03:17 PM
NFS error: sometimes unable to find the files at NFS-client machines samengr Linux - Server 0 09-01-2008 11:26 AM
View Tif files from Konquer? Thumbs? usaf_sp SUSE / openSUSE 3 06-19-2006 11:55 PM
Thumbs up for Suse 9.1 Wolfgang67 Linux - Distributions 18 08-05-2004 08:30 PM
winex - 5 thumbs up! kazuni LinuxQuestions.org Member Success Stories 8 06-05-2003 07:43 PM


All times are GMT -5. The time now is 01:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration