LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-07-2013, 05:19 PM   #1
Gandalf_PCHF
Member
 
Registered: Jan 2013
Location: Middle Earth
Distribution: Cinnamon
Posts: 109

Rep: Reputation: 0
Newbie with a question


I decided to join your fellowship, because I found a lot of posts geared to my searches were directed to this site, but the post dates were years old and a lot of the links were no longer valid. I am hoping that the expertise that created those posts is still here, because I need to access some of that knowledge.

I am a retired graduate engineer, but I am not a programmer. I used to work in the UNIX environment so some of the Linux language is in my brain, but very rusty.

I installed R4W (long story) on my new custom built i7 computer. Yea, I built it. I installed and am running Boinc.

I would like to have BOINC startup during reboot. I found a few references on this site, but the associated links no longer connected and the post usually referenced the info contained in the link.

If I have left off any needed info, please say so and I will provide it.

My second and most important is that BOINC doesn't seem to see my GPU. I have two EVGA GeForce GTX 650 1024MB GDDR5 DVI mHDMI Graphics Card.
I support WCG and the cancer research group uses CUDA to crunch numbers. I know because I have a second i7 with Win7 installed and it is crunching with it's two GPU like mad. I would like this i7 to do likewise. I check before I bought them and these two GPUs do support CUDA. So why can't BOINC see them?

Please help. I have gone to the end of my rope (knowledge). I need access to your brains. Remember I am not a programmer, so please break down any directions for me and do not assume I know what you know. Believe me, I don't.


PS - Is there a Spell Checker associated with this edit window? If so, how do I turn it on? If not, why not? I'm not an english major. At my age, I'm lucky if I remember how to spell my own name.


Thanks in Advance for taking the time to read my babble.

Gandalf
 
Old 01-07-2013, 05:38 PM   #2
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,632
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Quote:
Originally Posted by Gandalf_PCHF View Post
I installed R4W (long story) ... I would like to have BOINC startup during reboot.
R4W? That's a bit of an odd choice - I would have though a more mainstream Linux distro would be better supported. I can't find any docs for it on the web. Anyway, if you meant "I want BOINC to start automatically when the computer boots up", then have a look in /etc - do you have directories called e.g /etc/rc0.d ? Or does R4W use upstart, or systemd? If all else fails, you could put 'boinc' in our .xinitrc.

Quote:
My second and most important is that BOINC doesn't seem to see my GPU. I have two EVGA GeForce GTX 650 1024MB GDDR5 DVI mHDMI Graphics Card.
According to ArchWiki, https://wiki.archlinux.org/index.php...ects_using_GPU:

Quote:
If you want to use your GPU, you need the proprietary nvidia or amd drivers. For ATI/AMD Cards you also need Catalyst driver for stock kernel which you can get from AUR. For Nvidia, you also need the package opencl-nvidia located in extra.

In addition, the boinc user should be in the video group:

Code:
# gpasswd -a boinc video
The boinc user also needs to have access to your X session. Use this command to accomplish this:

Code:
xhost local:boinc
You may want to add that to a startup script.
The packages will have different names in your OS, but you should be using the proprietary driver, boinc should be in the video group and you should have run the 'xhost local:boinc' command.

Quote:
PS - Is there a Spell Checker associated with this edit window? If so, how do I turn it on? If not, why not? I'm not an english major. At my age, I'm lucky if I remember how to spell my own name.
Try a browser plugin, like https://addons.mozilla.org/en-us/fir...y-/?src=search for Firefox.

Elen síla lúmenn' omentielvo,

Last edited by Snark1994; 01-07-2013 at 05:40 PM.
 
Old 01-07-2013, 06:50 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,295

Rep: Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358
In addition to the above, you should find this a good tutorial for the cmd line
http://rute.2038bug.com/index.html.gz

To check your system, can you get into the cmd line aka cli, as root (admin) user and run the following and post the results
Code:
cat /etc/*release*

uname -a
 
1 members found this post helpful.
Old 01-09-2013, 10:25 PM   #4
Gandalf_PCHF
Member
 
Registered: Jan 2013
Location: Middle Earth
Distribution: Cinnamon
Posts: 109

Original Poster
Rep: Reputation: 0
BOINC doesn't seem to see my GPU.

I have two EVGA GeForce GTX 650 1024MB GDDR5 DVI mHDMI Graphics Card.

I support WCG and the cancer research group uses CUDA to crunch numbers. I know because I have a second i7 with Win7 installed and it is crunching with it's two GPU like mad. I would like this i7 to do likewise.

I check before I bought them and these two GPUs do support CUDA.
So why can't BOINC see them?
 
Old 01-09-2013, 10:59 PM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,131
Blog Entries: 2

Rep: Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833
As asked before, do you have the proprietary NVidia drivers installed?

Besides that, as far as I know, R4W is a distribution especially meant for use on legacy computers, which your machine is definitely not. I would recommend to use one of the more mainstream distros with a larger userbase and better support, like Ubuntu or Mint.
 
2 members found this post helpful.
Old 01-12-2013, 04:08 PM   #6
Gandalf_PCHF
Member
 
Registered: Jan 2013
Location: Middle Earth
Distribution: Cinnamon
Posts: 109

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TobiSGD View Post
As asked before, do you have the proprietary NVidia drivers installed?
Specifically, how do I do that?

Quote:
Originally Posted by TobiSGD View Post
Besides that, as far as I know, R4W is a distribution especially meant for use on legacy computers, which your machine is definitely not. I would recommend to use one of the more mainstream distros with a larger userbase and better support, like Ubuntu or Mint.
I have hear and I obey. I have changed to the Ubuntu 12.10.
 
Old 01-12-2013, 04:13 PM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,131
Blog Entries: 2

Rep: Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833
On Ubuntu 12.10 you can install the proprietary Nvidia drivers using the Additional Drivers program, which is integrated into the Software Sources program that can be found in the System Settings.
 
Old 01-12-2013, 05:00 PM   #8
Gandalf_PCHF
Member
 
Registered: Jan 2013
Location: Middle Earth
Distribution: Cinnamon
Posts: 109

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TobiSGD View Post
On Ubuntu 12.10 you can install the proprietary Nvidia drivers using the Additional Drivers program, which is integrated into the Software Sources program that can be found in the System Settings.
Been there, done that. I think. Don't know how to verify that the operation took.

I find myself backfilling a lot every time I learn something new. Which is a lot.
Thanks to the clarification. I'm sure I'll be back, when I run out of backfill and hit that brick wall.

Thanks...
 
Old 01-12-2013, 06:13 PM   #9
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Gnadalf PCHF You might want to look at this article. If you havent yet

http://www.dedoimedo.com/computers/u...al-nvidia.html

This one might be of interest too

http://www.omgubuntu.co.uk/2012/10/1...g-ubuntu-12-10

Good luck to you

Last edited by TroN-0074; 01-12-2013 at 06:15 PM.
 
Old 01-12-2013, 06:40 PM   #10
Gandalf_PCHF
Member
 
Registered: Jan 2013
Location: Middle Earth
Distribution: Cinnamon
Posts: 109

Original Poster
Rep: Reputation: 0
The first one is new. Will check it out.
Did the installs in the second link already, but thanks.
Thanks...
 
Old 01-12-2013, 08:11 PM   #11
Gandalf_PCHF
Member
 
Registered: Jan 2013
Location: Middle Earth
Distribution: Cinnamon
Posts: 109

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TroN-0074 View Post
I have just finished the procedures in the referenced URL.
Everything appeared to work with a little fudging, but that was forewarned.
However, the end result was a no go.

A little background. BOINC > WCG can use my GPUs via CUDA for Cancer research, however the GPUs have to be seen by the Boinc Manager. This is my second i7 that I am trying to use for this purpose. The first i7 runs under Win7. There is no problem with the Boinc Manager seeing the GPUs with Win7. All the modified files are in the correct places.

Is the Nvidia drivers the correct drivers for this purpose?
According to the referenced link, I thing they are. However, I am not the expert.
I just know it ain't working right.

I am still in need of expert assistance to make my CUDA capable GPUs work with the Boinc program correctly.

As always, I thank everyone who has assisted me to this point.

Last edited by Gandalf_PCHF; 01-12-2013 at 08:14 PM. Reason: typo
 
Old 01-12-2013, 09:26 PM   #12
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Well I dont really know how you have set up your video card, but in your signature you have EVGA Geforce GTX 650 for that video card this is the driver they suggest at the NVIDIA web site
http://www.geforce.com/drivers/results/52241

Remove the one you installed with the graphical tool
you can try to install it with these commands
Code:
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings
==================================================================================================== ========
OR

install the new driver by downloading the file from the above link, Once the donwload is done tur off your graphical display (Hit CTRL+ALT+F2 and login using your credentials.)
kill your current X server session by typing sudo service
Code:
sudo lightdm stop
remove any reminding of the old driver
Code:
sudo apt-get - purge remove xserver-xorg-video-nouveau
and go to your downloaded file like
Code:
 cd ~/Downloads
then type ls so you can see the files your have there
then to install the driver
Code:
sudo sh NVIDIA-Linux-x86_64-310.19.run
That is what I did in Ubuntu 12.04 but I didnt have any fancy set up with my nvidia card, on your signature says you have 2?

So I dont know if these steps are going to work for you. Good luck to you.

Last edited by TroN-0074; 01-12-2013 at 09:53 PM.
 
Old 01-12-2013, 10:04 PM   #13
Gandalf_PCHF
Member
 
Registered: Jan 2013
Location: Middle Earth
Distribution: Cinnamon
Posts: 109

Original Poster
Rep: Reputation: 0
Feedback:
This command...
sudo apt-get - purge remove xserver-xorg-video-nouveau
should read ...
sudo apt-get - purge xserver-xorg-video-nouveau


This command...
sudo sh NVIDIA-Linux-x86_64-310.19.run
produced...
ERROR: You appear to be running an X server; please exit X before
installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver
download page at www.nvidia.com.

Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find
suggestions on fixing installation problems in the README available
on the Linux driver download page at www.nvidia.com.

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Jan 12 19:57:03 2013
installer version: 310.19

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

nvidia-installer command line:
./nvidia-installer

Using: nvidia-installer ncurses user interface
-> The file '/tmp/.X1-lock' exists and appears to contain the process ID '2245' of a runnning X server.
 
Old 01-12-2013, 10:23 PM   #14
mreff555
Member
 
Registered: Sep 2011
Location: Philly
Distribution: Gentoo
Posts: 473

Rep: Reputation: Disabled
You should really consider switching to debian, redhat, or ubuntu. BIONIC is in all of their package managers and will install easy. There is also more documentation for all of these distro's. Based on what you are doing, I would imagine reliability would be an important factor.
I am pretty sure proprietary nVidia drivers are also in their package mangagers which you WILL need if you wish to make use of your cuda cores
 
Old 01-12-2013, 10:41 PM   #15
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
@ mreff555 He is Using Ubuntu 12.10

@Gandalf_PCHFF You need to turn 'Off' X server with the command

Code:
sudo service lightdm stop
or

Code:
sudo stop lightdm
then Ctrl+Alt+F2
log in with your credentials

then
Code:
sudo apt-get - purge xserver-xorg-video-nouveau
then
Code:
cd ~/Downloads
then
Code:
sudo sh NVIDIA-Linux-x86_64-310.19.run
once is done you can do
Code:
sudo service lightdm start
or reboot If it doesnt work you will know because you wont have a graphical interface the next session

Adding the PPA was the easiest way though, didnt work for you either?

Code:
 

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Last edited by TroN-0074; 01-12-2013 at 11:00 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache newbie question.. (very newbie question) tarballed Linux - Newbie 1 02-07-2003 08:41 PM
RE: Suse 8.0 hardware question {newbie question, pls help} Radiouk Linux - Distributions 2 06-04-2002 12:53 PM
RE: Samba question pls help {Newbie question} Radiouk Linux - Networking 4 06-03-2002 06:40 PM


All times are GMT -5. The time now is 06:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration