LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-04-2012, 07:25 AM   #16
chesh9
LQ Newbie
 
Registered: Sep 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled

As far as the setup goes, the optiplex box is hardwired into the router, and the laptop is connected via wifi...
 
Old 10-04-2012, 03:00 PM   #17
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,261

Rep: Reputation: 118Reputation: 118
Let's see now, You are trying to connect to Optiplex from outside?
If so, you need to configure NAT (aka PortForward) on the router.

Does your network look like this:
Code:
Your client's ---------  router ------------ Optiplex
and Internet
or is it
Code:
     Internet ------------ router ------------ Optiplex and client's, same network
Apart from that:
* To check a textfile, it's "cat /etc/hosts.deny"
* Have you tried mandyapenguin's suggestions in post #13?

Last edited by pingu; 10-04-2012 at 03:02 PM. Reason: Making it a tiny bit clearer
 
Old 10-05-2012, 02:37 AM   #18
arun5002
Member
 
Registered: Aug 2011
Location: Chennai,India
Distribution: Redhat,Centos,Ubuntu,Dedian
Posts: 549
Blog Entries: 5

Rep: Reputation: Disabled
HI CHESH

you have to use sudo before command


Quote:
chesh@ubuntu:~$ /etc/hosts.deny
bash: /etc/hosts.deny: Permission denied
Quote:
chesh@ubuntu:~$sudo /etc/hosts.deny
bash: /etc/hosts.deny: Permission denied
 
Old 10-05-2012, 02:40 AM   #19
arun5002
Member
 
Registered: Aug 2011
Location: Chennai,India
Distribution: Redhat,Centos,Ubuntu,Dedian
Posts: 549
Blog Entries: 5

Rep: Reputation: Disabled
You have to use sudo


chesh@ubuntu:~$ /etc/hosts.deny
bash: /etc/hosts.deny: Permission denied

chesh@ubuntu:~$sudo /etc/hosts.deny

Last edited by arun5002; 10-05-2012 at 02:44 AM.
 
Old 10-05-2012, 11:08 AM   #20
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,478

Rep: Reputation: 441Reputation: 441Reputation: 441Reputation: 441Reputation: 441
you need to be root to edit that file.

also are you on a LAN, or are you trying to come in via the WAN from the MS Windows computer to the Linux computer.

On Linux install ssh and sshd, run sshd. the daemon, NOT ssh the client. just because you can ssh out does not mean you can ssh in to the same Linux computer.

as Mint is a clone of Debian you can use apt-get to search:

Code:
# apt-get search ssh*
then as root ensure it is running:

Code:
# /etc/init.d/sshd start
double check that is the correct path/code for Mint, sorry im RH guy.

Once that is up and running verify that in your /etc/hosts you have the LAN IPscheme if you are on a LAN.

ex:

Code:
 # vi /etc/hosts

add:

192.168.1.   mylan
or something to that effect. restart ipfilter, then attempt to connect.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie question - ssh tunnels, putty and sooo much more chesh9 Linux - Networking 6 10-04-2012 02:32 PM
ssh tunnels question philosophia Linux - Newbie 2 01-29-2010 03:03 PM
question about VI/VIM and ssh via putty Lleb_KCir Linux - Software 6 06-25-2009 07:03 AM
An abstract question on port forwarding and ssh tunnels. uncle-c Linux - Newbie 1 11-03-2007 08:27 AM


All times are GMT -5. The time now is 12:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration