LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-29-2012, 06:37 AM   #1
chesh9
LQ Newbie
 
Registered: Sep 2012
Posts: 17

Rep: Reputation: Disabled
newbie question - ssh tunnels, putty and sooo much more


hi guys,

I think this forum may be the better place for this question

I am almost completely new to linux I have no experience of working in code, but am trying to teach myself using Google and related forums and have to say I am loving it so far!

Although I am now pulling my hair out trying to create a file server on Mint.

I have installed the latest version of Mint on to an old optiplex box that I want to use as a remotely accessible server purely as a dumping ground for all my photographs.

I have downloaded Apache2, a SSH client amongst loads of other packages that I have downloaded from articles found on google.

The optiplex box is hard wired to the router.

I am using putty on a windows laptop, and trying to connect directly to the optiplex box, but I cant establish a connection. In fact I dont even get the password box to appear, all I get is connection timed out error.

The Optiplex box running linux is able to connect to the net...

please can somebody help!! what am I doing wrong!!??

keep the replies simple please

kindest regards

chris
 
Old 09-29-2012, 09:06 AM   #2
kb2tfa
Member
 
Registered: Oct 2006
Location: Philadelphia PA
Distribution: Ubuntu 14.04
Posts: 48

Rep: Reputation: 7
for me i installed the ssh "server" on my box, and made sure it was running
sudo /etc/init.d/ssh start

from my putty i enter 198.192....etc for that box and it connects. It should just require the server installed on box and ssh running for it to work.

that's all i did in my case.
 
Old 09-29-2012, 09:11 AM   #3
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,287

Rep: Reputation: 120Reputation: 120
You need to install an ssh server on the optiplex box.
Do you hav a GUI on it? If so, use the "Package Manager" (I think that's the name, not on Mint myself right now).
If not, you need to attach a monitor & keyboard, log in as root, and "apt-get install ssh".
But maybe first check if it's installed but not started: in terminal
# /etc/init.d/ssh start (still not on Mint, should be the same command though).
 
Old 09-29-2012, 11:40 AM   #4
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,734

Rep: Reputation: 1264Reputation: 1264Reputation: 1264Reputation: 1264Reputation: 1264Reputation: 1264Reputation: 1264Reputation: 1264Reputation: 1264
duplicate of http://www.linuxquestions.org/questi...re-4175429577/
 
Old 09-29-2012, 08:46 PM   #5
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 7,715

Rep: Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458Reputation: 1458
Here is tutorial specifically oriented towards Mint.

http://www.jonathanmoeller.com/screed/?p=3781

Note that, when it tells you to install something, check first to make sure it's not already installed.
 
Old 09-30-2012, 02:34 PM   #6
chesh9
LQ Newbie
 
Registered: Sep 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
thanks for all your responses guys, will give it a try at work tomorrow and report back.
kindest regards

chris
 
Old 10-01-2012, 09:25 AM   #7
chesh9
LQ Newbie
 
Registered: Sep 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
followed the tutorial to the letter, and still no success just keep getting the same error message

I think I must have done something fundamentally wrong when setting up the originoal installation of Mint.
I am considering doing a complete re-installation and start from scratch unless anyone has any further suggestions.

regards

chris
 
Old 10-01-2012, 09:28 AM   #8
chesh9
LQ Newbie
 
Registered: Sep 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by kb2tfa View Post
for me i installed the ssh "server" on my box, and made sure it was running
sudo /etc/init.d/ssh start

from my putty i enter 198.192....etc for that box and it connects. It should just require the server installed on box and ssh running for it to work.

that's all i did in my case.
this command didnt work for me, just comes back with command not found ?
 
Old 10-01-2012, 09:30 AM   #9
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,287

Rep: Reputation: 120Reputation: 120
As I said, you need to install the ssh server.
Look at my first post - post nr 3 in this thread.

(frankbell's tutorial covered samba not ssh, maybe he accidentally gave wrong url?)
 
Old 10-01-2012, 10:03 AM   #10
chesh9
LQ Newbie
 
Registered: Sep 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
hi Pingu,

Thanks for your observations, I have found a similar step by step guide by the same person on ssh
have just followed it to the word and still no success, just the same old error message!

do you think i would have a better chance of success with a different version of linux?

and suggestions gratefully recieved

chris
 
Old 10-01-2012, 10:19 AM   #11
mandyapenguin
Member
 
Registered: Nov 2011
Location: India
Distribution: RedHat, Cent OS, Fedora, Debian, Ubuntu
Posts: 105

Rep: Reputation: Disabled
Quote:
Originally Posted by chesh9 View Post
this command didnt work for me, just comes back with command not found ?
Did you install openssh-server?
In server run
Code:
$ sudo apt-get install openssh-server
$ sudo /etc/init.d/ssh restart
In client run
Code:
$ ssh username@server_IP
If still you are facing same problem, make sure whether ssh port is opened in firewall.
Code:
$ sudo iptables -L -n
I don't have much experience with iptables rules in linux mint, though try these once
Code:
$ sudo iptables -I INPUT 1 -p tcp --dport 22 -j ACCEPT
$ sudo iptables-save
And then try
Code:
$ ssh username@server_IP

Last edited by mandyapenguin; 10-01-2012 at 10:25 AM.
 
Old 10-01-2012, 10:22 AM   #12
chesh9
LQ Newbie
 
Registered: Sep 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
thanks mandy,

I am running linux on the server, but windows on the client (assuming i'm using the correct terminology)

chris
 
Old 10-01-2012, 10:52 AM   #13
mandyapenguin
Member
 
Registered: Nov 2011
Location: India
Distribution: RedHat, Cent OS, Fedora, Debian, Ubuntu
Posts: 105

Rep: Reputation: Disabled
Quote:
assuming i'm using the correct terminology
If you are using putty or cygwin on windows then definetely you should be able to connect ssh server. I can't fingure out the problem with less inforamtion.
1) Are you able to connect in server itself using?
Code:
ssh username@localhost
2) Make sure whether ssh service is not denied in "/etc/hosts.deny" file,
3) make sure the settings in "/etc/ssh/sshd_config" file to ensure whether or not only particulare user or group is allowed.
4) if "/etc/nologin" file is exist in server then no one will be able to connect SSH server apart from root.
5) Is there any other firewall between client and ssh server. or both server and client in the same LAN/subnet, and pinging one another? explain your setup i.e wheris client and whereis server.

Last edited by mandyapenguin; 10-01-2012 at 10:59 AM.
 
Old 10-04-2012, 06:39 AM   #14
chesh9
LQ Newbie
 
Registered: Sep 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
mandy....



chesh@ubuntu:~$ sudo iptables -I INPUT 1 -p tcp --dport 22 -j ACCEPT
chesh@ubuntu:~$ sudo iptables-save
# Generated by iptables-save v1.4.12 on Thu Oct 4 12:33:29 2012
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT -p tcp -m tcp --dport 22 -j ACCEPT
COMMIT
# Completed on Thu Oct 4 12:33:29 2012

does that help you to help me?

chris
 
Old 10-04-2012, 06:40 AM   #15
chesh9
LQ Newbie
 
Registered: Sep 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
chesh@ubuntu:~$ /etc/hosts.deny
bash: /etc/hosts.deny: Permission denied
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie question - ssh tunnels, putty and sooo much more chesh9 Linux - Networking 6 10-04-2012 02:32 PM
ssh tunnels question philosophia Linux - Newbie 2 01-29-2010 03:03 PM
question about VI/VIM and ssh via putty Lleb_KCir Linux - Software 6 06-25-2009 07:03 AM
An abstract question on port forwarding and ssh tunnels. uncle-c Linux - Newbie 1 11-03-2007 08:27 AM


All times are GMT -5. The time now is 10:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration