LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   newbie question - ssh tunnels, putty and sooo much more (http://www.linuxquestions.org/questions/linux-newbie-8/newbie-question-ssh-tunnels-putty-and-sooo-much-more-4175429580/)

chesh9 09-29-2012 06:37 AM

newbie question - ssh tunnels, putty and sooo much more
 
hi guys,

I think this forum may be the better place for this question

I am almost completely new to linux I have no experience of working in code, but am trying to teach myself using Google and related forums and have to say I am loving it so far!

Although I am now pulling my hair out trying to create a file server on Mint.

I have installed the latest version of Mint on to an old optiplex box that I want to use as a remotely accessible server purely as a dumping ground for all my photographs.

I have downloaded Apache2, a SSH client amongst loads of other packages that I have downloaded from articles found on google.

The optiplex box is hard wired to the router.

I am using putty on a windows laptop, and trying to connect directly to the optiplex box, but I cant establish a connection. In fact I dont even get the password box to appear, all I get is connection timed out error.

The Optiplex box running linux is able to connect to the net...

please can somebody help!! what am I doing wrong!!??

keep the replies simple please

kindest regards

chris

kb2tfa 09-29-2012 09:06 AM

for me i installed the ssh "server" on my box, and made sure it was running
sudo /etc/init.d/ssh start

from my putty i enter 198.192....etc for that box and it connects. It should just require the server installed on box and ssh running for it to work.

that's all i did in my case.

pingu 09-29-2012 09:11 AM

You need to install an ssh server on the optiplex box.
Do you hav a GUI on it? If so, use the "Package Manager" (I think that's the name, not on Mint myself right now).
If not, you need to attach a monitor & keyboard, log in as root, and "apt-get install ssh".
But maybe first check if it's installed but not started: in terminal
# /etc/init.d/ssh start (still not on Mint, should be the same command though).

pan64 09-29-2012 11:40 AM

duplicate of http://www.linuxquestions.org/questi...re-4175429577/

frankbell 09-29-2012 08:46 PM

Here is tutorial specifically oriented towards Mint.

http://www.jonathanmoeller.com/screed/?p=3781

Note that, when it tells you to install something, check first to make sure it's not already installed.

chesh9 09-30-2012 02:34 PM

thanks for all your responses guys, will give it a try at work tomorrow and report back.
kindest regards

chris

chesh9 10-01-2012 09:25 AM

followed the tutorial to the letter, and still no success :( just keep getting the same error message

I think I must have done something fundamentally wrong when setting up the originoal installation of Mint.
I am considering doing a complete re-installation and start from scratch unless anyone has any further suggestions.

regards

chris

chesh9 10-01-2012 09:28 AM

Quote:

Originally Posted by kb2tfa (Post 4792508)
for me i installed the ssh "server" on my box, and made sure it was running
sudo /etc/init.d/ssh start

from my putty i enter 198.192....etc for that box and it connects. It should just require the server installed on box and ssh running for it to work.

that's all i did in my case.

this command didnt work for me, just comes back with command not found ?

pingu 10-01-2012 09:30 AM

As I said, you need to install the ssh server.
Look at my first post - post nr 3 in this thread.

(frankbell's tutorial covered samba not ssh, maybe he accidentally gave wrong url?)

chesh9 10-01-2012 10:03 AM

hi Pingu,

Thanks for your observations, I have found a similar step by step guide by the same person on ssh
have just followed it to the word and still no success, just the same old error message!

do you think i would have a better chance of success with a different version of linux?

and suggestions gratefully recieved

chris

mandyapenguin 10-01-2012 10:19 AM

Quote:

Originally Posted by chesh9 (Post 4794025)
this command didnt work for me, just comes back with command not found ?

Did you install openssh-server?
In server run
Code:

$ sudo apt-get install openssh-server
$ sudo /etc/init.d/ssh restart

In client run
Code:

$ ssh username@server_IP
If still you are facing same problem, make sure whether ssh port is opened in firewall.
Code:

$ sudo iptables -L -n
I don't have much experience with iptables rules in linux mint, though try these once
Code:

$ sudo iptables -I INPUT 1 -p tcp --dport 22 -j ACCEPT
$ sudo iptables-save

And then try
Code:

$ ssh username@server_IP

chesh9 10-01-2012 10:22 AM

thanks mandy,

I am running linux on the server, but windows on the client (assuming i'm using the correct terminology)

chris

mandyapenguin 10-01-2012 10:52 AM

Quote:

assuming i'm using the correct terminology
If you are using putty or cygwin on windows then definetely you should be able to connect ssh server. I can't fingure out the problem with less inforamtion.
1) Are you able to connect in server itself using?
Code:

ssh username@localhost
2) Make sure whether ssh service is not denied in "/etc/hosts.deny" file,
3) make sure the settings in "/etc/ssh/sshd_config" file to ensure whether or not only particulare user or group is allowed.
4) if "/etc/nologin" file is exist in server then no one will be able to connect SSH server apart from root.
5) Is there any other firewall between client and ssh server. or both server and client in the same LAN/subnet, and pinging one another? explain your setup i.e wheris client and whereis server.

chesh9 10-04-2012 06:39 AM

mandy....



chesh@ubuntu:~$ sudo iptables -I INPUT 1 -p tcp --dport 22 -j ACCEPT
chesh@ubuntu:~$ sudo iptables-save
# Generated by iptables-save v1.4.12 on Thu Oct 4 12:33:29 2012
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT -p tcp -m tcp --dport 22 -j ACCEPT
COMMIT
# Completed on Thu Oct 4 12:33:29 2012

does that help you to help me?

chris

chesh9 10-04-2012 06:40 AM

chesh@ubuntu:~$ /etc/hosts.deny
bash: /etc/hosts.deny: Permission denied


All times are GMT -5. The time now is 02:09 PM.