LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-01-2010, 03:35 PM   #1
bluesbru
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Rep: Reputation: 0
newbie needs help with networking


Hello, this is the first time I've tried using a forum of any kind, so please bear with me.

I just started using Ubuntu Linux and I can't ever see going back to, ahem, Windows. In Windows, however, I could get a couple computers to recognize each other following their "wizards" I'll admit I'm a little confused in Linux.

I have two Acer laptops running Ubuntu 10.04 and a Netgear hub. Right now I'm just trying to get the two computers to see each other, wired.

Both computers have Internet access. I've found the Network folder and "Connect to Server..." under Places, and "Network Connections" and "Network Proxy" under Preferences. I'm not getting much sense out of the help files. The Network folder only has "Windows Network" in it. In "Network Connections" I have one item, "Auto eth0" (both computers)

Do I add folders somewhere where they can be seen, or add permissions? I know the answer must be painfully simple, what am I missing?

Thank you for your time.
 
Old 10-01-2010, 04:02 PM   #2
jf.argentino
Member
 
Registered: Apr 2008
Location: Toulon (France)
Distribution: FEDORA CORE
Posts: 493

Rep: Reputation: 50
The WINDOWS directories sharing is called SAMBA in the linux world, just google for it to have more info, it's quite straightforward to set it under UBUNTU.
But be aware that you've got now real unixes system with a bunch of tools like rsync, scp, ssh... they could looks tough at first but once you've test them, you can't live without. Especially ssh, it permits to connect to a remote system, thus controlling your thousand and a half computers with just one keyboard...
 
Old 10-01-2010, 04:17 PM   #3
1467
LQ Newbie
 
Registered: Sep 2010
Distribution: slackware 13.1
Posts: 26

Rep: Reputation: 0
i recommend ssh try places > connect to network and switch it to ssh then type in the ip of the other computer
 
Old 10-01-2010, 08:33 PM   #4
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
For file/disk sharing, you can use either NFS or CIFS/SMB (MS) in Linux. There is also some perversion of other protocols built into some GUI tools, which allows you to access filesystems on other hosts. You can also connect hosts in other ways. You can login to one host from another, whereupon the commands you execute will run on that other host. There are also ways to move/copy files around from host to host.
Before anyone gets into too many details of specific methods, do you have a particular kind of 'connection' in mind?

--- rod.
 
Old 10-01-2010, 08:48 PM   #5
bluesbru
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Original Poster
Rep: Reputation: 0
It's just a simple home network, a router with a couple computers tied to it. Do I have to have one of the computers assigned as the host? How do I get the computer's ip? Is that the same as the the computer name?
 
Old 10-02-2010, 01:25 AM   #6
Bryanlee
Member
 
Registered: May 2005
Location: Honolulu, HI
Distribution: Ubuntu 10.04
Posts: 56

Rep: Reputation: 15
Your IP address can be found by opening a terminal and typing
Code:
ifconfig
You should see your ip address. It may look something like 192.168.1.1
 
Old 10-02-2010, 09:51 AM   #7
bluesbru
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Original Poster
Rep: Reputation: 0
OK, I tried that, on this computer I got:

bruce@lydia:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:26:2d:7f:96:37
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::226:2dff:fe7f:9637/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1166 errors:0 dropped:0 overruns:0 frame:0
TX packets:1396 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:347269 (347.2 KB) TX bytes:370620 (370.6 KB)
Interrupt:16

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:60 errors:0 dropped:0 overruns:0 frame:0
TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4528 (4.5 KB) TX bytes:4528 (4.5 KB)

wlan0 Link encap:Ethernet HWaddr 00:17:c4:e4:9b:9c
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


So, I take it that "inet addr:192.168.0.2" is what I'm looking for?

I tried what 1467 suggested, using the same number from the other computer, I got:

Cannot display location "sftp://192.168.0.3/"
Connection refused by server.

It has to be simpler than this. Why don't I have a "Linux Network" in my Network File Browser?
 
Old 10-02-2010, 11:07 PM   #8
Bryanlee
Member
 
Registered: May 2005
Location: Honolulu, HI
Distribution: Ubuntu 10.04
Posts: 56

Rep: Reputation: 15
If you are only interested in sharing files I would do the following.

1. Go to Places -> Connect to Server and fill in the info below.

2. Server = IP Address of target machine (username@192.168.1.2)
Port = 22
Folder = Folders you would like to share i.e. /home/user or maybe just /

3. I would check the "Add Bookmark" box and then name it accordingly. This bookmark will show up in "Places"

You can do this on both of your Ubuntu machines and by doing so you will have complete read and write access as is you were sitting in front of the computer.
 
Old 10-03-2010, 10:52 AM   #9
bluesbru
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Original Poster
Rep: Reputation: 0
I'm getting somewhere. Thank you Bryanlee for your help. I tried what you suggested and I got this message:

Cannot display location "ftp://anonymous%40bruce@192.168.0.3:22/home/bruce"
Error connecting: Connection refused

The other computer was on, I'm just making sure this doesn't turn into one of those computer tech jokes.

Let me make sure I have my facts straight. Where you say username, that means what I'm logged in as, in my case its bruce on both computers. The other computer's IP is 192.168.0.3, and this one is 192.168.0.2

From what I've read about ip addresses, 192.168 is the same on any home network and the last numbers are determined by your router. Just because I thought I might learn something, I turned on my old desktop. This thing is nine years old, it's dual boot with Windows XP and my last connection to Microsoft. I don't use it much. It's IP is 192.168.0.4, yes, I have to admit this, I just noticed, 2, 3 and 4 are lit up on my router.

So I tried the same thing with my old computer. Same message as before only with a 4 instead of a 3.

The service type was Public FTP, is that the default? I looked at the options, I noticed SSH was one of them. I tried that and got:

Cannot display location "sftp://bruce%40bruce@192.168.0.3/home/bruce"
Connection refused by server.

Let me add to a question I asked earlier. According to the help files, inside my Network folder I should have at least two objects, "Unix Network (NFS)" and "Windows Network (SMB)"

Like SSH, I noticed these were mentioned earlier. I have the windows thing on all three of my computers but the Linux or Unix thing is missing on all of them. How do I get the Linux/Unix thing?

Last edited by bluesbru; 10-03-2010 at 02:07 PM.
 
Old 10-03-2010, 02:21 PM   #10
Bryanlee
Member
 
Registered: May 2005
Location: Honolulu, HI
Distribution: Ubuntu 10.04
Posts: 56

Rep: Reputation: 15
I'm sorry I think I left a step out.

Go to "places" -> "Connect to Server"

Then select the drop down box and choose "SSH"

In the server box you will enter the user name that you would log onto that computer with if you were sitting in front of it, followed by the ip address. It should look something like "username@192.168.1.2"

Everything else should be the same. I posted an image of what it should look like just to make it easy. If you still have problems after that we can go from there.
Attached Thumbnails
Click image for larger version

Name:	SSH_Connect.png
Views:	4
Size:	27.4 KB
ID:	4755  

Last edited by Bryanlee; 10-03-2010 at 02:31 PM.
 
Old 10-03-2010, 10:07 PM   #11
bluesbru
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Original Poster
Rep: Reputation: 0
I tried that. That's why asked about the service type. I tried both Public FTP and SSH.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie Networking stupeas Linux - Newbie 2 02-04-2007 11:13 AM
Help Newbie Networking rmsat Linux - Networking 2 06-29-2004 05:26 PM
Newbie Networking Lodnod Linux - Newbie 4 03-16-2004 01:20 AM
Networking Newbie Nice Guy Eddie Linux - Networking 1 05-04-2003 02:35 AM
Newbie Networking!!! GeeMoney Linux - Networking 2 11-25-2001 01:55 AM


All times are GMT -5. The time now is 04:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration