LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-05-2002, 10:19 AM   #1
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Slackware + Debian
Posts: 191

Rep: Reputation: 16
Talking Newbie having trouble/fun.



Hello, my first post. sorry for any typos, im trying to explain as much as possible so somebody might be able to help.

I got slackware 8.1 off a coverdisk. PC-didnt want to boot from it (although it booted from old redhat6), so i made boot disk (usb.i) and the 5 installation disks and the rescue disk. So I managed to install it OK i think... here's a installation and system hardware summary:

AMD k6-2 500mhz, Microstar5169 mbd, 192mbSDRAM, ELSA Gladiac 311-tv-out (uses GeForce2mx200 chip) AGP 32Mb SDR, PCI SB Live! Value, D-Link DE-220 ISA Network card, IDE0=80Gb HD (Win98SE in 3 partitions 40,20,20Gb), IDE1=8.4Gb HD (Linux), IDE2=52xCreativeCD-ROM,IDE3=RICOH CD Writer.
mouse=ms intellipoint explorer optical USB (thats why i used 'usb.i' rather than 'bare.i' boot disk). Also i just noticed i had an USB scanner plugged in during installation, will this have not helped with regard to the mouse being usb?

So I made the 8.4Gb disk to be linux with 256Mb linux swap, 4Gb root bootable linux native, rest ~4.2Gb /home linux native. both the last 2 being ext2 file system (is this a similar thing in nature to fat16/32 etc.?). linux installation saw the win disks fine and I allocated them names. I then made two boot disks during the install (i guessed they are identical, just having 2 is more safe yes?).

during install there was no option of any geforce cards anywhere.

the first reboot of the system was the 'aw naw!' moment. I changed the boot device in the BIOS to IDE1 instaed of IDE0 to boot from the linux disk, but when it booted the disk the screen was filling up with lots of '40's, scrolling down the screen. upon rebooting and hitting 'pause' i saw that at the start it all began during LILO bootup as it only got this far:
L 40
and then continued to make more 40's thus:
L 40 40 40 40 40 40 40 40 etc.

that was that. so then i booted using the boot disks created during installation. NOTE: i chose to use the kernel from the floppy i booted with, i.e. usb.i as i thought it the right choice. once booted with the disk, i got in as root and made my password and then tried to load X using the startx command. but it was none to happy and didnt work.

PS: how do make anoother non-root user. please could somebody tell me where to get the linux commands(move around the directoried edit etc. - i was decent with dos, but that not much use), and how to use them. i managed to find the 'help' command

so X didnt want to start KDE. i went through 'xf86config' a few times but it not help.

also choosing the mouse and keyboard etc. is a 'bus mouse' a usb mouse or should i use MS intellipoint? im from UK, so i couldnt see an obvious choice - during installation i chose US perhaps and it got everything right but the pounds sign didnt exist (keys next to return key mapped correctly, only sign missing).

one other question: with windows its 'good' (ie make things more likely to work) to install it with say only the video card in as it prevents pnp scanning to get confused... and then install them one at a time after initial system in. is this the same with linux, as i just kept everything in during installation?

Thanks to anyone who reads this far! i cant think of any other useful details, but PLEASE SOMEBODY HELP ME GET IT WORKING! feel free to ask me for more details.
thanks again.
 
Old 10-05-2002, 12:59 PM   #2
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Welcome to LQ!

If a bootable, maybe not yours, CD doesn't boot, the first thing to check is BIOS.

I can see you did your homework before moving forward.

Dividing a HD into pieces for Linux is good IF you know how to resize them without destroying them. I don't. So what I do is to make a 5gig for Linux and use a FAT32 as My Doc.

Yes you should connect all devices and turn them on during install. Linux will detect them or not.

I don't think you need swap. 128MB+ RAM is plenty. If you do, you should get 384MB (192 x 2).

2 boot discs are redundant. Since once your Linux is set, you would need one very rarely. You can boot the CD and fix Linux.

adduser username
passwd username

I'd recommend you do it in KDE/Gnome with Kuser, etc. cuz if you don't set the shell, you won't be able to log in. That happened to me once.

On Linux, the installer installs all drivers/modules at once. If you do it seperately... you could take over the mod's position.

xf86config worked for me. Choosing whatever mouse is irrelevant. Fact is your mouse probably doesn't work without tweaking. I choose the first mouse and after, I edit

pico /etc/X11/XF86Config

for my MS Wheel Mouse Optical on PS/2. If you could, remove the USB converter and plug it in PS/2. It'll save you a LOT of trouble.

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/psaux"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"
Option "Emulate3Buttons" "no"
EndSection

That's for your USB mouse.
 
Old 10-06-2002, 05:23 AM   #3
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Slackware + Debian
Posts: 191

Original Poster
Rep: Reputation: 16


Thanks for that reply jetblackz. I'll maybe put my mouse onto PS/2 to save hassle, but i've had a few more ideas about what my problem might be... but i could still do with any help if anyone knows more.

OK. Is putting LILO onto the secondary hard disk just stupid? To install linux I had my bios det up to boot from the master IDE0 (80Gb windoze), but booted from the bootdisk i made and went on and installed linux including LILO. THEN, when it said it wanted to reboot I went into the BIOS and made the first boot hard disk to be the 8Gb linux one so that it would initiate LILO. was this stupid? I did this because my other hard disk needs to use the Western Digital EZ-BIOS (I think WD as great as they even provide cool tools that even wipe a whole disk, very handy!) boot loader as my BIOS doesn't like more than 64Gb, and I don't want LILO to interfere with it as I want to keep that disk 'good' (i.e. i don't want to seriously mess it up) as i may want to use it in a new computer should i ever build another.

Did that make sense? so I'm basically needing help with LILO and whether or not my setup was a bad idea.

Thanks.

PS: whilst trying to reinstall Linux i accidentally deleted absolutely everything on my primary win80Gb disk partition... only noticed my mistake when i saw that my final partition had ten times more than expected... seeing as my two hard drives are 8Gb and 80Gb it was an easy but none-the-less annoying mistake to make. i spent a few hours putting windoze dack together. D'OH!
 
Old 10-06-2002, 08:17 AM   #4
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
No problem.

No, that's not stupid. That's what I do. I put lilo on 2nd disk. I let NTBOOTLOADER take over at bootup.

But I don't play with BIOS (fire). I set it up to boot from hd1, 2, so forth. So I know exactly what is on hd1, 2, so forth. No HD swapping.I haven't lost a bit of Windows info since losing a few installs. Learned my lesson. Always manually partition HD's.

For your situation, you install and boot Linux the way your BIOS is setup at the time. If it boots from hd2, make sure it does before you boot Linux. Install lilo on disk1, from your BIOS' point of view. Your disk2 is disk1. Make a boot floppy. That's it.

The problem you're experiencing is that you THINK disk1 is disk2 and disk2 is disk1. That's, you think you installed lilo on disk2, 8gb, but actually you installed lilo on disk1, 80gb. That's what the whole confusion is.

lilo doesn't inference with Windows. It's usually human mistake. Computers do what you tell them.

Buy Norton Ghost at all costs. It takes less than 10 minutes to bring Windows back at the stage you backed it up, preferably, after drivers and major apps installs.
 
Old 10-15-2002, 09:57 AM   #5
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Slackware + Debian
Posts: 191

Original Poster
Rep: Reputation: 16
ok so ive got it in and a nice 1024 console with tux sitting at the top looks nice but i cant load x by typing startx. i have an ELSA gladiac 311 nvidia geforce2mx tv-out fraphicscard so i know its the problem but how do go about getting it to work? i would appreciate step by step instructions as im a newbie... but i managed to install slackware 8.1!!!!1 after multiple re-re-re-re-re-partitioning shinanigins and much formatting. i use a floppy to boot it which is nice enough... im so proud i got this far, i just want to get kde up and running. sniff . also ive got another partitipon that lilo doesnt give me the option of booting from, ive got it formattd via format inc. /s sytem files but it only gives me the option to load hda1'fat32' and hdb3'linux' whereas i also want to be able to load hdb1'fat32'. any help will be much appreciated. thanks.

Last edited by Mr Marmmalade; 10-16-2002 at 09:57 AM.
 
Old 10-15-2002, 10:59 AM   #6
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
http://jetblackz.freeservers.com/Con...ackware81.html

Did you install any OS Windows on hdb1'fat32' ? If not, you shouldn't put an option in lilo. If it's just a storage space, you can link it there. Read the page above. Includes all instructions.
 
Old 10-16-2002, 09:56 AM   #7
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Slackware + Debian
Posts: 191

Original Poster
Rep: Reputation: 16
i didnt install the os on that hdb1fat32 bit i just copied the system filed after formatting it which shoulkd make it bootable, i think ill be able to sort this out once ive got into X. ONCE I GET INTO X! thats the thing. i got the latest nvidia 3123 drivers the NVIDIA_kernel-1.0-3123.i386.rpm (i had to compile this from an src version... which was cool), and ive got the respective GLX file too. my latest problem is that when i try to actually put the driver in using this line:
rpm -ivh /usr/src/rpm/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm
it gave the following error:
error: failed dependencies
kernel >= 2.2.0 is needed by NVIDIA_kernel-1.0-3123
rpm >= 3.0.4 is needed by NVIDIA_kernel-1.0-3123
/bin/sh is needed by NVIDIA_kernel-1.0-3123
/bin/sh is needed by NVIDIA_kernel-1.0-3123
/bin/sh is needed by NVIDIA_kernel-1.0-3123
im guessing that translated into part of my system being an older version than required. i was proceeding as per the nvidia readme file. there was a bit about making sure that:
"first ensure that the headers foryour kernel are installed."

so how should i proceed? i have the kernel 2.4.18 if that helps? that confuses me as the above error said it wanted kernel >=2.2.0, which mine clearly is. the rpm version i have i do not know but i would assume that my rpm may also be new enough. any thought on how to get these drivers in? i hadnt got round to doing the GLX file as the instruction were for doing the kernel first so i'd assume it neede to be in prior to the GLX as it'd link with it but my GLX is already in compiled rpm form as it was much smaller im assuming: i didnt even noting i was downloading a src at the time but i managed to compile it. wayhey!
thanks again jetblackz ive got that website and will look at it.
 
Old 10-16-2002, 10:29 AM   #8
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Slackware + Debian
Posts: 191

Original Poster
Rep: Reputation: 16
Ah, maybe i rebuilded the source wrong.i first did:
rpm --rebuild /Max4o8FAT32/nvidia/NVIDIA_kernel-1.0-3123.src.rpm
maybe doing:
rpmbuild --rebuild /Max4o8FAT32/nvidia/NVIDIA_kernel-1.0-3123.src.rpm
instead. although i didnt see any error when i did the first command and it rattled off a lot of stuff on the scteen looking as if it was doing whatever it was meant to be doing and told me where it put the built kernel file so i could do the next step.
 
Old 10-16-2002, 12:58 PM   #9
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Anytime.

I wouldn't learn to run before I learn to walk. You know what I'm saying? If it's your first time to install Slack, use whatever drivers/modules come with it. xf86config has nVidia driver. It's fine. You're not running UT 2003, are you? Just web browsing, email, and word processing we don't need the "bleeding-edge" drivers. BTW, the new drivers will eventually be included in the next X.

If you can get it up and running with default drivers, then you might want to fiddle with it more.

BTW, what file system did you copy to that fat? Windows 98? Might work. You still have to run fdisk/mbr which may destroy lilo.
 
Old 10-17-2002, 09:11 AM   #10
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Slackware + Debian
Posts: 191

Original Poster
Rep: Reputation: 16
i didnt see any suitable drivers for my graphics card when the installation gave me the option. i think i came across some info for nvidia geforce cards on the net the other day saying ut was option 322 or something on the list?
mines an ELSA Gladiac 311 tv-out GeForce2mx200 32mb AGP.
who said i only want to do word processing on my machine! thats crazy talk! yeah well quake2 and glquake1 i'd rekkon would work on reference drivers you say xfree86 come with so i'll give 'xf86config' another try. sigh.

i don't want to go anywhere near my computer with the letters F..D..I..S..K.../...M...B..R...! aaaaaaah, ive had enough of harassing MBR.

when you said 'X' did you mean a new version of xfree86?

ive been putting slack8.1 into my computer for nearly3 weeks and i've never yet seen the GUI, although bash looks smart. please could you confirm the geforce number i gave above? sorry for the long posts, thanks for your help and time jetblackz .
 
Old 10-17-2002, 10:41 AM   #11
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
I'm reading you loud and clear. I understand you're gonna play games on Linux.

Look, "ive been putting slack8.1 into my computer for nearly3 weeks and i've never yet seen the GUI" is the first thing you've to solve. So my suggestion is to use built-in driver. Once you see X, you'll want to upgrade driver. It's not impossible. 322 is correct. Mine is gf2MX 400. I use the generic nVidia driver and it's pretty fast.

Don't worry about messing up mbr, cuz it's just "lilo" to fix it. Linux can't repair Windows. Only Windows can. So use W98 to fix itself and then run lilo again to write bootloader.

bash is what most people use.
 
Old 10-18-2002, 07:58 AM   #12
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Slackware + Debian
Posts: 191

Original Poster
Rep: Reputation: 16
it works it works! kde gui looks cool! at long last,thanks for the help. now i need to figure out how to change the desktop from being huge... i have to scroll around it as i can only see about 1/4th of it at a time.the crtl+alt+'-' or '+' doesnt seem to do anything. man kde looks nice, anti aliasing and transparency, that 322 thing sorted out all my woes! i even mamaged to play a cd! but my sound card isnt up yet : sb live! player, that will be my next linux quest.
 
Old 10-18-2002, 08:43 AM   #13
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
"kde gui looks cool!"

well... kde looks like Windows. personally i think there's a distinct difference...
 
Old 10-18-2002, 10:53 AM   #14
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Congratulations! You're now accepted by the Jedi Council.

What you're seeing is called virtual screen/desktop. Nobody needs it since today's monitors are big enough to hold everything. You can turn it off

su
cp /etc/X11/XF86Config /etc/X11/XF86Config.bak
pico /etc/X11/XF86Config (careful pico tends to break lines improperly)
scroll to Section "Screen"
remove all resolutions you don't want. I leave only 1024x768 there.
logout, restart X or reboot

For sound, check out

http://jetblackz.freeservers.com/Con...ackware81.html

Your driver is in the rc.modules.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fun newbie guide. tripmix General 2 01-30-2005 10:45 AM
The fun of being a newbie... (help needed) abethepunk Linux - Newbie 11 07-21-2003 06:05 PM
Newbie mail trouble Neorio Linux - Networking 0 06-05-2003 03:03 AM
Newbie got into some trouble, Help?? TeknoPhreak Linux - Newbie 20 04-01-2003 09:05 AM
Newbie in trouble! TurboThy Linux - Newbie 6 05-15-2002 06:10 PM


All times are GMT -5. The time now is 08:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration