LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-09-2004, 01:11 AM   #1
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
Newbie: ext3 permissions


I've searched the forum over and over, but people only ask about how to read/write to DOS partitions. I created an ext3 partition (hdd1), and everything is fine when I am in root. But I want all users to have read/write access to this. Do I need to make changes in the fstab (i.e. not defaults), or do I chmod it. What do I do? I'm sure this has been asked a million times, but I can't find it from my searches.
 
Old 02-09-2004, 01:26 AM   #2
Quis
Member
 
Registered: May 2001
Location: Germany, Süd-Baden
Distribution: Gentoo
Posts: 139

Rep: Reputation: 15
please post your fstab line for hdd1 here
 
Old 02-09-2004, 01:28 AM   #3
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Original Poster
Rep: Reputation: 30
Here it is:
/dev/hdd1 /mnt/hdd1 ext3 defaults 1 2
(formatting is obviously different here than in the actual fstab file)
 
Old 02-09-2004, 01:42 AM   #4
Quis
Member
 
Registered: May 2001
Location: Germany, Süd-Baden
Distribution: Gentoo
Posts: 139

Rep: Reputation: 15
change it to:
/dev/hdd1 /mnt/hdd1 ext3 defaults 0 0
should fix it
 
Old 02-09-2004, 02:56 AM   #5
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Original Poster
Rep: Reputation: 30
no dice, I still can't access it as a regular user.

I'm wondering if I need to chmod it, because it does seem to be mounted alright. Does anybody out there know what I should do?
 
Old 02-09-2004, 03:26 AM   #6
Quis
Member
 
Registered: May 2001
Location: Germany, Süd-Baden
Distribution: Gentoo
Posts: 139

Rep: Reputation: 15
ok, if your drive is mounted with the old settings (/dev/hdd1 /mnt/hdd1 ext3 defaults 1 2) you have to remount it with the settings i've posted.

if you've remounted it, 'mkdir' (as root) a new folder on this device and 'chown' it to your preferred user. (check read/write permissions also)

after this:
change to your user, 'cd' to your new folder on hdd1 and make a new or dir or 'touch' a new file.

this should work
 
Old 02-09-2004, 11:51 AM   #7
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Original Poster
Rep: Reputation: 30
This doesn't work. Aren't these last columns pretty useless? I've been researching this, and I understand that they are only a way to back up the the filesystems. Are you sure this is what needed to be done? Has anybody else done this in RedHat 9, or another version of RedHat?
 
Old 02-09-2004, 12:01 PM   #8
jazernorth
Member
 
Registered: Jan 2004
Location: Green Bay
Distribution: RedHat 8.0, LFS-5.0
Posts: 100

Rep: Reputation: 15
Do this:

Set /etc/fstab line as:
Code:
/dev/hdd1 /mnt/hdd1 ext3 defaults 0 0
Then:
Code:
su (as root)
chown user:group /mnt/hdd1
chmod 770 /mnt/hdd1 
exit
Then:
Code:
ls -l /mnt/hdd1
Should show you permissions set for all /mnt/hdd1.

Now, you might want to 'mkdir' as something else to mount the hdd1. For example:
Code:
su
mkdir /var/<newdrive>
chmod 770 /var/<newdrive>
exit
Edit /etc/fstab:
Code:
/dev/hdd1 /var/<newdrive> ext3 defaults 0 0
Then:
Code:
umount /mnt/hdd1
mount /var/<newdrive>
exit
Either of those will make it work for you.

Enjoy.

JN
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting ext3 partition with rw permissions for non-root user ilyushin Linux - Newbie 5 06-27-2005 07:58 AM
User write permissions on ext3 partition darin3200 Linux - General 4 05-30-2005 08:27 AM
knoppix mount write permissions ext3 baird LinuxQuestions.org Member Success Stories 1 12-20-2004 01:59 PM
Multible newbie questions (pppd, ext2 vs ext3, and random inode read errors) (Slack10 Nicolae Slackware 8 08-28-2004 04:51 PM
r/w permissions on a mounted ext3 hard drive harperonline Linux - Hardware 1 03-19-2003 05:22 PM


All times are GMT -5. The time now is 09:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration