LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-04-2005, 02:44 PM   #1
boosted_skip
LQ Newbie
 
Registered: Mar 2005
Location: Norfolk, UK
Distribution: Red Hat 9.0
Posts: 4

Rep: Reputation: 0
Newbie - display driver problem


Hello peeps, absolute total UNIX and Linux newbie here, limit of my current knowledge is being able to use VI lol

I have installed Red Hat 9.0 ok and can get into the main window no problem. Decided to have a go at updating the video driver to try and get something better than 800x600... Got the latest Linux drivers for my MSI Gforce FX 5500 from NVidias website, followed the instructions for editing the XF86Config file and it was all going well until I tried to restart X, I get the following error....

No devices detected

Fatal Server Error:
No screens found

I have read as much as I can and am now totally stuck! From what it seems from others problems I need to show you my XF86Config file, well I have checked that Load "glx" was present and it was - didnt find Load "drv" or Load "GLcore" as the Nvidia readme said I may or may not and only thing I changed from the bare install was

Driver "vesa" to Driver "nvidia"

Havent specified a monitor to use, is this neccessary? From what I have read it looks like I need to check if "agpart" is loading and it isnt, tried running modprobe agpart and got the following error

modprobe: Cant locate module agpart

Can anyone offer me any ideas?

Cheers

Skip
 
Old 03-04-2005, 03:15 PM   #2
GlenX
Member
 
Registered: Feb 2005
Location: United Kingdom
Distribution: Fedora Core 3 -
Posts: 37

Rep: Reputation: 15
Hi boosted_skip,


I had a simuler problem once, my sulotion was to add 'nvidia' to the modprobe file, i have forgot where this file is located tho, anyone else know?

GlenX
 
Old 03-04-2005, 03:20 PM   #3
boosted_skip
LQ Newbie
 
Registered: Mar 2005
Location: Norfolk, UK
Distribution: Red Hat 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the reply Glen. I can run "modprobe nividia" and it doesnt give me any errors and when I check it with "lsmod" I can see it at the top of the list.... Its only modprobe agpart that doesnt run, and as I have an AGP card I guess that needs to run?

Really done know what to do!
 
Old 03-05-2005, 05:30 AM   #4
boosted_skip
LQ Newbie
 
Registered: Mar 2005
Location: Norfolk, UK
Distribution: Red Hat 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
Bump - can anyone help me??
 
Old 03-05-2005, 01:22 PM   #5
mugstar
Member
 
Registered: Jun 2004
Location: Scotland
Distribution: Anything that'll install...
Posts: 305

Rep: Reputation: 30
The module you need is agpgart (note the extra 'g').
 
Old 03-05-2005, 03:01 PM   #6
boosted_skip
LQ Newbie
 
Registered: Mar 2005
Location: Norfolk, UK
Distribution: Red Hat 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by mugstar
The module you need is agpgart (note the extra 'g').
Being a bit thick, where do I get that from? Or is it already installed?
 
Old 03-05-2005, 05:19 PM   #7
mugstar
Member
 
Registered: Jun 2004
Location: Scotland
Distribution: Anything that'll install...
Posts: 305

Rep: Reputation: 30
Should already be there, AFAIK. Try `modprobe agpgart`.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mass Newb Problem with DISPLAY DRIVER Pro)ZeuS Linux - General 4 05-09-2006 08:57 AM
[newbie] Gentoo 1.4 and P4C800 - network driver compile problem barrel Linux - Hardware 2 11-06-2003 02:01 AM
Problem making Linux-WLAN driver, newbie needs help. sabaka Linux - Wireless Networking 1 09-09-2003 07:22 PM
display driver problem vin_kudva Linux - Newbie 2 08-02-2003 06:17 AM
Flickering display after exiting from X (Nvidia driver problem) biosx Linux - General 2 01-11-2003 06:31 PM


All times are GMT -5. The time now is 01:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration