LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-09-2005, 08:10 PM   #1
thinkdeeper777
LQ Newbie
 
Registered: Jul 2005
Distribution: Fedora Core 3
Posts: 1

Rep: Reputation: 0
Newbie Cannot Connect to Internet (Can't get an IP address)


Thanks in advance for all your help.

I am a complete newbie, and I've only really begun to get into Linux this past week. I had an old box that was just sitting in a closet taking up space, so I intstalled Fedora Core 3 onto it. Installation went wonderfully, but I know that I'll be stuck if I can't get online, so that was the first thing I attempted. I went to the Network Configuration page (Applications => System Settings => Network) and there was presented with an already present, but inactive, ethernet connection. When I tried to activate it, a dialogue box opened which stated "Determining IP information for eth0..." After about 3 minutes, it comes back and adds that the operation failed. We have DSL at home, so I wasn't sure whether to use the ethernet or DSL option. When I did try to confgure the DSL option, i was given this error:

/sbin/adsl-start: line 215: 3988 Terminated
$Connect "$@" >/dev/null 2>&1

Really, that's is just a bunch of code to me, of which I cannot make heads nor tails. Help please!

My box is a Dell Dimension 8100
1296 MHz Processor
256 MB RAM
3Com Corporation 3c905-TX/TX-M [Tornado] integrated ethernet card


We're running everything through a Linksys wireless-G broadband router (WRT54G), by using the ethernet plugs in the back. Also, we use Verizon to provide the DSL service, so I think everything is DHCP.

My questions then are:

Should I configure for an ethernet or a DSL connection?

How do I do that successfully?

By the way, I do have internet access on an XP box sitting right next to the Fedora box. Thanks again for your help.

thinkdeeper777
 
Old 07-10-2005, 03:48 AM   #2
dinolinux
Member
 
Registered: Jun 2005
Location: Oslo, Norway
Distribution: Slackware 11, Solaris 10, Solaris 9, Sourcemage 0.9.6
Posts: 322

Rep: Reputation: 31
Hello!

When you have DHCP you don't have to configure DSL. If you do, you'll get the same error. Try configuring eth0 for DHCP
 
Old 07-10-2005, 09:52 AM   #3
RanDrake10
Member
 
Registered: Oct 2004
Location: Florida
Distribution: Debian
Posts: 319

Rep: Reputation: 30
I have to power cycle the Linksys routers sometimes to get them to work. Leave DHCP set up on the router starting at say 200, and use static IP's for your network (makes sharing a little easier). Also check the "ifcfg-eth0" file to make sure all settings are right.
 
Old 07-10-2005, 12:04 PM   #4
siyeclover
Member
 
Registered: Jan 2003
Location: RaMetal
Distribution: Solaris,FC2,FreeBSD
Posts: 41

Rep: Reputation: 15
You should config adsl connection, run command:
adsl-setup



siyeclover
 
Old 07-20-2005, 05:17 PM   #5
filzmoos
LQ Newbie
 
Registered: Jun 2005
Posts: 3

Rep: Reputation: 0
Hi, I'm having the same problem, I have a 3com dsl modem wireless router, my laptop works fine (wireless) so does my imac (ethernet) the pc works fine when booted as win98 but when suse9.1 I cant conect to the internet. The router is loged on all the time so trying to use kinternet just causes errors. All I want to know is how to conect to the internet via a LAN yet nowhere can I find this basic bit of info.
 
Old 07-20-2005, 05:48 PM   #6
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
SuSE installs a firewall by default. Have you configured that in YAST to allow kinternet or eth0 to connect to the router?

I will say, though-- the reason that you likely can't find the information is because the vast majority of times it "just works", so no one needs to write down what to do when it doesn't.

But if I was you, I'd be in YAST checking my network settings-- maybe you're not connected to the network for some reason, or your ethernet card isn't working. Because if the card were working, and you were thus connected to the network (and therefore the router), it would "just work", and the fact that it doesn't suggests that something in your basic setup is messed up.
 
Old 07-20-2005, 06:39 PM   #7
filzmoos
LQ Newbie
 
Registered: Jun 2005
Posts: 3

Rep: Reputation: 0
Found one address conflict in network setup which I fixed and now using the ip address I can now log-on to the router admin so I guess the network card works. I temporarily turned off both firewalls but still I get unknown host when I try to smurff
 
Old 07-20-2005, 07:10 PM   #8
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Did you set your hostname? Or is the router supposed to do that for you (the default network setting in most network config tools under Linux is that the router gives you a hostname along with the IP. No idea why)? If so, does the router know about this (is it expecting to give you a hostname, because you're on a domain or something)? If not, turn that setting off, give yourself a hostname (name the computer), if you haven't, and check YAST or edit /etc/hosts manually to associate your IP address with the hostname of your computer.

That should solve the host being 'unknown'.
 
Old 07-24-2005, 12:30 PM   #9
filzmoos
LQ Newbie
 
Registered: Jun 2005
Posts: 3

Rep: Reputation: 0
Smile

Thanks to all, finally figured out that the manual gave me a bum steer. It says if you have a valid internet connection bind gets you connected to a dns server- wrong (at least in my case) it should have said "valid dial up connection". As I was able to communicate with ip addresses I figured I had to install a dns server, this I did and now all works fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can connect to Internet but can't PING any address 1kyle Linux - Wireless Networking 2 09-06-2005 07:41 PM
Newbie - How SuSE Linux COnnect to Windows 2003 Internet Connection Cipherfx Linux - Networking 4 01-07-2005 01:44 AM
Eth0 up, has ip address, but cant connect to anything! Munix Linux - Distributions 1 04-10-2004 09:34 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 08:32 PM
Should i use the eth0 ip address of my internet ip address when applying iptables ForumKid Linux - Security 2 01-03-2002 09:54 AM


All times are GMT -5. The time now is 08:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration