LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-29-2016, 12:25 PM   #1
dwgraham
LQ Newbie
 
Registered: Jan 2016
Location: Bedford, TX
Distribution: Slacko & Ubuntu
Posts: 4

Rep: Reputation: Disabled
NEWBIE Can't get wifi with UBUNTU 14.04.3


I have searched and tried various web sites solutions to getting wi-f- with my Broadcom 4311 card on Dell D820 Ubuntu/Windows 7

Here is a list of results from terminal

doug@doug-Latitude-D820:~$ lspci -nnk | grep -i net -A2
09:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express [14e4:1600] (rev 02)
Subsystem: Dell Device [1028:01cc]
Kernel driver in use: tg3
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11a/b/g [14e4:4312] (rev 01)
Subsystem: Dell Wireless 1490 Dual Band WLAN Mini-Card [1028:0007]
Kernel driver in use: b43-pci-bridge

doug@doug-Latitude-D820:~$ lsmod
Module Size Used by
rfcomm 61440 0
bnep 20480 2
bluetooth 430080 10 bnep,rfcomm
snd_hda_codec_idt 57344 1
b43 397312 0
snd_hda_codec_generic 65536 2 snd_hda_codec_idt
snd_hda_intel 32768 3
snd_hda_controller 32768 1 snd_hda_intel
bcma 49152 1 b43
snd_hda_codec 122880 4 snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
coretemp 16384 0
mac80211 618496 1 b43
snd_hwdep 16384 1 snd_hda_codec
i915 925696 3
kvm 413696 0
snd_pcm 94208 3 snd_hda_codec,snd_hda_intel,snd_hda_controller
gpio_ich 16384 0
binfmt_misc 20480 1
snd_seq_midi 16384 0
snd_seq_midi_event 16384 1 snd_seq_midi
dell_laptop 16384 0
pcmcia 53248 0
snd_rawmidi 28672 1 snd_seq_midi
cfg80211 450560 2 b43,mac80211
snd_seq 57344 2 snd_seq_midi_event,snd_seq_midi
dcdbas 16384 1 dell_laptop
yenta_socket 40960 0
i8k 16384 0
ssb_hcd 16384 0
snd_seq_device 16384 3 snd_seq,snd_rawmidi,snd_seq_midi
drm_kms_helper 114688 1 i915
pcmcia_rsrc 20480 1 yenta_socket
snd_timer 28672 2 snd_pcm,snd_seq
joydev 20480 0
serio_raw 16384 0
pcmcia_core 24576 3 pcmcia,pcmcia_rsrc,yenta_socket
snd 69632 16 snd_hwdep,snd_timer,snd_hda_codec_idt,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_code c,snd_hda_intel,snd_seq_device
drm 282624 5 i915,drm_kms_helper
irda 172032 0
soundcore 16384 2 snd,snd_hda_codec
lpc_ich 20480 0
shpchp 32768 0
i2c_algo_bit 16384 1 i915
crc_ccitt 16384 1 irda
8250_fintek 16384 0
mac_hid 16384 0
video 20480 1 i915
parport_pc 32768 0
ppdev 20480 0
lp 16384 0
parport 40960 3 lp,ppdev,parport_pc
firewire_ohci 36864 0
psmouse 102400 0
firewire_core 65536 1 firewire_ohci
crc_itu_t 16384 1 firewire_core
pata_acpi 16384 0
ssb 57344 2 b43,ssb_hcd
tg3 159744 0
ptp 20480 1 tg3
pps_core 20480 1 ptp

doug@doug-Latitude-D820:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

doug@doug-Latitude-D820:~$ iwconfig lan0
lan0 No such device
 
Old 01-29-2016, 12:31 PM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Did you have a look at this?
 
Old 01-29-2016, 01:39 PM   #3
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,709
Blog Entries: 3

Rep: Reputation: 770Reputation: 770Reputation: 770Reputation: 770Reputation: 770Reputation: 770Reputation: 770
Hi...

Thanks for posting the information I requested. Another option that might work is just simply open up "Additional Drivers," if you haven't already and install the driver from there. This worked fine on a friend's laptop that had a similar chip.

Regards...
 
Old 01-29-2016, 06:28 PM   #4
dwgraham
LQ Newbie
 
Registered: Jan 2016
Location: Bedford, TX
Distribution: Slacko & Ubuntu
Posts: 4

Original Poster
Rep: Reputation: Disabled
WIFI working problem solved

-I kept searching found the following command lines


sudo apt-get update

If you have a b43 card use the command

sudo apt-get install firmware-b43-installer

I had done this before but it never got the B43 = wlan0.

For the wireless card, I don't see a driver listed. Perhaps this is part of the issue?

I went ahead and tried the command

modprobe b43

just to see if anything happened...and my wireless card connected!


UPDATE: I restarted the computer, tried the "modprobe b43" command again (must be run as sudo) and it worked. So things seem to be working, thank you for the help!

Now I have an idea of how to get it working. Thanks for your help and understanding a Newbie frustration.

Now for a shutdown and see if it stays.
 
Old 01-29-2016, 08:45 PM   #5
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,709
Blog Entries: 3

Rep: Reputation: 770Reputation: 770Reputation: 770Reputation: 770Reputation: 770Reputation: 770Reputation: 770
Cool, I'm glad you got it to work.

Regards...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wifi hotspot using wifi connection in ubuntu 14.10, rssr25 Linux - Newbie 5 03-31-2015 10:50 AM
Wifi problem in ubuntu 9.04 with atheros wifi card raghulmz Linux - Hardware 1 10-28-2009 05:58 AM
Ubuntu 9.04 can't connect to wifi with Intel Wireless WiFi Link 5100 Shinbatsu Linux - Networking 3 08-30-2009 01:55 AM


All times are GMT -5. The time now is 09:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration