LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-04-2011, 12:07 AM   #1
gbsk
LQ Newbie
 
Registered: Jul 2011
Posts: 11

Rep: Reputation: Disabled
Newbie - BIOS


I am a newbie. I just went to a Linux users group and they installed Fedora for me. I have had problems with XP since Jan. They were going to make one a slave and the other a master but decided not to since I get the message "BIOS not installed" at startup but this has been going on for over a year and well before the XP trouble. They seemed pretty cabable but could not find the BIOS trouble. How can I get the BIOS installed? It is not the battery.

Thanks
GB
 
Old 07-04-2011, 12:16 AM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Where is the message coming from dmesg?
Can you post the message from system?
What is make & model
 
Old 07-04-2011, 12:16 AM   #3
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
1. As I think you've learned, a "BIOS not installed" message has nothing to do with either Windows or Linux per se. It's an issue with your motherboard.

2. It sounds like you're able to boot, correct?
If so, this is merely an "annoyance", correct?

3. A couple of things you can try:

a) See if your motherboard's vendor has a BIOS update. If so, try installing it.

b) Try removing peripherals (like your hard drive) to identify the source of the problem.

You can actually boot without your hard drive enabled - just boot from the Fedora install CD (and see if the BIOS message occurs or not).

c) Consider upgrading your motherboard.
 
Old 07-04-2011, 12:17 AM   #4
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 208Reputation: 208Reputation: 208
Is this a custom built machine or a one of the popular makes. If the latter please state all the information you have on the machine..
 
1 members found this post helpful.
Old 07-04-2011, 07:45 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,929

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
I assume that the computer functions without issues. More information about the motherboard and how it is configured is required but typically this warning is due to the fact that there are no drives connected to the SATA/RAID controller. See what happens if you disable RAID in the BIOS. Anyway the message can be safely ignored.
 
1 members found this post helpful.
Old 07-04-2011, 05:46 PM   #6
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,374

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
I agree it is the raid bios it is talking about or maybe some other hardware that could have a bios to install or cache.

It kind of competes with the master slave part as I'd more assume a serial drive. It could easily have a raid card in pci or motherboard to ide also.

If it is a newish system they should have installed a free virtual machine. It would have been a better choice on a newish system with enough ram. It would help if you told us what you have maybe.

Last edited by jefro; 07-04-2011 at 05:47 PM.
 
Old 07-07-2011, 07:18 AM   #7
gbsk
LQ Newbie
 
Registered: Jul 2011
Posts: 11

Original Poster
Rep: Reputation: Disabled
Newbie BIOS

This is really weird. I posted an answer earlier and now it is not on here. Here is a similar message.

I have a Dell Dimension 2400 running XP. The BIOS not installed message comes at startup on a DOS type screen. It does not seem to affect the way the computer runs. The reason I sent this is because I got another computer HD loaded with FEdora and Libre Office at a local Linux users group that is located about 50 miles away. The fellow who loaded it wanted to make one a master and the other a slave but said he could not because of the BIOS issue. He wanted to fix that first.so right now I just have 2 separate HDs with XP and Linux. Is there a way to fix the BIOS?

Thanks
GB
 
Old 07-07-2011, 07:19 AM   #8
gbsk
LQ Newbie
 
Registered: Jul 2011
Posts: 11

Original Poster
Rep: Reputation: Disabled
I do not know how to disable RAID.

Thanks
GB
 
Old 07-07-2011, 07:33 AM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,929

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
I do not think the 2400 has a built in RAID controller so we will need to know what type of PCI cards are installed.
 
Old 07-07-2011, 04:05 PM   #10
gbsk
LQ Newbie
 
Registered: Jul 2011
Posts: 11

Original Poster
Rep: Reputation: Disabled
Here is my Belarc computer profile. I do not see anything about the PCI card.

Operating System new – server roles System Model
Windows XP Home Edition Service Pack 3 (build 2600)
Install Language: English (United States)
System Locale: English (United States)
Installed: 12/21/2009 4:36:38 PM Dell Computer Corporation Dimension 2400
Enclosure Type: Space-saving
Processor a Main Circuit Board b
2.20 gigahertz Intel Pentium 4
8 kilobyte primary memory cache
512 kilobyte secondary memory cache
Not hyper-threaded Board: Dell Computer Corp. 0G1548 A00
Serial Number: ..CN7082137PD036.
Bus Clock: 400 megahertz
BIOS: Dell Computer Corporation A05 12/02/2003
new USB Storage Use in past 30 Days (mouse over last used for details) new Hosted Virtual Machines (mouse over name for details)
Last Used
OLYMPUS u850SW,S850SW USB Device, s/n F07533771, rev 1.00 7/6/2011 3:27:13 PM
Generic Flash Disk, s/n YTAA1007051708143923, rev 8.00 6/30/2011 11:50:25 AM*
UDISK PDU09_8G A1I2.0 USB Device, s/n 5e37b0b6f447c5, rev 0.00 6/13/2011 3:02:23 PM*


* Possibly used again before the reboot following this time. None discovered
Drives new – drive encryption Memory Modules c,d
41.07 Gigabytes Usable Hard Drive Capacity
12.30 Gigabytes Hard Drive Free Space

HL-DT-ST RW/DVD GCC-4480B [Optical drive]

Maxtor 2F040L0 [Hard drive] (41.11 GB) -- drive 0, s/n F1CQNK5E, rev VAM51JJ0, SMART Status: Healthy
photosmart printer card reader (HPH09) [Hard drive] -- drive 1 1534 Megabytes Usable Installed Memory

Slot 'DIMM_1' has 1024 MB
Slot 'DIMM_2' has 512 MB
Local Drive Volumes new – volume encryption

c: (NTFS on drive 0) 41.07 GB 12.30 GB free

Network Drives
None discovered
Users (mouse over user name for details) Printers
local user accounts last logon
Administrator 3/19/2011 11:38:16 AM (admin)
Owner 7/4/2011 12:32:39 PM (admin)
local system accounts
ASPNET never
Guest never
HelpAssistant never
SUPPORT_388945a0 never


Marks a disabled account; Marks a locked account Foxit PDF Printer Driver on FOXIT_PDF:
hp photosmart 1215 series on DOT4_002
HP PSC 500 on DOT4_001
Microsoft Office Live Meeting 2007 Document Writer Driver on Microsoft Office Live Meeting 2007 Document Writer Port:
Microsoft XPS Document Writer on XPSPort:

Controllers Display
Intel(R) 82801DB Ultra ATA Storage Controller - 24CB
Primary IDE Channel [Controller]
Secondary IDE Channel [Controller] Intel(R) 82845G/GL/GE/PE/GV Graphics Controller [Display adapter]
DELL 1504FP [Monitor] (14.6"vis, s/n XX-0J0947-XXXXX-37A-CJ8N, July 2003)
Bus Adapters Multimedia
Intel(R) 82801DB/DBM USB Universal Host Controller - 24C2
Intel(R) 82801DB/DBM USB Universal Host Controller - 24C4
Intel(R) 82801DB/DBM USB Universal Host Controller - 24C7
Intel(R) 82801DB/DBM USB2 Enhanced Host Controller - 24CD SoundMAX Integrated Digital Audio
Unimodem Half-Duplex Audio Device
USB Audio Device
Virus Protection [Back to Top] Group Policies
avast! Antivirus Version 5.0.100664421
Virus Definitions Version Up To Date
Realtime File Scanning On
None discovered
Communications new – connection speed & status Other Devices
Conexant D850 56K V.9x DFVc Modem

↓ Broadcom 440x 10/100 Integrated Controller
Status: Cable unplugged
Dhcp Server: none responded
Physical Address: 00:0BB:BE:04:82
↑ Linksys NC100 Fast Ethernet Adapter
primary Auto IP Address: 192.168.2.100 / 24
Gateway: 192.168.2.1
Dhcp Server: 192.168.2.1
Physical Address: 00:12:17:58:04:F1

Networking Dns Server: 192.168.2.1
CMS PortIO Driver
HID-compliant consumer control device (3x)
HID-compliant device
USB Human Interface Device (4x)
HID Keyboard Device
Microsoft USB Comfort Optical Mouse 3000 (IntelliPoint)
USB Composite Device (2x)
USB Root Hub (4x)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dodgy bios? 'Bios may corrupt low RAM, working around it' Fred Caro Linux - Newbie 8 05-02-2011 05:29 AM
Dumb Newbie - lost linux partition + BIOS problem? BlendedRacer Linux - Newbie 2 06-28-2004 10:23 PM
old BIOS (1992) won't detect my cdrom drive; BIOS says: neither IDE prots enabled carbono Linux - Hardware 5 05-18-2004 12:07 PM


All times are GMT -5. The time now is 12:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration