LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-21-2008, 08:37 AM   #1
Jimbo13
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Rep: Reputation: 0
New Ubuntu user can't fix Resolution.


I'm trying Ubuntu seeing if I like linux I normally use Windowsxp.

I am having a problem setting my resolution properly.

Current options 800x600, 640x480, 400x300.

My video card is a Nvidia GeForce 6200 my monitor is a generic 19 inch wide screen LCD I think the resolution I use in windows is 1200x800.


Under system/administration/hardware drivers I have the option for a Nvida accelerated drivers when enabled it limits me to 600x430 resolution so I disabled it.

I downloaded NVIDIA-Linux-x86_64-169.12-pkg2.run from the nvidia website when I click on it

Could not open the file /home/jim/Desktop/NVIDIA…ux-x86_64-169.12-pkg2.run.

gedit has not been able to detect the character coding.
Please check that you are not trying to open a binary file.
Select a character coding from the menu and try again.


Character coding options are Current Locale (utf-8) and WESTERN ISO, neither work.

NVIDIA Says to Install Type "sh NVIDIA-Linux-x86_64-169.12-pkg2.run" to install the driver.

I don't know how to pull up a prompt to do this.


Any help getting in a resolution easier on the eyes is greatly appreciated.
 
Old 04-21-2008, 08:45 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Under system/administration/hardware drivers I have the option for a Nvida accelerated drivers when enabled it limits me to 600x430 resolution so I disabled it.
Nope - this is the one you use. The resolution issue is different - that's probably Ubuntu trying to protect you.

Do not use the nvidia driver you downloaded.

The command prompt is in Applications >Accessories > terminal

Enter:

sudo dpkg-reconfigure -phigh xserver-xorg

See if that gets you better options. Failing that, we need to look at your /etc/X11/xorg.conf file.
 
Old 04-21-2008, 09:03 AM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Do not use the nvidia driver you downloaded.
Why not? (unless he has a 32-bit system--in which case get the 32-bit version of the driver.) I have found that Nvidia installer to be really great.

This said, the nvidia driver may already be available in the Ubuntu repos. Try a search using the package manager (Adept or Synaptic)
Quote:
my monitor is a generic 19 inch wide screen LCD I think the resolution I use in windows is 1200x800.
I don't think so...."conventional" monitors are 4:3. Widescreens are typically 16:9 or 16:10. Note that LCDs are always best at their highest (native) resolution.

I have found that--with widescreens--it is often necessary to use a "modeline" in xorg.conf. Once you confirm that you have the right driver---and can get higher resolutions---we can walk you thru setting up a modeline.
 
Old 04-21-2008, 09:18 AM   #4
Jimbo13
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Simon Bridge View Post
Nope - this is the one you use. The resolution issue is different - that's probably Ubuntu trying to protect you.

Do not use the nvidia driver you downloaded.

The command prompt is in Applications >Accessories > terminal

Enter:

sudo dpkg-reconfigure -phigh xserver-xorg

See if that gets you better options. Failing that, we need to look at your /etc/X11/xorg.conf file.
At the terminal it gave me

xserver-xorg postinst warning: overwriting possibly-customised configuration file; backup in /etc/X11/xorg.conf.20080421065106

my xorg.conf reads the following:


Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection



When I go to enable the driver now my system hangs up for a moment and nothing seems to happen.
 
Old 04-21-2008, 09:28 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Your xorg.conf file has no details---you will have to run a configuration program or do it manually.

Try "xorgconfig" in the terminal (With Ubuntu, maybe "sudo xorgconfig")

Quote:
When I go to enable the driver now my system hangs up for a moment and nothing seems to happen.
What do you mean by "enabling the driver"? Are you trying to run that Nvidia installer?

Did you try looking for the nvidia driver with Adept or Synaptic?
 
Old 04-21-2008, 09:31 AM   #6
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
<<Light goes on>>
Have you installed Ubuntu or are you running from live CD? Don't waste your time trying to install drivers and stuff if you have not installed Ubuntu.

When installing, Ubuntu should have put more details into xorg.conf
 
Old 04-21-2008, 09:35 AM   #7
Jimbo13
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by pixellany View Post
<<Light goes on>>
Have you installed Ubuntu or are you running from live CD? Don't waste your time trying to install drivers and stuff if you have not installed Ubuntu.

When installing, Ubuntu should have put more details into xorg.conf
Not off a CD, I installed with http://wubi-installer.org/


Try "xorgconfig" in the terminal (With Ubuntu, maybe "sudo xorgconfig")

Command not found to both.

I'm looking up Synaptec know.

Last edited by Jimbo13; 04-21-2008 at 09:39 AM.
 
Old 04-21-2008, 10:05 AM   #8
Jimbo13
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Okay now my xorg.conf says:

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection


System/preferences/screen resolution/


The only option I get now is 640x480 and 320x240

Also my system is a 64 bit system, the driver I downloaded is for my card.

Last edited by Jimbo13; 04-21-2008 at 10:08 AM.
 
Old 04-21-2008, 12:30 PM   #9
Jimbo13
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Original Poster
Rep: Reputation: 0
My gut feeling tells me I need to install this driver NVIDIA-Linux-x86_64-169.12-pkg2 from the nvidia website.

When I double click it I get

Could not open the file /home/jim/Desktop/NVIDIA…ux-x86_64-169.12-pkg2.run.

gedit has not been able to detect the character coding.
Please check that you are not trying to open a binary file.
Select a character coding from the menu and try again.


When I try it in terminal using sh NVIDIA-Linux-x86_64-169.12-pkg2.run

I get

sh: Can't open NVIDIA-Linux-x86_64-169.12-pkg2.run

Can anyone tell me what I need to do to run that driver?
 
Old 04-21-2008, 01:48 PM   #10
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 8 Jessie
Posts: 1,688
Blog Entries: 5

Rep: Reputation: 163Reputation: 163
It should not be necessary to install the nVidia drivers to get the resolution you want, and if you do install the nVidia drivers you'll want to do it using Ubuntu's "Restricted Driver" wizard. It's not that you can't do it the manual way, but it's easier to just point and click on a friendly graphical interface. Either way you get the same driver (Actually, perhaps not--the 64 bit driver is only used if you're using the 64 bit version of the OS).

The reason it's confused when you double-click on the .run file is that it's a binary file and it's trying to open it with a text editor (gedit is like Notepad). If you're confused by that, don't worry. Using the Restricted Driver wizard is easier. Just point and click, and it'll do the installation for you.

But first, I suggest you keep things simple and do NOT use the nVidia drivers at first. Unlike Windows, the generic VGA driver in Linux is actually capable of handling custom resolutions on many video cards; yours may be one of them.

So, the simplest thing will be to reinstall Ubuntu. I'm not familiar with this "wubi" installer, but see if there's some sort of "safe graphics mode" option. With the normal Ubuntu liveCD, I ironically find that I can usually get the correct resolution only in "safe graphics mode", which uses the generic "vesa" driver, whereas if Ubuntu tries to use the "proper" video driver then the resolution is often limited to 800x600 or even lower.

The resolution of your monitor, BTW, is probably 1280x800 (this is a 16:10 resolution, common with LCD monitors).
 
Old 04-21-2008, 02:51 PM   #11
CouchMaster
Member
 
Registered: Mar 2005
Location: West Texas
Distribution: Sidux - Mint - PC Linux - Ubuntu 7.04 - Mepis 7 Beta5 - DreamLinux 2.2
Posts: 234

Rep: Reputation: 33
Borrow another monitor (preferably a standard Dell - your roommate/neighbor probably has one) and use it to install Ubuntu. then switch monitors. I guarantee this will work and you don't have to edit anything!
 
Old 04-21-2008, 09:10 PM   #12
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Borrowing another monitor is not going to help.

If the computer boots up OK with the xorg.conf as you show it, then you already have the nvidia driver---no need to install from the script you downloaded.

You are still missing some things in xorg.conf. The minimum info is something similar to this:
Code:
Section "Monitor"
    Identifier "monitor1"
    HorizSync 24-92
    VertRefresh 50-75
EndSection

Section "Device"
    Identifier "device1"
    Driver "radeon"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    Subsection "Display"
        Depth 24
        Modes "1600x1200" 
    EndSubsection
EndSection
I'm surprised you don't have xorgconfig. When I search for it in the package manager (on two different machines) it's not there---that means it comes with X. Try:
sudo find / -name xorgconfig

This aside, I would bite the bullet and learn to hand-edit xorg.conf. start with the man page: "man xorg.conf"
 
Old 04-22-2008, 12:49 AM   #13
Jimbo13
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Well its fixed, not sure how I did it but I my resolution setting is good enough to web browse without a headache.

After a few reboots a configuration UI opened, I was asked a few questions about my keyboard layout then a dual tabbed interface with Monitor/Graphics card.

If anyone could tell me how to get back to this dialog I'd appreciate it.

Thank you for all the help.


For anyone else with this problem here was a few things I was looking at.


Most likely I used the Nvidida driver settings in /system/administration/Synaptic.


If you have this Linux Kernel which I'm not sure if I do or not the Nvidia drivers have to be patched, I never achieved the patch but my driver was mentioned in the problem.

Using NVIDIA Linux graphics drivers with Linux 2.6.25-rc
http://www.nvnews.net/vbulletin/showthread.php?t=110088

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "vesa"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1440x900"
Horizsync 31.5-56.0
Vertrefresh 56.0 - 65.0
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1440 900
Modes "1440x900@60" "1280x800@60" "1280x720@60" "1280x768@60" "800x600@60" "800x600@56"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "vesa"
Busid "PCI:1:0:0"
Driver "vesa"
Screen 1
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection
 
Old 04-22-2008, 03:15 AM   #14
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by pixellany View Post
Why not? (unless he has a 32-bit system--in which case get the 32-bit version of the driver.) I have found that Nvidia installer to be really great.

This said, the nvidia driver may already be available in the Ubuntu repos.
That's why not. Also the repo version will be better packaged and it updates with the kernel.

7.10 even has a special gui for installing it.

@Jimbo13:
The trouble you had was due to your xorg.conf screen section not having any modelines.

For some reason you chose not to follow advise to dpkg-reconfigure nor to manually edit xorg.conf to include the "mode" line - this specifies the available resolutions. You also ignored advise not to install the nvidia packaged driver, citing "gut feeling"s. While your intestines can lead you a long way, it is pointless to ask assistance if you prefer to follow them.

Have a look at system > administration > screens and graphics
That is probably the two-tab dialog you saw before. The second tab sets your videocard and driver, which affects the resolutions available in the first tab.

Last edited by Simon Bridge; 04-22-2008 at 03:42 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me fix a Display Resolution problem? GregDC Linux - Newbie 7 04-19-2007 03:11 AM
Trying to fix resolution. I've googled it and beyond, no luck. ImaMadGoat Ubuntu 3 07-06-2005 02:23 AM
How to fix my screen resolution takky Linux - Newbie 11 02-01-2005 08:55 PM
needing to fix my screen resolution yokie1979 Linux - Hardware 0 08-22-2002 02:41 PM


All times are GMT -5. The time now is 04:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration