-   Linux - Newbie (
-   -   New Ubuntu install, getting error message on boot. (

mtotombogo 09-03-2009 12:38 PM

New Ubuntu install, getting error message on boot.
have been having some issues with tight vnc, then switched to x11vnc, now getting this message on boot:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

i suspect something to do with the keyboard config, but dont know how to adjust?

also, quite often now any form field will grab a letter and just keep repeating it, this will carry over to other applications.
should i report this as a bug?

thank you..

Agrouf 09-04-2009 08:53 AM

Please post the output of
- xdpyinfo | grep KEYBOARD
- xprop -root | grep XKB
- gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

mtotombogo 09-06-2009 12:45 PM


thanks for responding, here are the outputs

XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "pc105", "us", "", ""

and model =
options = []
layouts = [aa]

i suspect its something to do with the keyboard. when i first setup tightvnc the keyboard i logged in on didnt work, and i had to adjust the keyboard properties, then i changed to a user instead of root, cos someone said it was insecure, and everything stopped working, so i changed to x11vnc, which is great. i think the changes i made for tightvnc maybe conflicting with the setup for x11vnc.
-> i had to type something in the brackets there [aa] to get tightvnc to recognise the keyboard i was using remotely, but i cant remember where i changed the value.


Agrouf 09-06-2009 03:25 PM

xdpyinfo | grep KEYBOARD doesn't return anything?

All times are GMT -5. The time now is 07:36 AM.