LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-24-2014, 05:49 PM   #1
rickytikki
LQ Newbie
 
Registered: Jul 2014
Location: Dallas Texas
Distribution: Slackware
Posts: 6

Rep: Reputation: Disabled
New To Slackware tedious but FUNNNN how to install skype lulz


Hello all like i said im new to slackware ive installed SLackware 64 bit on my Vostro laptop specs are icore 5 intel 4 gigs of ram Nvidia Geforce 310m n intel ultimate 5300 wifi card. Before this ive been using ubuntu distros so i understood jumping from ubuntu to slackware that it was going to be an ordeal but what better way to learn then from experience (or breaking and fixing) so here i am.

So like i said ive install Slackware which took me like 2 days to configure and install play around with it. Now ive installed a couple of things like proprietary drivers Adobe flash and Alsa for sound and a couple of other small things. So now im trying to get skype from what i understand skype is a 32 bit program so i need the multilib files to run 32 bit programs as well as 64 bit.
Ive been using sbopkg for the most part and figured how to use the slackbuilds. now im not extremely familiar with the command line but i know how to get around. ive been following slackware wiki on how to get the multilibs. so i have a home file with 14.1 folder and in that folder is the multilibs. but when i try to install skype i get this

Code:
bash-4.2$ cd skype
bash-4.2$ ls
README            doinst.sh                  skype.SlackBuild  slack-desc
README.SLACKWARE  skype-alternative.desktop  skype.info
bash-4.2$ ./skype.SlackBuild
x86_64 is not supported, you will need 32bit compatibility libs...
rm: cannot remove '/tmp/SBo/package-skype': Permission denied
bash-4.2$ su
Password: 
bash-4.2# ./skype.SlackBuild
x86_64 is not supported, you will need 32bit compatibility libs...
tar: /home/best/14.1/skype/skype-4.3.0.37.tar.bz2: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
bash-4.2#
So right now im lost and really have no clue what to do lulz please help me what comes next
here is my multi libs directory and files
Code:
bash-4.2$ cd 14.1
bash-4.2$ ls
CHECKSUMS.md5
CHECKSUMS.md5.asc
CHECKSUMS.md5.gz
CHECKSUMS.md5.gz.asc
FILELIST.TXT
GPG-KEY
MANIFEST.bz2
PACKAGES.TXT
PACKAGES.TXT.gz
_build_gcc-4.8.2_multilib_20131021.log.gz
compat32-tools-3.2-noarch-2alien.lst
compat32-tools-3.2-noarch-2alien.meta
compat32-tools-3.2-noarch-2alien.tgz
compat32-tools-3.2-noarch-2alien.tgz.asc
compat32-tools-3.2-noarch-2alien.tgz.md5
compat32-tools-3.2-noarch-2alien.txt
debug
gcc-4.8.2_multilib-x86_64-1alien.lst
gcc-4.8.2_multilib-x86_64-1alien.meta
gcc-4.8.2_multilib-x86_64-1alien.txt
gcc-4.8.2_multilib-x86_64-1alien.txz
gcc-4.8.2_multilib-x86_64-1alien.txz.asc
gcc-4.8.2_multilib-x86_64-1alien.txz.md5
gcc-g++-4.8.2_multilib-x86_64-1alien.lst
gcc-g++-4.8.2_multilib-x86_64-1alien.meta
gcc-g++-4.8.2_multilib-x86_64-1alien.txt
gcc-g++-4.8.2_multilib-x86_64-1alien.txz
gcc-g++-4.8.2_multilib-x86_64-1alien.txz.asc
gcc-g++-4.8.2_multilib-x86_64-1alien.txz.md5
gcc-gfortran-4.8.2_multilib-x86_64-1alien.lst
gcc-gfortran-4.8.2_multilib-x86_64-1alien.meta
gcc-gfortran-4.8.2_multilib-x86_64-1alien.txt
gcc-gfortran-4.8.2_multilib-x86_64-1alien.txz
gcc-gfortran-4.8.2_multilib-x86_64-1alien.txz.asc
gcc-gfortran-4.8.2_multilib-x86_64-1alien.txz.md5
gcc-gnat-4.8.2_multilib-x86_64-1alien.lst
gcc-gnat-4.8.2_multilib-x86_64-1alien.meta
gcc-gnat-4.8.2_multilib-x86_64-1alien.txt
gcc-gnat-4.8.2_multilib-x86_64-1alien.txz
gcc-gnat-4.8.2_multilib-x86_64-1alien.txz.asc
gcc-gnat-4.8.2_multilib-x86_64-1alien.txz.md5
gcc-go-4.8.2_multilib-x86_64-1alien.lst
gcc-go-4.8.2_multilib-x86_64-1alien.meta
gcc-go-4.8.2_multilib-x86_64-1alien.txt
gcc-go-4.8.2_multilib-x86_64-1alien.txz
gcc-go-4.8.2_multilib-x86_64-1alien.txz.asc
gcc-go-4.8.2_multilib-x86_64-1alien.txz.md5
gcc-java-4.8.2_multilib-x86_64-1alien.lst
gcc-java-4.8.2_multilib-x86_64-1alien.meta
gcc-java-4.8.2_multilib-x86_64-1alien.txt
gcc-java-4.8.2_multilib-x86_64-1alien.txz
gcc-java-4.8.2_multilib-x86_64-1alien.txz.asc
gcc-java-4.8.2_multilib-x86_64-1alien.txz.md5
gcc-objc-4.8.2_multilib-x86_64-1alien.lst
gcc-objc-4.8.2_multilib-x86_64-1alien.meta
gcc-objc-4.8.2_multilib-x86_64-1alien.txt
gcc-objc-4.8.2_multilib-x86_64-1alien.txz
gcc-objc-4.8.2_multilib-x86_64-1alien.txz.asc
gcc-objc-4.8.2_multilib-x86_64-1alien.txz.md5
glibc-2.17_multilib-x86_64-7alien.lst
glibc-2.17_multilib-x86_64-7alien.meta
glibc-2.17_multilib-x86_64-7alien.txt
glibc-2.17_multilib-x86_64-7alien.txz
glibc-2.17_multilib-x86_64-7alien.txz.asc
glibc-2.17_multilib-x86_64-7alien.txz.md5
glibc-i18n-2.17_multilib-x86_64-7alien.lst
glibc-i18n-2.17_multilib-x86_64-7alien.meta
glibc-i18n-2.17_multilib-x86_64-7alien.txt
glibc-i18n-2.17_multilib-x86_64-7alien.txz
glibc-i18n-2.17_multilib-x86_64-7alien.txz.asc
glibc-i18n-2.17_multilib-x86_64-7alien.txz.md5
glibc-profile-2.17_multilib-x86_64-7alien.lst
glibc-profile-2.17_multilib-x86_64-7alien.meta
glibc-profile-2.17_multilib-x86_64-7alien.txt
glibc-profile-2.17_multilib-x86_64-7alien.txz
glibc-profile-2.17_multilib-x86_64-7alien.txz.asc
glibc-profile-2.17_multilib-x86_64-7alien.txz.md5
glibc-solibs-2.17_multilib-x86_64-7alien.lst
glibc-solibs-2.17_multilib-x86_64-7alien.meta
glibc-solibs-2.17_multilib-x86_64-7alien.txt
glibc-solibs-2.17_multilib-x86_64-7alien.txz
glibc-solibs-2.17_multilib-x86_64-7alien.txz.asc
glibc-solibs-2.17_multilib-x86_64-7alien.txz.md5
glibc-zoneinfo-2013d_multilib-noarch-7alien.lst
glibc-zoneinfo-2013d_multilib-noarch-7alien.meta
glibc-zoneinfo-2013d_multilib-noarch-7alien.txt
glibc-zoneinfo-2013d_multilib-noarch-7alien.txz
glibc-zoneinfo-2013d_multilib-noarch-7alien.txz.asc
glibc-zoneinfo-2013d_multilib-noarch-7alien.txz.md5
skype
slackware64-compat32
bash-4.2$
 
Old 07-24-2014, 05:58 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
Simple, just follow the instructions --> http://alien.slackbook.org/dokuwiki/...kware:multilib
 
Old 07-24-2014, 06:11 PM   #3
rickytikki
LQ Newbie
 
Registered: Jul 2014
Location: Dallas Texas
Distribution: Slackware
Posts: 6

Original Poster
Rep: Reputation: Disabled
Code:
bash-4.2# upgradepkg --install-new *-compat32/*.t?z

+==============================================================================
| Skipping package aaa_elflibs-compat32-14.1-x86_64-3compat32 (already installed)
+==============================================================================


+==============================================================================
| Skipping package attr-compat32-2.4.46-x86_64-1compat32 (already installed)
+==============================================================================


+==============================================================================
| Skipping package bzip2-compat32-1.0.6-x86_64-1compat32 (already installed)
+==============================================================================


+==============================================================================
| Skipping package cups-compat32-1.5.4-x86_64-3compat32 (already installed)
+==============================================================================



bash-4.2#
its already installed so how do i get skype

Last edited by rickytikki; 07-24-2014 at 06:17 PM.
 
Old 07-24-2014, 06:18 PM   #4
rickytikki
LQ Newbie
 
Registered: Jul 2014
Location: Dallas Texas
Distribution: Slackware
Posts: 6

Original Poster
Rep: Reputation: Disabled
what am i doing wrong??
 
Old 07-24-2014, 06:44 PM   #5
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
There are several more steps to enabling 32-bit support in Slackware64. Since you're not providing much information regarding every step you've taken, it's difficult to determine exactly what you're doing wrong.
 
Old 07-24-2014, 07:17 PM   #6
rickytikki
LQ Newbie
 
Registered: Jul 2014
Location: Dallas Texas
Distribution: Slackware
Posts: 6

Original Poster
Rep: Reputation: Disabled
k what i have done is followed that exact same wiki Adding Multilib Capability to Slackware on x86_64 Architecture. all the way to the end so i know the library is installed my problem is installing skype how do i enable the lib for skype ive got from slackbuild. i have tried to put the skype in the same directory and the 32multi lib and im still getting that error. im having trouble i believe in compiling and executing the software to work. do i put the skype file in the slackware64-compat32 then run it? using ./skype.slackbuild what do i do with the doins.sh file? sorry for the noob questions i just want to get it right. Also for commands should i right down and keep a list of commands because in ubuntu syntax is not that much really diff but this bash syntax is really hard for me to understand at times. really what i would like to do is run skype.
 
Old 07-24-2014, 07:19 PM   #7
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,090
Blog Entries: 3

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
well I would not worry about it skype 4.3 requires much more than the maintainer tells you skype voice will not work unless you install pulseaudia and all the optional dependencies and pavucontrol and all of it's dependencies. Skype drops support for ALSA
here is a copy of the old tar ball and the old link to 4.2.0.13 is still good link to old sbo-tarball
or link to to the 4.2.0.13 I went to google talk and now it's free calls in the usa.

Yes Ponce knows about this and yes the maintainer knows about this. I contacted the maintainer to edit his readme but have not seen it.
no you do not convert the package. you install it as is.

Last edited by Drakeo; 07-24-2014 at 07:20 PM.
 
Old 07-24-2014, 07:22 PM   #8
rickytikki
LQ Newbie
 
Registered: Jul 2014
Location: Dallas Texas
Distribution: Slackware
Posts: 6

Original Poster
Rep: Reputation: Disabled
also can u please be more specific on what info u need me to provide to help u help me? i understood using slackware no one was really gonna hold my hand like ubuntu n such but im determined to get this anyway i can.
 
Old 07-24-2014, 07:24 PM   #9
rickytikki
LQ Newbie
 
Registered: Jul 2014
Location: Dallas Texas
Distribution: Slackware
Posts: 6

Original Poster
Rep: Reputation: Disabled
thank you so much drakeo trying it right now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
latest skype Skype 2.2.0.25 and Slackware --current anti_user Slackware 10 04-07-2011 03:22 PM
[SOLVED] Install skype on Slackware 13.1 ZebraIzToronto Slackware 4 11-14-2010 04:06 AM
noise in skype to skype calls in skype v2.1 beta for fedora mq15 Linux - Software 0 01-20-2010 01:04 AM
editing HTML files - the tedious way noir911 Linux - Desktop 5 11-07-2008 12:21 AM
Tedious migration process??? zwdaniel Linux - General 2 04-27-2005 04:57 AM


All times are GMT -5. The time now is 06:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration