LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-28-2006, 06:01 AM   #1
read83
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Rep: Reputation: 0
new to linux and encountering installation problems


i am attempting to install mandriva 2006 on a sata raid 0array. i also have windows xp installed on this drive. i create a root partition, swap, and /home. when asked where to put grub i have several options: the windows partition, root, swap, or home. i put it in the windows partition and when i reboot grub runs, but will not load linux. it will however load windows. furthermore, i can't even rewrite the boot sector to no longer run grub. i have tried loading the windows cd and and running "fixboot c:" , "fixmbr", and "bootcfg /rebuild". none of those attempts worked. it still boots grub. is there at least some way to change the boot priority in grub. i would like to have linux work, but failing that i at least want to get rid of grub.

please help me!!!
 
Old 04-28-2006, 06:34 AM   #2
deroB
Member
 
Registered: Dec 2005
Location: Sydney, Australia
Distribution: Arch Linux
Posts: 208

Rep: Reputation: 30
when grub appears try typing 'c' to bypass grub.

if this works....and you have a grub prompt
Code:
grub>
you can try too boot into madriva manually.
try the following:
Code:
grub> root (hd0,5)
//where 5 is your root(/) partition, note that 5 means /dev/hda6 in grub

grub> kernel /boot/vmlinuz root=/dev/hda6
//vmlinuz may be different

grub> initrd /boot/

grub> boot
if this works you will need to edit the file /boot/grub/menu.lst to fix grub

there is some good notes here
http://forums.scotsnewsletter.com/in...ST&f=14&t=5025
or in the grub manual
http://www.gnu.org/software/grub/manual/grub.html

good luck

Last edited by deroB; 04-28-2006 at 06:49 AM.
 
Old 04-28-2006, 09:12 AM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by read83
i am attempting to install mandriva 2006 on a sata raid 0array. i also have windows xp installed on this drive. i create a root partition, swap, and /home. when asked where to put grub i have several options: the windows partition, root, swap, or home.
Something's wrong here...
Putting grub on root, swap, or home makes absolutely no sense. The two most common options for where to put grub would be the mbr on the first drive, or on a floppy.

If you did a fixmbr using the Windows CD--and still get grub on bootup, then it may be something to do with the boot order.

Is everything on the raid array? When you installed Linux, did it see the raid array? What is your partitioning setup?
 
Old 04-28-2006, 07:07 PM   #4
read83
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Original Poster
Rep: Reputation: 0
thanks for the responses. in response to derob grub will begin to boot linux, but it fails during the boot sequence so i'm not sure that manually booting the os would be the answer although i will give it a try a lil later just to be sure. w/ regard to pixellany when i was given the option of where to put grub i was given other ide hard drives which have no os installed, or the raid array position 0, 5,6,or 7. 5,6,& 7 of course being the root, swap, and home respectively. so i installed it to the 0 partition. if this was in error please let me know. also, linux did detect and install to the raid array. hope this information helps you help me.
 
Old 04-28-2006, 08:14 PM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by read83
w/ regard to pixellany when i was given the option of where to put grub i was given other ide hard drives which have no os installed, or the raid array position 0, 5,6,or 7. 5,6,& 7 of course being the root, swap, and home respectively. so i installed it to the 0 partition. if this was in error please let me know. also, linux did detect and install to the raid array. hope this information helps you help me.
I don't know what is meant by "raid array position 0,5,6,or 7". If a RAID array is detected during install, it should be detected as one drive. On that drive, you would then create partitions. Since you talk about root, swap, and home, I suspect that you are talking about partitions.
It is incomprehensible to me that the installer would ask if you wanted to put grub on---eg--the swap space.
Again, grub normally goes in the mbr or on a floppy---did you have those choices?

Can you boot up from a live CD of some sort and verify what partitions you have?

All else aside, the first thing I would do if a solution was not found quickly would be to get rid of the RAID. That eliminates a big variable. Depending on what drives you have, I recommend OSes and apps one one drive, and then a big FAT32 partition on another drive for shared data.
 
Old 04-28-2006, 09:29 PM   #6
read83
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Original Poster
Rep: Reputation: 0
thanks again for the help pixellany. the raid array is detected as a single drive and i was referring to partitions. the options given to me for grub were :

/dev/hdb
/dev/mapper/sil_agaedicfagbg
/dev/mapper/sil_agaedicfagbg5
/dev/mapper/sil_agaedicfagbg6
/dev/mapper/sil_agaedicfagbg7
/dev/fd0

the dev/hdb i assum is my ide drive which has files for windows but no os, i boot from the raid, which is the next 4 entries. initially i put grub in the second option listed. grub loads fine when hard disk is selected as first boot device but when i attempt to load linux i recieve this error:

kernel panic - not syncing : no init found

i really want to get this to work so i look forward to yours as well as anybody else's assistance.

thanks
 
Old 04-29-2006, 02:22 AM   #7
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora
Posts: 1,841

Rep: Reputation: 260Reputation: 260Reputation: 260
Grub is working correctly

Here are some things you want to know. Grub is in the MBR. This means grub will come up first thing. If you don't want grub in the MBR, you tell the linux install not to put grub in the MBR. Then you can use the MS Windows boot loader to boot. You need to add a line to c:\boot.ini, at the end of the file, and all you do is change the partition number, the title, and the path to: \boot\grub. Evertything else stays the same. You use the last line in boot.ini as a template, and create a new last line with clipboard, then make the changes to the copied line.

The message you are getting means initrd is loading, but when it tryies to find init, which is a file, and the mother of all linux processes, it can't find it. That means the drive specification for where linux is is wrong.

Here is what a /boot/grub/menu.lst entry looks like:

title Debian GNU/Linux, kernel 2.6.820050831
root (hd0,0)
kernel /boot/vmlinuz-2.6.820050831 root=/dev/sda1 ro acpi=off
initrd /boot/initrd.img-2.6.820050831
savedefault
boot

Debian stuff works pretty well for testing. It is pretty standard linux. At the grub prompt, type root and then TAB. All the possible partitions will be listed and you pick the one that contains /boot. Type kernel TAB, and all the possible kernels will come up. Pick the right one and type it in there. But, in the kernel statement there is a root option. That is the partition that contains /sbin. /sbin is where init is. You might want ro to load the kernel read only, and you may or may not need acpi=off. That all goes on the kernel statement. Type initrd TAB, all your possible initrd files will come up. Type the one that matches your kernel. Everything will be the same, except kernel will say initrd. You usually don't need savedefault or boot, but if you can get it to work try putting your root partition i.e. /dev/partition in the boot statement. The press b. It should boot now, and you can fix /boot/grub/menu.lst to reflect the temporary values you used to boot linux permanently.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux 8 installation - network problems charlton Linux - Hardware 2 03-18-2005 12:15 PM
Problems after linux installation Toddo97 Linux - Newbie 1 06-14-2004 04:52 PM
New to llinux and this forum, and encountering numerous problems! SoulPioneer Linux - Newbie 37 04-19-2004 07:04 PM
Linux 6.1 installation problems TheXMan007 Linux - General 2 03-09-2004 08:58 AM
Linux Installation Problems RushG Linux - Newbie 1 06-04-2002 01:45 PM


All times are GMT -5. The time now is 05:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration