LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-09-2007, 11:11 AM   #1
intheshadows
Member
 
Registered: Sep 2007
Location: United Kindom
Distribution: Fedora 11, Yellow Dog Linux (PS3 Version)
Posts: 39

Rep: Reputation: 15
new to linux


hi im trying to set up a wireless usb adapter but i need to use wlan0 but its not there

[root@localhost ~]# iwconfig wlan0
wlan0 No such device

how do i set it up to use wlan0

im using fedora 7

the wireless adapter is
belkin wireless usb adapter F5D7051

(and i know its a pain)
 
Old 09-09-2007, 11:14 AM   #2
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Have a look at System > Administration > Network. Does it list the wireless or not? If not your driver is not installed or not working for some reason.
 
Old 09-09-2007, 11:19 AM   #3
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Rep: Reputation: 30
i use the same wireless thing its a major pain infact 70% or more are never gonna work on linux because of the chipset its just not compatible
 
Old 09-09-2007, 11:20 AM   #4
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
It could also be called eth1 (eth0 would be your wired ethernet connection, if any). On some systems eth1 is the default, and wlan0 can be used via alias. But before either one of those is there, you need to have the wireless card powered on (for example laptops have a button to power it on) and then a correct, working driver for the wireless device installed and loaded (a kernel module which needs to be modprobe'd before it works, should be loaded during boot).

Code:
lsmod
This lists the loaded modules (except for those built directly into the kernel). See if your wireless driver is mentioned; otherwise you need to use modprobe as root to load it.

EDIT:
Quote:
i use the same wireless thing its a major pain infact 70% or more are never gonna work on linux because of the chipset its just not compatible
That's not true; a device is not Linux compatible or not, either there is a working driver for it, or then not - and if not, then it's a matter of somebody writing it. I don't know of any wireless device that would not work with Linux no matter what. It's simply a matter of having a correct driver and configuration.

Last edited by b0uncer; 09-09-2007 at 11:22 AM.
 
Old 09-09-2007, 11:30 AM   #5
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Rep: Reputation: 30
well im sorry then what i meant is that a working driver for the dominant chipset of that model number (yes the company made 2 chipsets for the exact same model) has not been written yet

in other words its not compatible right now but i dont think its popular enough for there to be much of a reson to write a driver for it..... for it will be obsolete very soon
 
Old 09-09-2007, 11:31 AM   #6
intheshadows
Member
 
Registered: Sep 2007
Location: United Kindom
Distribution: Fedora 11, Yellow Dog Linux (PS3 Version)
Posts: 39

Original Poster
Rep: Reputation: 15
not sure what to look for

i typed lsmod but im not sure what to look for and its not got the driver installed yet

Edit i tried using BCMRNDIS.INF it installed the driver but didnt work

Last edited by intheshadows; 09-09-2007 at 11:34 AM.
 
Old 09-09-2007, 11:40 AM   #7
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Quote:
i typed lsmod but im not sure what to look for and its not got the driver installed yet
Ok you can forget lsmod until the driver's installed..are you trying to use NDISwrapper to get it working (one of your best chances right now I guess)? If so, first install ndiswrapper and ndiswrapper-utils. Should be available trough yum (or use your graphical package manager - launch from the menu!). After installing ndiswrapper (as new versions of any packages available for it), obtain the right Windows drivers for the wireless card (you need a .inf and .sys file from the driver package; you may need to do some work to find them), put them into some directory, then open a terminal and use 'cd' command to move to that directory, and install the drivers for NDISwrapper like this:
Code:
su
<type your root password and press ENTER>
/sbin/ndiswrapper -i windows-driver-file.inf
If it went ok, see if it's working:
Code:
/sbin/ndiswrapper -l
should tell you that driver is loaded and hardware is present. Otherwise the driver is probably wrong. If it went all right,
Code:
/sbin/ndiswrapper -m
and see if it now works
 
Old 09-09-2007, 11:44 AM   #8
intheshadows
Member
 
Registered: Sep 2007
Location: United Kindom
Distribution: Fedora 11, Yellow Dog Linux (PS3 Version)
Posts: 39

Original Poster
Rep: Reputation: 15
okay thanks i tried yum install ndiswrapper and after some output it said nothing to do
 
Old 09-09-2007, 11:49 AM   #9
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Ok, then download the rpm files from rpm.pbone.net; if you're using a 32-bit Fedora 7, download this file or if you're using 64-bit, then download this file. Once done, double-click on it and see if it installs..if not, try to get the depending packages off yum.

Last edited by b0uncer; 09-09-2007 at 11:50 AM.
 
Old 09-09-2007, 12:10 PM   #10
intheshadows
Member
 
Registered: Sep 2007
Location: United Kindom
Distribution: Fedora 11, Yellow Dog Linux (PS3 Version)
Posts: 39

Original Poster
Rep: Reputation: 15
when i have the drivers in a folder do i use make then make install then use ndiswrapper -i
 
Old 09-09-2007, 01:39 PM   #11
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
no make and make install, just install them with ndiswrapper -i
 
Old 09-09-2007, 01:49 PM   #12
intheshadows
Member
 
Registered: Sep 2007
Location: United Kindom
Distribution: Fedora 11, Yellow Dog Linux (PS3 Version)
Posts: 39

Original Poster
Rep: Reputation: 15
how do i Disable config 4stacks option, recompile and install kernel
 
Old 09-09-2007, 01:54 PM   #13
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
you don't need do that, my wireless drivers worked fine without doing that
 
Old 09-09-2007, 03:25 PM   #14
intheshadows
Member
 
Registered: Sep 2007
Location: United Kindom
Distribution: Fedora 11, Yellow Dog Linux (PS3 Version)
Posts: 39

Original Poster
Rep: Reputation: 15
right ive install the driver

[root@localhost bcmrndis]# ndiswrapper -l
bcmrndis : driver installed
device (050D:7051) present (alternate driver: rt2500us

[root@localhost bcmrndis]# ndiswrapper -m
adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper ...
[root@localhost bcmrndis]# ifconfig wlan0 up
wlan0: unknown interface: No such device


but it shows no wireless extensions how do i set it to wlan0

Last edited by intheshadows; 09-09-2007 at 03:38 PM.
 
Old 09-09-2007, 09:25 PM   #15
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
you need to run
modprobe ndiswrapper
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 08:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration