LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-23-2012, 09:23 PM   #31
priya86mohanty
Member
 
Registered: Apr 2012
Posts: 33

Rep: Reputation: Disabled
#30


Ok. I removed ns-allinone-2.28 and tried installing ns-allinone-2.31. Followed the below procedure for installation:
1) sudo ln -s i386-linux-gnu/asm/
2) sudo apt-get update
3) sudo apt-get install linux-libc-dev
4) sudo apt-get install g++ autoconf automake libtool libxmu-dev
5) tar xvf ns-allinone-2.31.tar.gz
6) cd ns-allinone-2.31/
7) ./install

I got the error as:
otcl.o: In function `OTclDispatch':
/home/xyz/ns-2.31/ns-allinone-2.31/otcl-1.13/otcl.c:495: undefined reference to `__stack_chk_fail_local'
otcl.o: In function `Otcl_Init':
/home/xyz/ns-2.31/ns-allinone-2.31/otcl-1.13/otcl.c:2284: undefined reference to `__stack_chk_fail_local'
ld: libotcl.so: hidden symbol `__stack_chk_fail_local' isn't defined
ld: final link failed: Bad value
make: *** [libotcl.so] Error 1
otcl-1.13 make failed! Exiting ...
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems


a) How to correct it? What is the gcc version needed for ns-2.31? For ns-2.28, I had used gcc410. Does it work with ns-2.31 also or is it different?
b) And why is that wimax 1.02 / ns-2.28 is not working with the tcl examples? Is it like this combination does not work on Ubuntu 11.04 or irrespective to any platform it'll not work?
c) Also let me know about "ns231-wimax203-i686" that you have provided for download. How am I supposed to install it with ns-2.31 after ns-allinone-2.31 is installed successfully?

Thanks.

Quote:
Originally Posted by knudfl View Post
# 29.

That's right, wimax 1.02 / ns-2.28 doesn't work with the two tcl examples.
Wimax version 2.03 for ns-2.31 : OK.

.

Last edited by priya86mohanty; 05-23-2012 at 09:44 PM.
 
Old 05-24-2012, 04:02 AM   #32
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,283

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
# 31.

Ns-allinone-2.31 : gcc / g++ version 4.1 will work.
The reason to show the "ns231-wimax203-i686" :
I used a 'dirty trick' to compile it : ns-2.31/packmime/* failed,
so I copied the five packmime/<file>.o from an unpatched ns-2.31.

The binary will work as a standalone, when you have /home/<name>/lib/,
where "lib/" is the lib/ folder from a compiled ns-allinone-2.31/lib/.
Tested OK with the two example*.tcl on an OS with no other ns2 than "lib/"


P.S. : How did you make / get a gcc410, that works on Ubuntu 11.04 ?
(I used the home made g++41-compat-4.1.2_i386.deb, gcc41-compat-4.1.2_i386.deb
once created on a clean install of Ubuntu 11.04 with no updates.)

.

Last edited by knudfl; 05-24-2012 at 04:37 AM.
 
Old 05-24-2012, 04:44 AM   #33
priya86mohanty
Member
 
Registered: Apr 2012
Posts: 33

Rep: Reputation: Disabled
#31

Can you please provide me the steps that I need to carry out? g++41-compat-4.1.2_i386.deb, gcc41-compat-4.1.2_i386.deb should be installed first is it? Before even ns-2.28 is installed on Ubuntu 11.04?
The link which I referred for gcc compilers is "http://www.linuxquestions.org/questions/linux-software-2/how-to-integrate-the-resource-energy-leach-class-into-ns-2-34-a-870368/page13.html". The downloadable given there are to be used no?

Quote:
Originally Posted by knudfl View Post
# 31.

Ns-allinone-2.31 : gcc / g++ version 4.1 will work.

P.S. : How did you make / get a gcc410, that works on Ubuntu 11.04 ?
(I used the home made g++41-compat-4.1.2_i386.deb, gcc41-compat-4.1.2_i386.deb
once created on a clean install of Ubuntu 11.04 with no updates.)

.
 
Old 05-24-2012, 05:07 AM   #34
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,283

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
# 33
http://www.linuxquestions.org/questi...68/page13.html
> post # 181

Yes, those two packages have been available for about a year.
( Google will find them easily too.)
Will work with ns-allinone, versions 2.26, 2.27, 2.28, 2.29, 2.30, 2.31, 2.33, 2.34.
( 2.26, 2.27, 2.28 with a "gcc410-patch" ).

.

Last edited by knudfl; 05-24-2012 at 05:10 AM.
 
Old 05-24-2012, 05:15 AM   #35
priya86mohanty
Member
 
Registered: Apr 2012
Posts: 33

Rep: Reputation: Disabled
#34

I have 2 patches with me. ns228-gcc40[1].patch and ns-2[1].28-gcc410.patch. Will patching these two files work or should I patch just the later one only?

Quote:
Originally Posted by knudfl View Post
# 33

Will work with ns-allinone, versions 2.26, 2.27, 2.28, 2.29, 2.30, 2.31, 2.33, 2.34.
( 2.26, 2.27, 2.28 with a "gcc410-patch" ).

.
Attached Files
File Type: txt ns228-gcc40[1].patch.txt (4.2 KB, 2 views)
File Type: txt ns-2[1].28-gcc410.patch.txt (15.6 KB, 2 views)
 
Old 05-24-2012, 06:29 AM   #36
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,283

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
# 35 : ns-allinone-2.28 for Ubuntu , both patches.

Please see post #15 here ...
http://www.linuxquestions.org/questi...4-a-842773/#15
 
Old 05-24-2012, 04:24 PM   #37
tanveer_ahmed
LQ Newbie
 
Registered: May 2012
Posts: 2

Rep: Reputation: Disabled
Hello everyone. I am facing a problem in running the Network Animator (nam package) when installing ns2. While I run "./configure" it says that "failed to open shared file libotcl.so". And so if i enter the "make" and "make install" it doesn't work. That means my nam is not installed. I don't know how to recover this problem. I have successfully installed ns2 in my Red Hat Enterprise 6 and i can simulate and get an output file(like .tr). But the tcl files that are written to run the nam i. e. network animator also, it doesn't run. But it is compiled and gives the output file(in .tr). Can anyone please help me in this case? I really need to install nam package. I am a bit new user in RedHat Enterprise 6. I have installed the required and optional packages except Xgraph. Because installing Xgraph also shows some errors. But first can anybody help me installing nam-1.14.i386.rpm this package please? I would be grateful.
 
Old 05-24-2012, 04:51 PM   #38
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,283

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Post # 37, @tanveer_ahmed : Welcome to LQ.

Better use a well tested static nam : No dependencies are required.
And : I don't know the referred rpm package, which is also unknown by Google.

Nam i586 : https://docs.google.com/open?id=0B7S...k4NGI5NzliM2Ux
>> nam-1.14.i586.tar.gz : unpack, and 1) su 2) cp nam /usr/local/bin/


Xgraph is never built in any ns-allinone-2.xx .
Building xgraph from source : Post # 2 here ..
http://www.linuxquestions.org/questi...34-a-862233/#2

.
 
Old 05-24-2012, 05:24 PM   #39
tanveer_ahmed
LQ Newbie
 
Registered: May 2012
Posts: 2

Rep: Reputation: Disabled
Thank you so much for that file in google docs. It was so kind being helped. I am happy and grateful. Thank you so much....
 
  


Reply

Tags
nam, ns2, wimax


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ns2- network simulator problem vivekr Linux - Networking 5 02-16-2011 01:25 PM
HP UX simulator Rahul Kolan Linux - Software 3 08-08-2008 02:48 AM
Simulator Vampyre_2099 Linux - Games 1 02-27-2008 10:07 AM
joystick problem with gl-117 flight simulator vaisarger Linux - Games 1 07-06-2006 05:12 AM
Problem with insatlling a Simulator-undefined symbol flock invinciblemk Linux - Software 0 03-23-2004 11:06 AM


All times are GMT -5. The time now is 01:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration