LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 11-29-2004, 10:17 PM   #1
cykoburn
LQ Newbie
 
Registered: Nov 2004
Posts: 18

Rep: Reputation: 0
new nividia driver installation


I recently downloaded new nvidia drivers for my nvidia video card (just installed slackware 10 also). Then i ran the installation for the drivers. It tell me that is cannot get new drivers from the ftp site so it has to rebuild the Kernel itself. id does this and gets to 100% and says done above the bar. now it says its done but just sits there. im not sure if this is normal or not but it did't seem to have any affect on my computer. any help?
 
Old 11-29-2004, 11:41 PM   #2
Psycho
Member
 
Registered: Feb 2002
Location: Carson City, Nevada
Distribution: Gentoo / SuSE 9.1 Pro (both A64)
Posts: 159

Rep: Reputation: 30
You'll need to insert the new module. As su do 'modprobe nvidia'. Don't forget to make the edits in your X config file. /etc/X11/XF86Config or xorg.conf depending on which you're using. Comment out with # in the driver section load "opengl" and load "dri", and make sure it has load "glx". In the device section for the video card change Driver "nv" or 'vesa" to Driver "nvidia"

I don't know where to autoload modules for Slack, so you'll have to find that yourself, unless a Slacker can shed a little light there

Hope that helps,
--glenn
 
Old 11-30-2004, 12:41 AM   #3
redjokerx
Member
 
Registered: Aug 2004
Location: San Diego
Distribution: Slackware
Posts: 303

Rep: Reputation: 31
/etc/rc.d/rc.modules
 
Old 11-30-2004, 01:56 AM   #4
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
You do not need to place a line in /etc/rc.d/rc.modules because if you look at it closely it access /etc/modules.conf too. Just place

alias char-major-195 nvidia
alias /dev/nvidia* nvidia

in /etc/modules.conf. The nvidia installer may have added those lines already.
 
Old 11-30-2004, 11:32 PM   #5
cykoburn
LQ Newbie
 
Registered: Nov 2004
Posts: 18

Original Poster
Rep: Reputation: 0
i fixed problem i was having. thanx for all your help

I was installing the wrong linuxdrivers because there are specific drivers for Athalon 64 processors. also i ran xorgsetup which seemed to fix most of my problems. if you have an athalon 64 chip and are having the same problem post a message here and ill help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nividia drivers for Suse9.1 Shamgar Linux - Newbie 1 02-14-2005 04:45 PM
rivafb module interferes with nividia.... deft Linux - Software 3 09-03-2004 06:02 AM
Maya Linux on Nividia, refresh problem somushiv Linux - Software 1 05-21-2004 11:00 PM
nividia driver compatibility SLaCk_KiD Linux - General 3 07-25-2003 07:35 PM
Nividia Driver Problems subservant Linux - Hardware 21 02-21-2003 06:36 PM


All times are GMT -5. The time now is 09:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration