LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-07-2004, 05:34 PM   #1
Trey2501
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 26

Rep: Reputation: 15
New MPlayer errors - command line works, GUI doesn't


OK, I got Mplayer to work originally using rpms, but decided to install it from source to get codecs and video card recognition. I got it to compile with gui-enabled, got it to make, got it to make install, when I try and execute gmplayer to view videos, I get the following message:

Code:
Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/trey/.mplayer/config
[cfg] read config file: /home/trey/.mplayer/gui.conf
Reading config file /home/trey/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
xscreensaver_disable: Could not find xscreensaver window.
Reading /home/trey/.mplayer/codecs.conf: Can't open '/home/trey/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/trey/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/trey/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
gmplayer: relocation error: /usr/lib/libgdk-1.2.so.0: undefined symbol: XListInputDevices
I can play videos with no problem from the command line using mplayer -vo xv (movie), but not using gmplayer. Help!!! I feel like the codecs and timing errors are not what is the problem here, it's the "input devices."
 
Old 03-07-2004, 05:39 PM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
try recompiling
 
Old 03-07-2004, 05:40 PM   #3
Trey2501
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 26

Original Poster
Rep: Reputation: 15
Also, I just copied the default input.conf from the MPlayer/etc install directory to /usr/local/share/mplayer/ and I still get the same last error about and undefined symbol.
 
Old 03-07-2004, 05:47 PM   #4
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
All the messages above "gmplayer: relocation error: /usr/lib/libgdk-1.2.so.0: undefined symbol: XListInputDevices" are normal, its just looking for personalized config files.
Looks like it has something to do with gtk1 library, see if recompiling helps first.
 
Old 03-07-2004, 05:54 PM   #5
Trey2501
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 26

Original Poster
Rep: Reputation: 15
OK, I just recompiled and got the same error. Perhaps I need another version of gtk? I have 1.2.0 and 2.2.0 installed. (But I was told that 2 is different from 1 and shouldn't affect it)
 
Old 03-07-2004, 06:04 PM   #6
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
It compiles fine on my system with 1.2.10, but instead of trying to upgrade it which may break things, try this patch
http://demonbane.org/mplayer-1.0-gtk2.patch
it enables you to compile mplayer gui with gtk2
cd to where you extracted Mplayer, then
Code:
patch -p1 < /path/to/mplayer-1.0-gtk2.patch
then ./configure --enable-gtk2 --enable-gui
 
Old 03-07-2004, 07:18 PM   #7
Trey2501
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 26

Original Poster
Rep: Reputation: 15
God, this has gone from bad to worse!

OK, I patched that file, but it inserted some lines in config.mak that say "Perhaps you should add the directory containing `gtk+-2.0.pc' to the PKG_CONFIG_PATH environment variable." So, I went to verify that I had gtk+-2.0 installed:

whereis gtk+-2.0 produced no results, so I downloaded the source for gtk+ 2.2.3 and went to install it. It told me my glib-2.0 dependencies were not met. So, I installed glib-2.2.3, and went back to configure gtk+-2.2.3. It gives me this message:

Code:
error: Library requirements (glib-2.0 >= 2.1.4 atk >= 1.0.1 pango >= 1.0.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
I looked and both glib and pango are installed, so I figured it must be atk that isn't installed. I went to configure atk-1.2.4, and got the following error message:

Code:
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
Executing grep glib config.log gives:

Code:
configure:9786:18: glib.h: No such file or directory
configure:9792: error: `glib_major_version' undeclared (first use in this function)
configure:9792: error: `glib_minor_version' undeclared (first use in this function)
configure:9792: error: `glib_micro_version' undeclared (first use in this function)
| #include <glib.h>
|  return ((glib_major_version) || (glib_minor_version) || (glib_micro_version));
Doing a whereis glib.h shows that it is in /usr/lib/glib/

WHAT THE HECK IS GOING ON HERE? Sorry for the long post, but I'm trying to provide as much information as possible.
 
Old 03-07-2004, 07:25 PM   #8
Trey2501
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 26

Original Poster
Rep: Reputation: 15
pkg-config --list-all does not show a glib-2.0, but it shows a glib.

So apparently glib-2.0 installed itself incorrectly? Recompiling does not solve this.
 
Old 03-07-2004, 07:59 PM   #9
Trey2501
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 26

Original Poster
Rep: Reputation: 15
OK, fixed a bunch of errors, recompiled a whole bunch of stuff and now gmplayer works without a hitch.

Thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running MPlayer from the GUI, not the command line... xbill311x Linux - Software 14 03-28-2005 09:08 PM
MPlayer GUI errors ShadowMetis Linux - Software 10 12-08-2004 06:02 PM
mplayer works in command but I can't get it in GUI jsandro7 Linux - Newbie 12 12-23-2003 11:39 AM
mplayer works, gui problematic nithinkd Linux - Software 3 10-28-2003 05:59 PM
mplayer - command line and gui esteeven Linux - Software 7 12-06-2002 07:38 PM


All times are GMT -5. The time now is 01:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration