LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-01-2005, 07:21 AM   #1
jeffk42
Member
 
Registered: Mar 2005
Location: Orlando, FL USA
Distribution: Fedora Core 13 x86_64 / RHEL 5.3
Posts: 76

Rep: Reputation: 15
New laptop, several related problems...


I just got a new Compaq R3200Z this week. Split the drive up and installed Fedora Core 3. I selected the Generic LCD 1280x800, which I knew wasn't going to work right away, based on the threads I've read.

Unfortunately, many of these threads make references to XFree86Config, which I don't seem to have.

I downloaded the latest nvidia drivers (released yesterday, I think), and I'm trying to install them, so at least I have a starting point. But I can't install with gdm running. If I stop it, it starts right back up. Not to mention, when I switch to console mode via Ctrl+Alt+F1, the screen goes crazy and any text is unreadable. The same thing happens during shutdown, but not during startup at any point.

Right now I'm using the Generic NVidia drivers that installed with FC3. The screen is runnning at 1024x768. Gnome looks fine, just a little stretched out. The only problem is with the command line.

So...

Should I install the NVidia drivers before I try to fix the resolution problem? If so, how do I go about getting to console without ever starting up Gnome? And once I do have the drivers installed, what's next, considering I don't seem to have XFree86Config?

Thanks for your help. I'm new, but I'm learning.


Edit: BTW: video is an NVidia Geforce4 440 Go, CPU is an Athlon 64 3700+, and I'm running 2.6.10-1.770_FC3 x64

Last edited by jeffk42; 04-01-2005 at 07:27 AM.
 
Old 04-01-2005, 07:39 AM   #2
0pal_t0ad
Member
 
Registered: Feb 2004
Location: Southampton, England
Distribution: Laptop:Gentoo-i686-2.6.9-r9 Desktop:Slackware10 2.4.26
Posts: 298

Rep: Reputation: 30
From the top, if you don't have XFree86Config, then you're using Xorg(which is very popular at the mo') /etc/X11/xorg.conf

to get into command line mode, edit your /etc/inittab and look for a line that says something about 'Default run level' and change the number 3 to 5, or is it the other way around? either way, if it's a 3 then change it to 5 or if it's 3 then change to 5 then when reboot you won't have a GUI logon.

once you have the nvidia driver installed you change inittab again if you want. then you'll need to do a google search for the horizontal/vertical frequencies of the screen and edit xorg.conf accordingly.
 
Old 04-01-2005, 07:43 AM   #3
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,643

Rep: Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539
To go to the command line just type:
Code:
init 3
in an xterm.
Then as root install Nvidia drivers.
Since you don't have XFree86Config edit the /etc/X11/xorg.conf.
Find the line
Quote:
Driver "nv"
and change it to:
Quote:
Driver "nvidia"
To return to X run:
Code:
init 5
 
Old 04-01-2005, 08:27 AM   #4
jeffk42
Member
 
Registered: Mar 2005
Location: Orlando, FL USA
Distribution: Fedora Core 13 x86_64 / RHEL 5.3
Posts: 76

Original Poster
Rep: Reputation: 15
Okay, that worked. Thanks! The console is working fine now.

Although, now my desktop looks all screwed up. What do I need to do to get the 1280x800?

Thanks,
Jeff
 
Old 04-01-2005, 08:57 AM   #5
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
Refer to this link for further details: Essentially it is what the previous post describes but in detail:

http://www.linuxquestions.org/questi...icle&artid=113
 
Old 04-01-2005, 09:08 AM   #6
jeffk42
Member
 
Registered: Mar 2005
Location: Orlando, FL USA
Distribution: Fedora Core 13 x86_64 / RHEL 5.3
Posts: 76

Original Poster
Rep: Reputation: 15
Now when I reboot it gets to 'Configuring kernel parameters' and won't proceed past that point. I have no idea what's going on.
 
Old 04-01-2005, 10:06 AM   #7
jeffk42
Member
 
Registered: Mar 2005
Location: Orlando, FL USA
Distribution: Fedora Core 13 x86_64 / RHEL 5.3
Posts: 76

Original Poster
Rep: Reputation: 15
Okay, there was a problem in the xorg.conf file that was causing the boot to hang. I've got it back to its original settings, and I've started making small changes based on an XF86Config-4 file that a friend has on his laptop (the same model as mine, but running Debian). Nothing I do seems to help the problem though. Basically, the full 1024 pixels displays normally (not stretched), but there's a small black vertical strip starting at 1024 and going about 20-30 pixels. Then there's a small strip (about 10 pixels) that is a repeat of a strip of pixels somewhere in the 800 range. The rest of the screen is black.

At the bottom, it looks like pixels 768 through 800 are repeats of 767. I'm going to get back on it now and post a copy of xorg.conf.
 
Old 04-01-2005, 10:11 AM   #8
jeffk42
Member
 
Registered: Mar 2005
Location: Orlando, FL USA
Distribution: Fedora Core 13 x86_64 / RHEL 5.3
Posts: 76

Original Poster
Rep: Reputation: 15
Okay, here's my xorg.conf.

Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
#	Load  "dri"
	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Modes"

        # Here is the optimal mode: 1280x800 @ 60.0Hz
        # 1280x800 @ 60.00Hz (GTF) hsync: 49.68kHz; pclk: 83.46MHz
	Identifier     "16:10"
	ModeLine     "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "LCD Panel 1280x800"
	#HorizSync    31.5 - 90.0
	#VertRefresh  60.0 - 60.0
	UseModes	"16:10"
	HorizSync	30-90
	VertRefresh	50-75
	Option		"UseEdidFreqs"		"1"
	Option		"FlatPanelProperties"	"Scaling = aspect-scaled"
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "NVidia GeForce4 440 Go 64M"
	Driver      "nvidia"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "NVidia GeForce4 440 Go 64M"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes   "1280x800"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
All of 'Section "Modes"' was added from my friend's XF86Config file. In Section "Monitor" I commented out the stuff that was already in there and everything below those two comments I took from the XF86Config file. None of these changes made any noticeable difference.
 
Old 04-01-2005, 11:39 AM   #9
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
First make a copy of your /etc/X11/xorg.conf
cp /etc/X11/xorg.conf /root
comment out or remove load dri
Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
Load "dri" <---- this
EndSection

I would remove the mode section,the nvidia driver will make up some modes;

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Modes" <-----from here

# Here is the optimal mode: 1280x800 @ 60.0Hz
# 1280x800 @ 60.00Hz (GTF) hsync: 49.68kHz; pclk: 83.46MHz
Identifier "16:10"
ModeLine "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828
EndSection <----to here

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1280x800"
#HorizSync 31.5 - 90.0
#VertRefresh 60.0 - 60.0
UseModes "16:10" <------comment out this
HorizSync 30-90
VertRefresh 50-75
Option "UseEdidFreqs" "1"
Option "FlatPanelProperties" "Scaling = aspect-scaled"
Option "dpms"
EndSection

Section "Device"
Identifier "NVidia GeForce4 440 Go 64M"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVidia GeForce4 440 Go 64M"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x800"
EndSubSection
EndSection

Section "DRI" <----don't
Group 0 <----need
Mode 0666 <----this
EndSection <-------don't leave this,when you remove a section don't do what I have done
before and have two end sections.
See what happens,look at the log /var/log/Xorg.0.log
good luck
 
Old 04-01-2005, 12:45 PM   #10
jeffk42
Member
 
Registered: Mar 2005
Location: Orlando, FL USA
Distribution: Fedora Core 13 x86_64 / RHEL 5.3
Posts: 76

Original Poster
Rep: Reputation: 15
Thanks for the info, but I did what you said, and got no change.

Here's a section of my xorg.0.log:

Code:
(II) Module ddc: vendor="X.Org Foundation"
	compiled for 6.8.1, module version = 1.0.0
	ABI class: X.Org Video Driver, version 0.7
(II) NVIDIA(0): Monitor0: Using hsync range of 29.00-49.00 kHz
(II) NVIDIA(0): Monitor0: Using vrefresh range of 0.00-60.00 Hz
(II) NVIDIA(0): Clock range:  12.00 to 350.00 MHz
(II) NVIDIA(0): Not using mode "1280x800" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x350" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x175" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x400" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x200" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "720x400" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "360x200" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x480" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x240" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x480" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x240" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x480" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x240" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "800x600" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "400x300" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "800x600" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "400x300" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "400x300" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "512x384" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "512x384" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "512x384" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "512x384" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1152x864" (hsync out of range)
(II) NVIDIA(0): Not using default mode "576x432" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x960" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x480" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x960" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x480" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
.
.
.
.
.
Code:
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using mode "1280x800" (no mode of this name)
(II) NVIDIA(0): Not using default mode "1152x768" (width too large for virtual size)
(WW) NVIDIA(0): Not using mode "576x384":
(WW) NVIDIA(0):   horizontal sync start (589) not a multiple of 8
(**) NVIDIA(0): Validated modes for display device DFP-0:
(**) NVIDIA(0):      Default mode "1024x768": 65.0 MHz, 48.4 kHz, 60.0 Hz
(**) NVIDIA(0):      Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(**) NVIDIA(0):      Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(**) NVIDIA(0):      Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz
(**) NVIDIA(0):      Default mode "512x384": 32.5 MHz, 48.4 kHz, 60.0 Hz (D)
(**) NVIDIA(0):      Default mode "400x300": 20.0 MHz, 37.9 kHz, 60.3 Hz (D)
(**) NVIDIA(0):      Default mode "400x300": 18.0 MHz, 35.2 kHz, 56.3 Hz (D)
(**) NVIDIA(0):      Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(--) NVIDIA(0): Display dimensions: (320, 240) mm
(--) NVIDIA(0): DPI set to (81, 81)
I tried it the way you said, plus I tried the suggestions of a guy HERE, but that didn't work either.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
3 grub related problems alvi2 Linux - General 3 03-31-2005 12:23 PM
Laptop Backlight and Modem/Soundcard related ?? cyberjun Linux - Laptop and Netbook 1 03-30-2005 04:52 PM
Two X-related problems SolarBear Linux - Software 1 07-27-2004 01:20 PM
sound and floppy related problems mbacke Linux - Hardware 0 04-10-2004 02:13 PM
Terminal name related problems CARTMAN Linux - Newbie 1 02-13-2002 05:06 AM


All times are GMT -5. The time now is 06:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration