LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-08-2004, 12:37 AM   #1
dongmin
Member
 
Registered: May 2004
Posts: 37

Rep: Reputation: 15
new kernel.. errors.. how to recompile??


i installed debian sarge then dist-up'ed to sid.. then i compiled the new kernel 2.6.6, but it gave me this error:

Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)

i guess i didn't select the file system settings correctly when compiling the kernel..

how would i go about recompiling it?? i can still select the 2.4 at the grub menu that still works.. i need some advice especially in the lines of how to recompile, if it will write over the existing 2.6.6, and if not how i wiould remove the broken one...

thanks a bunch

Last edited by dongmin; 06-08-2004 at 01:12 AM.
 
Old 06-08-2004, 04:11 AM   #2
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
TO recompile a new kernel... well... just the same way you did it the first time :P LOL
OK.... IF you didnt deleted your source files/directories then:
Code:
bash:~$ cd /usr/src
                        (NOTE: create a symlink, use the correct kernel 
                         source folder name, if symlink existed already 
                         remove it and make a new one.)
bash:/usr/src$ ln -s kernel-source-2.4.18 linux
bash:/usr/src$ cd linux
bash:/usr/src/linux$ make xconfig
                (reconfigure your kernel)
bash:/usr/src/linux$ fakeroot make-kpkg clean
                (lots of cleaning here)
                (the value in 'append-to-version' can ve your choice. NO dashes, 
                  all lowercase, keep the dot '.' at the beggining of the value)
bash:/usr/src/linux$ fakeroot make-kpkg --append-to-version=.030401 kernel_image
bash:/usr/src/linux$ su
                 (enter root pasword)
bash:/usr/src/linux#dpkg -i kernel-image-2.6.5.030401_10.00.Custom_i386.deb
but I would highly recomend to read this:
http://newbiedoc.sourceforge.net/system/kernel-pkg.html

Last edited by Qucho; 06-08-2004 at 04:14 AM.
 
Old 06-08-2004, 04:23 AM   #3
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
Forgot to give you a couple of tips.
a) DON'T bother with RAMDISK, will give you more troubles than you need, when in fact you dont need it !!!!!!!!!
RMADISK is used in cases where you are installing/booting from a floppy disk or a CD-ROM.
b) Be SURE you have the filesystem compiled IN the kernel and not as module. This is only relevant for the filesystem used in the hard disk where you are booting Linux from.
c) Mouse, keyboard, VGA/VESA support compiled IN the kernel, not as modules.
d) Even if you have a VESA card you DO need the VGA support too !!!
e) Pray to Saint Tux, and make an ice-cube sacrifice to him.
 
Old 06-09-2004, 01:31 AM   #4
dongmin
Member
 
Registered: May 2004
Posts: 37

Original Poster
Rep: Reputation: 15
thanks! i'll try
 
Old 06-09-2004, 11:30 AM   #5
awreneau
LQ Newbie
 
Registered: Aug 2003
Location: GA
Distribution: Ubuntu
Posts: 29

Rep: Reputation: 15
I'm having the same problem, used make-kpkg and all went well, installed the kernel gave /boot/grub/menu.1st a look all is well.

Reboot and BAM!

Kernel Panic: VFS Unable to mount root fs on unknown_block (0,0)


I've read several time to compile the FS into the kernel and not as a module, however I've not read how to do that exactly, I have chosen the File Systems and all the FS have *'s with them, just to cover myself.

Please advise.

Thanks

Debian Sarge 2.6.6
Dell Latitude C810

Dual booting with XP.

Thanks
 
Old 06-10-2004, 12:20 AM   #6
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
awreneau,

Did you read the little HOW-TO link I posted?
What are you using to configure the kernel; xconfig, menuconfig, or config?
I used xconfig, with that front-end, IN the kernel is a 'check' mark, module is a 'dot' mark.
Are trying to use a RAMDISK ?
So, by your post, I asume you are sure the mounting point in '/boot/grub/menu.lst' is correct.

BTW, took me 32 trials to get my first kernel FULLY customized and fully functional. Not everybody is as dumb as me, so probably will take you less than that
 
Old 06-10-2004, 01:47 AM   #7
dongmin
Member
 
Registered: May 2004
Posts: 37

Original Poster
Rep: Reputation: 15
ok.. i recompiled with the right fs settings (i use ext3.. and i checked EVERY ext3 setting to * ), and then when i boot up, it still gives me the same error! i'm certain that the new kernel was correctly loaded, as i reconfigured some other settings and those showed up in the boot up before the error. what else could be the problem??
 
Old 06-10-2004, 02:13 AM   #8
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
dongmin,
Please read my previous reply.
 
Old 06-10-2004, 03:48 AM   #9
dongmin
Member
 
Registered: May 2004
Posts: 37

Original Poster
Rep: Reputation: 15
i'm using menuconfig.. so an ASTERICKS would mean it is installed in the kernel..
RAMDISK option was UNchecked
the /boot/grub/menu.lst shows that the settings for the newly compiled kernel are exactly the same as kernel 2.4 which still loads.

 
Old 06-10-2004, 04:15 AM   #10
nealkochhar
Member
 
Registered: May 2004
Posts: 56

Rep: Reputation: 15
Count me in on this problem.

Just compiled kernel 2.6.6 on my Slackware 2.4.22. It says that exact same error except instead of (0,0) it's (3,1).


I'm using Lilo and it's setup fine.


Any ideas?
 
Old 06-10-2004, 04:38 AM   #11
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
Ok.. so...
You got the FS built-IN... No RAMDISK...
What about your IDE controlers ?
Quote:
Just compiled kernel 2.6.6 on my Slackware 2.4.22. It says that exact same error except instead of (0,0) it's (3,1).
In GRUB terms...
(0,0) = First IDE, First Partition
(3,1) = Fourth IDE, Second Partition
[edit]
GRUB (0,0) = Linux /dev/hda1
GRUB (3,1) = Linux /dev/hdd2

Last edited by Qucho; 06-10-2004 at 04:41 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Errors Stomatella Linux - Newbie 1 11-25-2004 02:50 PM
Kernel Errors 2.4.26 gamehack Linux - Software 2 05-27-2004 06:58 AM
Errors in my 2.6.1 kernel bluefire Debian 6 02-03-2004 05:34 PM
kernel 2.6.1 and errors shellcode Slackware 1 01-25-2004 11:08 PM
Errors during filesystem check with one kernel while no errors with other kernel Potentials Linux - General 11 12-30-2003 04:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration