LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-09-2015, 09:46 PM   #1
mike6767
LQ Newbie
 
Registered: Jun 2015
Posts: 10

Rep: Reputation: Disabled
New installation of Mint 17 will not boot from HD


New user of Linux Mint and very limited technically. Created mirror disk and went thru installation of Mint ok. I didn't get a restart message at the end of installation but did get a finished message. I restarted the computer and entered the boot menu and changed it to HD from CD Drive. There was another option that I hadn't noticed before....a series of letters..ESC???..not at that computer right now. Anyway I selected HD and no go.
It attempts to boot from CD still after it looks like it has tried to boot from HD. Every thing works slowly from the CD boot so I am thinking the disk I made is ok???
When I go back into the boot menu it still shows as booting from CD Drive. Any help appreciated.
 
Old 06-09-2015, 10:44 PM   #2
Jjex22
LQ Newbie
 
Registered: Jun 2015
Distribution: Ubuntu, RHEL, SLE, #!++
Posts: 16

Rep: Reputation: Disabled
Hi Mike, Welcome to the forums!

I think the first question is how old is the computer? I ask to try and work out if you are using the older BIOS system, or the new UEFI-Bios type. They handle the boot process quite differently. Linux mint can use either, but we may need to change some settings. Have you tried booting the new entry in your boot list? If you have an EFI bios, you will see a new entry in your bios itself.

Also Have you installed Mint as the only OS on the computer, or are there other operating systems there? and if so are you using one hard drive or multiple hard drives?

At the moment what is happening is your computer is looking for what is called a 'boot loader'. When you start your computer your BIOS checks everything is OK, then it goes looking for a boot loader to start your OS with, in the case of Mint this is called 'Grub'. Currently it doesn't know where it is, so even when you select HDD, the system looks through the HDD, doesn't find what it wants, then continues on to the next device - the DVD drive.

Do you remember if you did a 'default install' or 'custom partitioning'? A default install should have configured GRUB correctly for your system, but if you did a custom install it's possible to put Grub anywhere.


JJ

Last edited by Jjex22; 06-09-2015 at 10:48 PM.
 
1 members found this post helpful.
Old 06-09-2015, 11:05 PM   #3
mike6767
LQ Newbie
 
Registered: Jun 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Thanks JJ for the response. I installed Mint as the only OS and only one hard drive. Computer is a HP-Compaq 6000 Pro and is about 5 years old. I took the option to erase the HD when installing. Something about grub did come up at the end of the installation in a DOS like screen. Was not mentioned in the user notes on installation tho.
 
Old 06-09-2015, 11:08 PM   #4
mike6767
LQ Newbie
 
Registered: Jun 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Sorry I forgot to say I did do a default install that said it would remove all previous partitions. Cheers
 
Old 06-09-2015, 11:32 PM   #5
Jjex22
LQ Newbie
 
Registered: Jun 2015
Distribution: Ubuntu, RHEL, SLE, #!++
Posts: 16

Rep: Reputation: Disabled
Ah that makes it a little bit easier. Generally a default install by Mint will wipe the HDD and set up the bootloader. So it's most likely a bios settings issue.


If you enter the BIOS itself, not the boot menu (boot menu is typically a one-time deal) and got to the boot options. (if you can't get into the bios itself, default button presses can be found here)

First thing to notice is if you see any options that say something along the lines of "Legacy mode" or "Secure boot" These are typically on the boot options page, but can also be on the general page you see when you enter the BIOS. IF you can't see them anywhere, you are most likely running a traditional BIOS and going to the boot options page, and setting your HDD to the top of the order should do the trick. Press Esc and save and exit. If that doesn't work we need to use your installer to repair Grub.

If you do see either of those options anywhere in your BIOS, you have the new UEFI BIOS. Make sure that 'Secure Boot' is off. Next there are two options for legacy mode - on or off. Legacy mode tries to recreate a traditional BIOS so your OS won't know you have a new computer. If Legacy mode and secure boot are off, again make sure the HDD is the top of the boot order, Esc and save and exit.

Based on the fact that you saw a new boot entry, I'm half expecting that you'll find the settings 'Secure boot: off' 'Legacy Mode: Off' This means that you are running in UEFI mode. In this mode it isn't enough to tell the BIOS which disk to search for a bootloader, the bootloader itself will be added as a boot device in the boot order and the BIOS will go straight there. If these were the settings during install, mint will have seen this and tried to create an entry in the boot order. On the boot order list, make sure the new entry is selected. This can be made easier if you remove all USB devices, that way you'll only see things like 'Name of HDD', 'Name of DVD drive' 'Network boot' and the other one with the potentially weird name is likely your EFI boot entry.

JJ
 
1 members found this post helpful.
Old 06-10-2015, 01:49 AM   #6
mike6767
LQ Newbie
 
Registered: Jun 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
thanks..I got into the bios and changed the boot order. Doesn't seem to want to hold it tho. Choice of HDD and integrated sata drive to boot from. Tried both but same result. every second time to reboot it boots from the CD. Not all the time tho. Cheers
 
Old 06-10-2015, 06:13 AM   #7
Jjex22
LQ Newbie
 
Registered: Jun 2015
Distribution: Ubuntu, RHEL, SLE, #!++
Posts: 16

Rep: Reputation: Disabled
Hi Mike,

Did you notice whilst you were in there if you had either of the 'Legacy' or 'secure boot' options? Or do you know the age/model of the computer? Just so we can rule out it being a BIOS Settings issue.

Failing that, I'll now assume the install did not proceed correctly. As this was a total erase of the Hard Drive and no data loss is at stake, I'd advise first step is to re-download and reinstall Linux Mint. If redownloading is going to be difficult, you can verify the 'MD5' of the downloaded file. Ubuntu's wiki has a guide for each OS on how to do this here. You get the MD5 number itself from the page where you downloaded linux mint 17. If the number isn't correct, redownload the DVD image, If it is correct, re-burn your DVD.

If you have the same problem again, Then I would recommend using This guide to fix grub after install using your installation CD.

JJ
 
Old 06-10-2015, 06:22 AM   #8
mike6767
LQ Newbie
 
Registered: Jun 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Thanks again...one of my posts seems to have disappeared. Computer 5 to 6 years old and is a HP/Compaq 6000 Pro. I didnt see a Secure boot or Legacy option. I will re download and reinstall Mint and go from there. Thanks again.
 
Old 06-10-2015, 06:59 AM   #9
Jjex22
LQ Newbie
 
Registered: Jun 2015
Distribution: Ubuntu, RHEL, SLE, #!++
Posts: 16

Rep: Reputation: Disabled
Ah I have another HP Slim form factor that uses the same BIOS as that one, it's defintely the classic BIOS type, so long as you've put the HDD at the top of the boot order it'll be fine.

Let us know how you get on with the reinstall, Best of Luck!

JJ
 
1 members found this post helpful.
Old 06-11-2015, 08:18 PM   #10
mike6767
LQ Newbie
 
Registered: Jun 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
I reinstalled Linux Mint. All seemed to go well but at the end the CD player popped out as expected and a DOS like message came up on the screen

[B]Welcome to Linux Mint
*Documentation: http://www.linuxmint.com
mint@mint "$
broadcast message from root@mint
(unknown at 23:21 ....

The system is going down for a reboot NOW!
modem-manager[1230] <info> Caught signal 15, shutting down....

Then it hangs on this screen. It did this last install and I turned the machine off and tried to change the boot sequence to HDD but still was finding CD drive and booting from there. What to do next?????
Cheers, Mike
 
Old 06-11-2015, 08:27 PM   #11
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,165
Blog Entries: 3

Rep: Reputation: 691Reputation: 691Reputation: 691Reputation: 691Reputation: 691Reputation: 691
Quote:
Originally Posted by mike6767 View Post
I reinstalled Linux Mint. All seemed to go well but at the end the CD player popped out as expected and a DOS like message came up on the screen

[B]Welcome to Linux Mint
*Documentation: http://www.linuxmint.com
mint@mint "$
broadcast message from root@mint
(unknown at 23:21 ....

The system is going down for a reboot NOW!
modem-manager[1230] <info> Caught signal 15, shutting down....

Then it hangs on this screen. It did this last install and I turned the machine off and tried to change the boot sequence to HDD but still was finding CD drive and booting from there. What to do next?????
Hi Mike...

Take the CD out of the drive and restart the computer. If if doesn't see any media to boot from, it will move on to the next drive, which should be your hard drive.

Regards...
 
Old 06-11-2015, 09:26 PM   #12
mike6767
LQ Newbie
 
Registered: Jun 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Just as I went to do that I noticed
"unable to connect to system bus:failed to connect to socket/var/run/dbus/system_bus_socket:no such file or directory"

I went ahead and turned the computer off and on without the CD in the drive and the boot order changed but resulted in a blank screen.

Cheers
 
Old 06-11-2015, 09:36 PM   #13
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
Originally Posted by mike6767 View Post
Just as I went to do that I noticed
"unable to connect to system bus:failed to connect to socket/var/run/dbus/system_bus_socket:no such file or directory"

I went ahead and turned the computer off and on without the CD in the drive and the boot order changed but resulted in a blank screen.
Cheers
Did you get a grub menu?
Did the blank screen come after all the boot messages?
If after grub & boot messages it's most likely graphics driver.
 
Old 06-11-2015, 09:51 PM   #14
mike6767
LQ Newbie
 
Registered: Jun 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
I didnt seem to get a grub menu and the blank screen was after the messages when I rebooted it. Should I try and install a graphics driver?
Cheers
 
Old 06-11-2015, 09:51 PM   #15
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,838

Rep: Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822
Let's see if the install worked.
Boot the CD - when you see the "booting in 10 secs" message, hit one of he "arrow" keys; it'll give you a menu of choices. Use the down arrow to highlight the "Boot local system" option, and hit <Enter>. Should boot to your new install.

Open a terminal and enter these, then reboot without the CD - you'll need to enter your password for the first use of sudo.
Code:
sudo update-grub
sudo grub-install /dev/sda
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Linux Mint dual boot installation problems. Valburg Linux - Newbie 14 01-07-2015 02:14 PM
[SOLVED] Can you pleas help me to understand why I cannot boot my new installation of Mint 16 g_s Linux Mint 7 02-19-2014 10:38 AM
MINT fails to show up after installation using dual boot with Windows. wvanes Linux - Newbie 2 01-05-2014 08:46 AM
GRUB boot menu does not appear after installation of Mint 15 mikebaiduu Linux - Newbie 2 12-30-2013 08:01 PM
Tri-boot installation Mint -> Win7 -> XP captainentropy Linux - General 4 03-05-2010 07:05 PM


All times are GMT -5. The time now is 03:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration