LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2009, 08:13 PM   #1
stringtheorem
LQ Newbie
 
Registered: Jan 2009
Location: UK
Distribution: Fedora 10
Posts: 9

Rep: Reputation: 0
New install of Fedora 10 - Problems with Updates


Hi everyone

I've just installed Fedora 10 and have been trying to use the 'Update System' to download all the available updates.

I am told that the 'Packages are not compatible'

The message says:

ERROR with rpm_check_debug vs depsolve:
libgnome-desktop-2.so.7 is needed by gnome-applets-1:2.24.2-2.fc10.i386
libgnome-desktop-2.so.7 is needed by gnome-applets-1:2.24.2-2.fc10.i386
Please report this error at http://yum.baseurl.org/report

What does this mean?

I'm a complete newbie, PLEASE HELP!

Thank you all
 
Old 01-16-2009, 08:24 PM   #2
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Partial messages make it hard to fix, but it's pretty clearly a reportable error (and I see a version has already been reported at the link given).

Since I can't see all the packages you are trying to download, I need to make a guess.

From a terminal session as root, try

yum update --exclude "gnome-desktop*"

and see how that goes
 
Old 01-17-2009, 02:41 PM   #3
stringtheorem
LQ Newbie
 
Registered: Jan 2009
Location: UK
Distribution: Fedora 10
Posts: 9

Original Poster
Rep: Reputation: 0
I've been working on it a bit, trying to install some of the programs it asks for as dependencies, but I'm still not getting anywhere.

I've tried the command line you gave but it is unfortunately still doesnt work

I still get this:-

-
Code:
-> Finished Dependency Resolution
python-iniparse-0.2.3-3.fc9.noarch from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package python-iniparse-0.2.3-3.fc9.noarch (installed)
audit-libs-python-1.7.8-6.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package audit-libs-python-1.7.8-6.fc10.i386 (installed)
libcanberra-0.10-2.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libltdl.so.3 is needed by package libcanberra-0.10-2.fc10.i386 (installed)
1:gedit-2.24.1-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libpython2.5.so.1.0 is needed by package 1:gedit-2.24.1-1.fc10.i386 (installed)
1:gnome-utils-2.25.2-1.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: libgnome-desktop-2.so.11 is needed by package 1:gnome-utils-2.25.2-1.fc11.i386 (rawhide)
libxml2-python-2.7.2-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package libxml2-python-2.7.2-1.fc10.i386 (installed)
1:control-center-2.25.3-2.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: libgnome-desktop-2.so.11 is needed by package 1:control-center-2.25.3-2.fc11.i386 (rawhide)
rpm-python-4.6.0-0.rc1.7.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package rpm-python-4.6.0-0.rc1.7.i386 (installed)
gnome-menus-2.24.1-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package gnome-menus-2.24.1-1.fc10.i386 (installed)
gnome-python2-gtkhtml2-2.19.1-24.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package gnome-python2-gtkhtml2-2.19.1-24.fc10.i386 (installed)
gvfs-1.0.2-3.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libcdio.so.7 is needed by package gvfs-1.0.2-3.fc10.i386 (installed)
libcanberra-gtk2-0.10-2.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libltdl.so.3 is needed by package libcanberra-gtk2-0.10-2.fc10.i386 (installed)
policycoreutils-2.0.57-11.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package policycoreutils-2.0.57-11.fc10.i386 (installed)
4:perl-libs-5.10.0-49.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: perl = 4:5.10.0-49.fc10 is needed by package 4:perl-libs-5.10.0-49.fc10.i386 (installed)
1:gnome-applets-2.25.3-3.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: libgnome-desktop-2.so.11 is needed by package 1:gnome-applets-2.25.3-3.fc11.i386 (rawhide)
gnome-panel-2.25.3-5.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: libgnome-desktop-2.so.11 is needed by package gnome-panel-2.25.3-5.fc11.i386 (rawhide)
gnome-screensaver-2.25.2-2.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: libgnome-desktop-2.so.11 is needed by package gnome-screensaver-2.25.2-2.fc11.i386 (rawhide)
eel2-2.25.1-4.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: libgnome-desktop-2.so.11 is needed by package eel2-2.25.1-4.fc11.i386 (rawhide)
xulrunner-1.9.0.4-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libpython2.5.so.1.0 is needed by package xulrunner-1.9.0.4-1.fc10.i386 (installed)
3:perl-version-0.74-49.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: perl = 4:5.10.0-49.fc10 is needed by package 3:perl-version-0.74-49.fc10.i386 (installed)
setroubleshoot-server-2.0.12-3.fc10.noarch from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package setroubleshoot-server-2.0.12-3.fc10.noarch (installed)
evince-2.24.1-3.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libpoppler-glib.so.3 is needed by package evince-2.24.1-3.fc10.i386 (installed)
cheese-2.25.4-1.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: libgnome-desktop-2.so.11 is needed by package cheese-2.25.4-1.fc11.i386 (rawhide)
rpm-python-4.6.0-0.rc1.7.i386 from installed has depsolving problems
  --> Missing Dependency: libpython2.5.so.1.0 is needed by package rpm-python-4.6.0-0.rc1.7.i386 (installed)
nautilus-2.25.2-6.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: libgnome-desktop-2.so.11 is needed by package nautilus-2.25.2-6.fc11.i386 (rawhide)
setroubleshoot-2.0.12-3.fc10.noarch from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package setroubleshoot-2.0.12-3.fc10.noarch (installed)
gnome-python2-libegg-2.19.1-24.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package gnome-python2-libegg-2.19.1-24.fc10.i386 (installed)
compiz-gnome-0.7.8-10.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: libgnome-desktop-2.so.11 is needed by package compiz-gnome-0.7.8-10.fc11.i386 (rawhide)
orca-2.24.1-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package orca-2.24.1-1.fc10.i386 (installed)
gnome-settings-daemon-2.25.3-2.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: libgnome-desktop-2.so.11 is needed by package gnome-settings-daemon-2.25.3-2.fc11.i386 (rawhide)
Error: Missing Dependency: python(abi) = 2.5 is needed by package orca-2.24.1-1.fc10.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-49.fc10 is needed by package 4:perl-libs-5.10.0-49.fc10.i386 (installed)
Error: Missing Dependency: libgnome-desktop-2.so.11 is needed by package gnome-panel-2.25.3-5.fc11.i386 (rawhide)
Error: Missing Dependency: libgnome-desktop-2.so.11 is needed by package gnome-settings-daemon-2.25.3-2.fc11.i386 (rawhide)
Error: Missing Dependency: python(abi) = 2.5 is needed by package gnome-python2-libegg-2.19.1-24.fc10.i386 (installed)
Error: Missing Dependency: libpython2.5.so.1.0 is needed by package rpm-python-4.6.0-0.rc1.7.i386 (installed)
Error: Missing Dependency: python(abi) = 2.5 is needed by package setroubleshoot-2.0.12-3.fc10.noarch (installed)
Error: Missing Dependency: libgnome-desktop-2.so.11 is needed by package cheese-2.25.4-1.fc11.i386 (rawhide)
Error: Missing Dependency: python(abi) = 2.5 is needed by package rpm-python-4.6.0-0.rc1.7.i386 (installed)
Error: Missing Dependency: libpython2.5.so.1.0 is needed by package 1:gedit-2.24.1-1.fc10.i386 (installed)
Error: Missing Dependency: libgnome-desktop-2.so.11 is needed by package eel2-2.25.1-4.fc11.i386 (rawhide)
Error: Missing Dependency: libcdio.so.7 is needed by package gvfs-1.0.2-3.fc10.i386 (installed)
Error: Missing Dependency: python(abi) = 2.5 is needed by package policycoreutils-2.0.57-11.fc10.i386 (installed)
Error: Missing Dependency: libpython2.5.so.1.0 is needed by package xulrunner-1.9.0.4-1.fc10.i386 (installed)
Error: Missing Dependency: python(abi) = 2.5 is needed by package libxml2-python-2.7.2-1.fc10.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-49.fc10 is needed by package 3:perl-version-0.74-49.fc10.i386 (installed)
Error: Missing Dependency: libltdl.so.3 is needed by package libcanberra-0.10-2.fc10.i386 (installed)
Error: Missing Dependency: libgnome-desktop-2.so.11 is needed by package gnome-screensaver-2.25.2-2.fc11.i386 (rawhide)
Error: Missing Dependency: libgnome-desktop-2.so.11 is needed by package 1:gnome-utils-2.25.2-1.fc11.i386 (rawhide)
Error: Missing Dependency: libpoppler-glib.so.3 is needed by package evince-2.24.1-3.fc10.i386 (installed)
Error: Missing Dependency: libgnome-desktop-2.so.11 is needed by package compiz-gnome-0.7.8-10.fc11.i386 (rawhide)
Error: Missing Dependency: libgnome-desktop-2.so.11 is needed by package 1:gnome-applets-2.25.3-3.fc11.i386 (rawhide)
Error: Missing Dependency: python(abi) = 2.5 is needed by package audit-libs-python-1.7.8-6.fc10.i386 (installed)
Error: Missing Dependency: python(abi) = 2.5 is needed by package gnome-menus-2.24.1-1.fc10.i386 (installed)
Error: Missing Dependency: libgnome-desktop-2.so.11 is needed by package nautilus-2.25.2-6.fc11.i386 (rawhide)
Error: Missing Dependency: python(abi) = 2.5 is needed by package setroubleshoot-server-2.0.12-3.fc10.noarch (installed)
Error: Missing Dependency: python(abi) = 2.5 is needed by package python-iniparse-0.2.3-3.fc9.noarch (installed)
Error: Missing Dependency: libltdl.so.3 is needed by package libcanberra-gtk2-0.10-2.fc10.i386 (installed)
Error: Missing Dependency: libgnome-desktop-2.so.11 is needed by package 1:control-center-2.25.3-2.fc11.i386 (rawhide)
Error: Missing Dependency: python(abi) = 2.5 is needed by package gnome-python2-gtkhtml2-2.19.1-24.fc10.i386 (installed)
[root@localhost Tom]#
I would be really grateful for any help
 
Old 01-17-2009, 03:17 PM   #4
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Why do you have rawhide packages in there? That's Fedora pre-release stuff. Most likely youi've broken your system.

If you haven't done anything other than install F10, I'd be thinking about a re-install and sticking with stable repos.
 
Old 01-17-2009, 03:27 PM   #5
stringtheorem
LQ Newbie
 
Registered: Jan 2009
Location: UK
Distribution: Fedora 10
Posts: 9

Original Poster
Rep: Reputation: 0
I'm a complete Linux newbie, and probably still a little more than incompetent!

I'm going to reinstall and work on it and use only staple repos.

Cool, thanks for your help, I'll post to say how I get on.

Cheers

Tom
 
Old 01-17-2009, 04:13 PM   #6
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Good option I think. Do look into the rpmfusion repos though (I'm guessing trhat's where the rawhide stuff came from), but choose the stable repo.

Rgds
 
Old 01-17-2009, 05:36 PM   #7
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
It's a good idea to use fc10 packages for Fedora 10.
You've said that you will reinstall,if so you can look here how to enable extra free and non-free stable repos for fc10 during installation.
 
Old 01-18-2009, 11:20 AM   #8
stringtheorem
LQ Newbie
 
Registered: Jan 2009
Location: UK
Distribution: Fedora 10
Posts: 9

Original Poster
Rep: Reputation: 0
Yeah, I made a mistake with the non fc10 packages, I did it by accident. As for the rawhide stuff, I do think it came from rpm fusion. Ive done what alan_ri did and I've got a nice copy on rom fusion running.

Thanks a lot!
 
Old 01-18-2009, 11:20 AM   #9
stringtheorem
LQ Newbie
 
Registered: Jan 2009
Location: UK
Distribution: Fedora 10
Posts: 9

Original Poster
Rep: Reputation: 0
Yeah, I made a mistake with the non fc10 packages, I did it by accident. As for the rawhide stuff, I do think it came from rpm fusion. Ive done what alan_ri said and I've got a nice copy on rom fusion running.

Thanks a lot!

Last edited by stringtheorem; 01-18-2009 at 11:23 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora 9 -versus- fedora 8 plus updates maxreason Fedora 9 08-04-2008 08:04 AM
Install Fedora Core 4 Extras or Updates without Internet Connection. jkuzenka Linux - Newbie 7 07-15-2005 09:14 AM
Having problems getting updates on my Fedora Core 1 box with up2date Hockeyfan Linux - General 0 06-29-2004 04:27 PM
Fedora Core 2 (1.91) Problems after updates rstr Fedora 3 04-13-2004 07:39 PM


All times are GMT -5. The time now is 04:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration