LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-05-2007, 05:01 AM   #1
asininity
Member
 
Registered: Apr 2007
Posts: 52

Rep: Reputation: 16
New ext3 partition doesn't mount on boot


I've been stuck on this one for ages can't seem to find the solution. I've blized my vista partition and using gparted turned it into a ext3 partition I can mount the partition manually fine but wanted it to mount on boot. I deleted the vista section from the grub menu I then changed the fstab file correcting the UUID and with the option "auto" which I assumed would now mount the partition when I started the laptop, but no.

Heres my fstab file the underlined bit is what I'm having trouble with:

Code:
# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
#

proc /proc proc defaults 0 0
# Entry for /dev/sda3 :
UUID=8e45368b-ca34-43f6-a5c0-3eb9f28939db / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/sda1 :
UUID=5C6C052B16D9B5D2 /media/sda1 ntfs umask=222,utf8 0 1
# Entry for /dev/sda2 :
UUID=1c5e974e-6386-4f80-96dd-ba67da68b609 /media/Storage ext3 auto 0 1
# Entry for /dev/sda4 :
UUID=1ddb49d5-157b-44a9-9f95-050ad2481da6 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
Can anyone shed some light on how I can get this new ext3 partition to mount automatically on boot?
 
Old 11-05-2007, 08:30 AM   #2
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978
Why don't simply use defaults, which usually comprises auto? Check man mount to see which options are referred by defaults.
 
Old 11-05-2007, 03:48 PM   #3
asininity
Member
 
Registered: Apr 2007
Posts: 52

Original Poster
Rep: Reputation: 16
Thanks for the reply but its working now I've added some more options:

UUID=1c5e974e-6386-4f80-96dd-ba67da68b609 /media/Storage ext3 rw,user,auto 1 1

I tried the "defaults" option and it didn't work for me, however, that was possibly my own fault. I have an a suspicion it might have had something to do with permissions but can't say for certain which is why I put "user" in the options. Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ext3 partition unable to mount majalee Linux - Hardware 4 07-17-2006 10:54 PM
How To Mount An Ext3 Partition ProdicalFlame Linux - Hardware 2 07-14-2006 07:30 AM
mount ext3 partition smiley_lauf Linux - Newbie 4 03-29-2006 08:45 AM
Mount An Existing ext3 Partition br00tal Linux - Newbie 3 06-10-2005 12:08 AM
How to mount an ext3 partition Dopeskills Linux - General 1 08-18-2004 09:35 PM


All times are GMT -5. The time now is 03:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration