LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-21-2002, 09:40 PM   #1
fstreed
Member
 
Registered: Aug 2002
Location: Oregon
Distribution: SuSE 11.3
Posts: 108

Rep: Reputation: 15
new DVD-ROM install


I installed a DVD-ROM today, it works fine under Windows ME so I know the thing works. I am running SuSE 8.0. The DVD is on IDE-2 as slave, there is a CDRW on the same cable as master. I unplugged the analog cable from my CDRW and plugged it into the new DVD. I right clicked and set up a new icon on the desktop. When I go into the "properties" tab there is a whole bunch of stuff listed under "device" none of it works. I have tried listing it as various things, mostly from reading threads on this forum, none of it works. Could anyone give me some simple directions on how to make a simple frigging DVD player work with Linux? I am not a programmer or a geek, just an old hillbilly so keep it simple please.
 
Old 08-21-2002, 09:52 PM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
The actual device name would most likely be (assuming you have 2 drives on Primary cable as well) /dev/hdd

So, you have MANY choices now. Link straight to the DVD with /dev/hdd, or make symlinks to the device. You can add these if you like:
ln -sf /dev/hdd /dev/dvd
ln -sf /dev/hdd /dev/cdrom2

And you can also make directories and additions to your fstab.

Maybe this:
/dev/dvd /mnt/dvd iso9660 defaults 0 0
/dev/cdrom2 /mnt/cdrom2 iso9660 defaults 0 0

to your fstab, and make corresponding directories:
mkdir /mnt/dvd
mkdir /mnt/cdrom2


And finally, restart your X server, and see if they are listed in the drop down now.

Cool
 
Old 08-22-2002, 12:30 AM   #3
fstreed
Member
 
Registered: Aug 2002
Location: Oregon
Distribution: SuSE 11.3
Posts: 108

Original Poster
Rep: Reputation: 15
MasterC,
You say:" So, you have MANY choices now. Link straight to the DVD with /dev/hdd, or make symlinks to the device. You can add these if you like:
ln -sf /dev/hdd /dev/dvd
ln -sf /dev/hdd /dev/cdrom2
And you can also make directories and additions to your fstab.

Maybe this:
/dev/dvd /mnt/dvd iso9660 defaults 0 0
/dev/cdrom2 /mnt/cdrom2 iso9660 defaults 0 0
to your fstab, and make corresponding directories:
mkdir /mnt/dvd
mkdir /mnt/cdrom2"

How and where do I put this stuff? Do I enter it into the shell-konsole? There is something here I am just not getting. I am not sure how to link to something and I can't find this info anywhere. What is a "symlink" and how do I do it? SuSE damn sure don't provide much in the way of instructions. Pardon my ignorance about this but I simply don't know.
 
Old 08-22-2002, 03:10 AM   #4
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
No problem, and I am sorry for making it complicated. man symlink will give you an explaination of what a symlink is, and can do. The first you would just "put into a console" sure. It's the part where you create symlinks to your device. if you don't just copy and paste it, make sure you use the correct letters, it's lowercase LN -SF /DEV/HDD... etc, as shown above.

The second you would add those first two lines to your /etc/fstab file:
dev/dvd mnt/dvd iso9660 defaults 0 0
and the other.

The other part of the second part of instructions is what you will need to do to create the directories to mount your dvd drive to.

Hope that clarifies it a bit, and at least points you towards somewhere to get started on understanding how to setup new devices.

Cool
 
Old 08-22-2002, 07:52 AM   #5
fstreed
Member
 
Registered: Aug 2002
Location: Oregon
Distribution: SuSE 11.3
Posts: 108

Original Poster
Rep: Reputation: 15
MasterC,
It worked! Thanks.
Now I only have one more thing to fix and it will be good to go. The way it is now I can only mount the DVD/CDROM2 while I am logged in as root. When I try to mount it logger in under my user name I get this:

"Could not mount device.
The reported error was:
mount: only root can mount /dev/cdrom2 on /mnt/cdrom2"

Does anyone know how to fix this so I can log in as user?
 
Old 08-22-2002, 08:06 AM   #6
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You're welcome Not too sure on your next issue, I will leave that one for someone who actually knows rather than me giving you suggestions that might not work.

Good Luck, and Happy Linuxing!
 
Old 08-23-2002, 03:14 AM   #7
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Alright, well here are my not so great ideas since no one else has owned up to any:

If the permissions on /dev/cdrom2 and /mnt/cdrom2 say that only root can use em, type the following commands to allow full access by everyone:
chmod 777 /dev/cdrom2
chmod 777 /mnt/cdrom2


You may also want to see if you could just edit your /etc/fstab file to allow users, the entry might look something like:
/dev/cdrom2 /mnt/cdrom2 auto noauto,user,ro 0 0
but can be tailored to fit your needs. see man fstab to find out about the entries there and to change them to fit your needs.

If someone has a better idea, or the right way to fix it, please post it.

Cool
 
Old 08-23-2002, 04:13 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,386

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
the "users" option is the one you're after.
 
Old 08-23-2002, 07:55 AM   #9
fstreed
Member
 
Registered: Aug 2002
Location: Oregon
Distribution: SuSE 11.3
Posts: 108

Original Poster
Rep: Reputation: 15
Thanks MasterC, the users mod in /etc/fstab fixed it so the drive works logged in as user. Now if I can only get my audio problem straightened out I will be one happy little linuxer...
 
Old 08-23-2002, 08:04 AM   #10
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
No problem, but that was Acid who tossed out the correct option. Glad I could though
 
Old 09-17-2003, 03:34 PM   #11
evannextel
Member
 
Registered: Sep 2003
Distribution: Red Hat 9
Posts: 54

Rep: Reputation: 15
You guys wouldn't happen to know what to do for a "No Medium Found" error when im trying to mount a DVD would ya? I know you don't mount dvd's to view the movie, but you can still do it to see the files. It used to work before I installed MPlayer, but now stopped working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slack 10.1 install on sata dvd-rom Hugh Akston Slackware 3 09-29-2005 06:26 PM
New install, cd rom and dvd rom do not work sniperhf Linux - Hardware 3 06-08-2004 05:24 PM
Creative DVD-ROM doesn't install Joe_Bogarde Slackware 5 02-11-2004 11:09 PM
newbie: how to install dvd/cdrw combo rom? sirpelidor Linux - Hardware 4 11-16-2003 06:02 AM
how to add cd-rom, dvd-rom, floppy, hard disk icons on gnome desktop? spyghost Linux - Software 6 09-21-2003 05:44 PM


All times are GMT -5. The time now is 05:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration