LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-27-2007, 09:54 PM   #1
wadesmart
Member
 
Registered: Jul 2005
Location: Oklahoma
Distribution: Ubuntu
Posts: 72

Rep: Reputation: 15
New Dovecot Install: auth(default) Need one userdb


I have been working on learning dovecot and installing it. I have asked for help in 13 lists with out any help yet.

I following the wiki on dovecot for a basic configuration.

wadesmart@wadesmart:~$ sudo dovecot -n
Password:
# /etc/dovecot/dovecot.conf
log_timestamp: %Y-%m-%d %H:%M:%S
protocols: imap
disable_plaintext_auth: no
login_dir: /var/run/dovecot/login
login_executable: /usr/lib/dovecot/imap-login
mail_extra_groups: mail
mail_location: ~/Maildir
maildir_copy_with_hardlinks: yes
auth default:
passdb:
driver: passwd-file
args: /etc/dovecot/passwd.dovecot
wadesmart@wadesmart:~$

Following the instructions of the tutorial I try to start dovecot and I receive this error:

Apr 27 21:33:53 wadesmart dovecot: auth(default): You'll need to add at least one userdb
Apr 27 21:33:53 wadesmart dovecot: child 9839 (auth) returned error 89
Apr 27 21:33:53 wadesmart dovecot: Temporary failure in creating login processes, slowing down for now

Im just not understanding what Im to add.

wade
 
Old 04-27-2007, 10:25 PM   #2
wadesmart
Member
 
Registered: Jul 2005
Location: Oklahoma
Distribution: Ubuntu
Posts: 72

Original Poster
Rep: Reputation: 15
I found this page in the wiki http://wiki.dovecot.org/AuthDatabase/PasswdFile

and it says to create a passwd and userdb file like so:

user:{plain}pass:1000:1000::/home/user::userdb_mail=maildir:~/Maildir

and so I did. Didnt help with the messages. Still saying I need a userdb file.
 
Old 04-28-2007, 07:58 AM   #3
wadesmart
Member
 
Registered: Jul 2005
Location: Oklahoma
Distribution: Ubuntu
Posts: 72

Original Poster
Rep: Reputation: 15
I fixed the userdb error after a few hours of reading.

One last thing, when I telnet in to check if it was running, I checked the Inbox like the tutorial said to and it said 10920 exists, 889 recent.

I havent been able to read my mail since I have been doing this but fetchmail has getting it for me. My /Maildir/new had 889 and now it has 1. What just happened to my email?

wade
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail seems not to use default-auth-info DieSpeedy Linux - Software 8 07-30-2009 07:38 AM
LXer: Install and Configure Auth Shadow on Debian/Ubuntu LXer Syndicated Linux News 0 02-23-2007 03:46 PM
Dovecot Install and Run issues crocks21 Linux - Software 1 05-25-2005 08:43 AM
SMTP Auth issue with Dovecot in debian fidelis Debian 0 09-28-2004 06:07 PM
How to install linux on a no-default-install-kernel-compatible controller ? DukeMC Linux - Hardware 2 11-20-2003 03:37 AM


All times are GMT -5. The time now is 11:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration