LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-07-2015, 07:58 PM   #1
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
New debian 7.7 non-free install - sound not working.


Hello everyone.
I have just installed debian stable non-free onto my hard drive but the sound isn't working.

I've been to the debian site https://wiki.debian.org/SoundConfiguration and found that 'users' don't automatically have access to audio (for security reasons).
So I did the following command as root (sudo):
Code:
adduser USER_NAME audio
Now when I am 'user', I can get sound.

I also did:
Code:
chgrp cdrom /dev/sr0
adduser USER_ID cdrom
This allows 'user' to get sound from the cdrom.

I then went onto the debian soundfaq https://wiki.debian.org/SoundFAQ

From the 'lspci -v' command, I get these 2 outputs which have the word 'audio' in it:
Code:
01:05.1 Audio device: Advanced Micro Devices [AMD] nee ATI RS880 HDMI Audio [Radeon HD 4200 Series]
	Subsystem: Giga-byte Technology Device 960f
	Flags: bus master, fast devsel, latency 0, IRQ 19
	Memory at fdefc000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 3
	Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
	Kernel driver in use: snd_hda_intel

00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
	Subsystem: Giga-byte Technology Device a102
	Flags: bus master, slow devsel, latency 32, IRQ 16
	Memory at fe024000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Kernel driver in use: snd_hda_intel
So I have 2 sound cards.

The debian website says: 'If sound does not work for root account as well, then that means that either your sound card is not supported by Debian or it was not configured properly'.

Ok, so the first part of the statement is worrying.
So I went to the debian device driver check page http://kmuto.jp/debian/hcl/ and did 'lspci -n'.
The output can be pasted onto their web page and debian will say if the sound cards are supported.
The web page shows that the sound cards are supported:

Quote:
10024383 Yes Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) snd-hda-intel v2.6.25
10029715 Yes Advanced Micro Devices [AMD] nee ATI RS880 [Radeon HD 4250] radeon v2.6.35-
1002970f Yes Advanced Micro Devices [AMD] nee ATI RS880 HDMI Audio [Radeon HD 4200 Series] snd-hda-intel v2.6.27-
So now I'm guessing that my sound cards are 'not configured properly'. But I've run a Youtube video and then changed the sound cards under alsamixer and I still don't get sound.
Is there is a simple solution to this please? Thank you in advance.
 
Old 01-07-2015, 08:09 PM   #2
Teufel
Member
 
Registered: Apr 2012
Distribution: Gentoo
Posts: 510

Rep: Reputation: 120Reputation: 120
By default alsa has all channels muted, did you unmute them?
You can do it with alsamixer.
 
Old 01-08-2015, 03:26 AM   #3
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
What is the output of:
Code:
aplay -l
 
Old 01-08-2015, 04:49 AM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,324
Blog Entries: 1

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
$ cat /proc/asounds/cards

The default card is always zero. Without using pulseaudio you can go a semi-simple route.

FILE: ~/.asoundrc
Code:
defaults.ctl.card 1
defaults.pcm.card 1
defaults.pcm.device 0
Where the 1 is the number of the preferred device as referenced in /proc/asound/cards. And yes users are not autmoatically in the audio group. Not only that but if you do a minimal install, the alsa-base package isn't installed. Technically you only need the defaults.pcm.card line to have audio (that doesn't use OSS aka /dev/dsp) go to the other card.

Edit: and channels are muted by default. alsamixer -c 1

Last edited by Shadow_7; 01-08-2015 at 04:51 AM.
 
Old 01-08-2015, 06:26 AM   #5
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,905

Rep: Reputation: 262Reputation: 262Reputation: 262
If both of these statements are true It shouldn't be a problem as long as you get sound as a user.
Quote:
sound does not work for root
Quote:
Now when I am 'user', I can get sound.
 
Old 01-08-2015, 11:06 AM   #6
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by Teufel View Post
By default alsa has all channels muted, did you unmute them?
You can do it with alsamixer.
Yes, I've pressed the 'm' button to unmute the sound bars.
With F6, when I select the analog sound card - I get a number of sound bars.
But when I select the HDMI sound card there aren't any sound bars - just a small square with S/PDIF underneath.
So I'm wondering if the HDMI card has been configured correctly.
 
Old 01-08-2015, 11:09 AM   #7
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by Head_on_a_Stick View Post
What is the output of:
Code:
aplay -l
It's showing:
Code:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
 
Old 01-08-2015, 11:22 AM   #8
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by Shadow_7 View Post

Where the 1 is the number of the preferred device as referenced in /proc/asound/cards.
This is the output I'm getting:

Code:
/proc/asound# cat cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe024000 irq 16
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfdefc000 irq 19

Last edited by Higgsboson; 01-08-2015 at 11:49 AM. Reason: Repeating myself
 
Old 01-08-2015, 11:47 AM   #9
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by colorpurple21859 View Post
If both of these statements are true It shouldn't be a problem as long as you get sound as a user.
Sorry, I should've been more clear. I used the 'adduser USER_NAME audio' to enable sound to the user. But I still can't get sound for either user or root.

I opened the Synaptic package manager on System Tools and did a search for 'non-free'.
There's options for 'firmware-linux' and 'fglrx' packages which refer to 'non-free ATI/AMD RadeonHD display driver'. These must include my sound card.
But when I installed the packages, I got this error message:

Code:
The fglrx driver is not yet configured. please consider using /usr/bin/aticonfig to create a working xorg.conf configuration.
For example, sudo aticonfig --initial should be sufficient for most use cases
So does this mean I create directory /usr/bin/aticonfig and reinstall those 'non-free' packages?
I can't find an aticonfig directory in /usr/bin/, although I may have deleted it after removing the 'broken' pkg install on synaptic.
 
Old 01-08-2015, 01:06 PM   #10
Teufel
Member
 
Registered: Apr 2012
Distribution: Gentoo
Posts: 510

Rep: Reputation: 120Reputation: 120
Quote:
With F6, when I select the analog sound card - I get a number of sound bars.
But when I select the HDMI sound card there aren't any sound bars - just a small square with S/PDIF underneath.
So I'm wondering if the HDMI card has been configured correctly.
What is your speakers? How do you have them connected to PC?
If you're using regular speakers connected to line output, then nothing to do with HDMI. You should go with HDA ATI SB instead of HDA ATI HDM.

Last edited by Teufel; 01-08-2015 at 01:07 PM.
 
Old 01-08-2015, 01:46 PM   #11
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by Teufel View Post
What is your speakers? How do you have them connected to PC?
If you're using regular speakers connected to line output, then nothing to do with HDMI. You should go with HDA ATI SB instead of HDA ATI HDM.
I have the computer hooked up to a tv.
I think the computer then gives sound from the tv's speaker.

Even so, if I play an mp3 file and then open alsamixer, neither of the sound cards produce sound when I use F6.
 
Old 01-08-2015, 07:23 PM   #12
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,905

Rep: Reputation: 262Reputation: 262Reputation: 262
Have you tried going into system settings>sound to get sound working?
 
Old 01-08-2015, 09:46 PM   #13
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by colorpurple21859 View Post
Have you tried going into system settings>sound to get sound working?
Yes, I've tried that. Essentially it allows me to change sound cards which I've done with rhythmbox running. Still no sound.
On System Tools there's an ATI Catalyst Converter app which I also have on Windows.
But when I open it, I get an error message: 'No AMD graphics driver is installed or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your AMD hardware, or configure using aticonfig.'

But I'm using a new non-free 7.7 debian version on my live USB, which was a successful install, and synaptic seems to be showing all the drivers are installed at boot.
So now I'm wondering how to 'configure using aticonfig'!
 
Old 01-08-2015, 10:04 PM   #14
odiseo77
Senior Member
 
Registered: Dec 2004
Location: Caracas, Venezuela
Distribution: Debian Sid, OpenSUSE 13.2
Posts: 1,147

Rep: Reputation: 506Reputation: 506Reputation: 506Reputation: 506Reputation: 506Reputation: 506
I haven't used a computer connected to a TV, but have you tried connecting a speaker directly to the computer to rule out a problem originated in the computer/TV setup?

(In case you have Windows or another OS installed on your computer and your PC/TV setup works on this other OS, then definitely it's a configuration problem with Debian).
 
Old 01-08-2015, 10:38 PM   #15
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,905

Rep: Reputation: 262Reputation: 262Reputation: 262
edit /etc/modprobe.d/alsa-base.conf and add to the end of the file:

snd-hda-intel model=generic

If you don't have a /etc/modprobe.d/alsa-base.conf create it. If it doen't work then undo.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] debian 8 sound stopped working tikoti Debian 7 12-07-2013 08:14 AM
LXer: Working with FSF on Debian Free-ness assessment LXer Syndicated Linux News 0 07-06-2012 03:40 AM
[SOLVED] Sound Card not working on Debian codeman1234 Linux - Hardware 3 02-14-2010 07:37 PM
Sound not working in Debian. porkertown Linux - Newbie 4 04-19-2008 06:59 PM
Debian sound stopped working HalfDiminished Debian 7 03-07-2005 01:25 PM


All times are GMT -5. The time now is 04:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration