LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-18-2011, 07:31 PM   #1
darkduck
Member
 
Registered: Jan 2011
Location: London
Distribution: Ubuntu, Debian
Posts: 493

Rep: Reputation: 26
Network share only for root?


I have network share which is listed in fstab as
Code:
//fnd/public /fnd cifs noserverino,guest,nolinux,iocharset=utf8,rw	0	0
File fstab is owned by root, as it should be (I believe).
Folder /fnd, when not mounted, is owned by user darkduck.
But once mounted this folder is owned by root.
Hence, I cannot edit, delete, move files within this folder, unless I do something like gksudo nautilus or sudo mc.
I tried to mount adding uid=1000,gid=1000 parameters. This allows me to create files, but not edit or delete them afterwards.

Folder itself is on the external network drive with hardware built-in samba. There is no user/password configuration for access on drive side.

Actually I was able to work normally with this folder until recent. But then situation changed, I don't know why and when.

Same situation for Ubuntu 10.10 and Debian 6.0.

I searched for solution, but only found unresolved topics.
 
Old 03-19-2011, 11:36 AM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi darkduck, Welcome to LQ. Have you tried adding a umask option or dmask & fmask options to your fstab?

Good luck. ;-)
 
Old 03-19-2011, 06:02 PM   #3
darkduck
Member
 
Registered: Jan 2011
Location: London
Distribution: Ubuntu, Debian
Posts: 493

Original Poster
Rep: Reputation: 26
umask option is not available for cifs.
dmode and fmode are deprecated.
Anyway, thanks for the direction.
Sorted issue in Debian with
Code:
//fnd/public /fnd cifs noserverino,nolinux,guest,iocharset=utf8,rw,file_mode=0777,dir_mode=0777	0	0
Will try in (K)Ubuntu. If does not work, will come back.
 
Old 03-19-2011, 06:33 PM   #4
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Glad you got it sorted.

Good luck. ;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to share network files on a Windows network with Ubuntu mollydoggy1971 Linux - Newbie 40 12-01-2008 08:44 AM
mount windows share export to samba share -> improve network performance tuning newuser77 Linux - Server 1 07-23-2008 11:28 AM
root samba share... batfastad Linux - Newbie 2 04-27-2005 10:36 PM
smb share root folder GarroteYou Linux - Networking 3 07-01-2004 11:18 PM
only root can rw my xp share! devfreak Linux - Networking 11 03-23-2004 07:33 AM


All times are GMT -5. The time now is 06:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration