LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-24-2011, 12:00 AM   #1
windstory
Member
 
Registered: Nov 2008
Posts: 486

Rep: Reputation: 36
network settings "your system is not supported" at system settings


I have a problem - network settings "your system is not supported" at system settings.

My box is scientific linux 6.1 x64.

I could not start dhcpd.

Quote:
[root@RedLeoWebDev Documents]# service dhcpd start
Starting dhcpd: [FAILED]
So I opened system settins - network settings, but there is another problem as you can see attatched photo.

How to solve this problem?

Thanks in advance.
Attached Thumbnails
Click image for larger version

Name:	111124_network_problem.jpg
Views:	15
Size:	60.8 KB
ID:	8465  
 
Old 11-24-2011, 12:25 AM   #2
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
I am unfamiliar with Scientific linux, or the settings dialog you are using.

The dialog appears to be for configuring a network interface.
"dhcpd" is for running a DHCP server. Is this what you are trying to do?

Perhaps you want "dhclient" instead?
 
1 members found this post helpful.
Old 11-24-2011, 12:40 AM   #3
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
fukawi1/ I want to start dhcpd.
 
Old 11-24-2011, 12:46 AM   #4
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Code:
tail /var/log/messages | grep dhcpd
should give some more info as to why dhcpd isn't starting.
 
1 members found this post helpful.
Old 11-24-2011, 12:47 AM   #5
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
Te result is here.

Quote:
[root@RedLeoWebDev Documents]# tail /var/log/messages | grep dhcpd
Nov 25 06:57:04 RedLeoWebDev dhcpd: exiting.
[root@RedLeoWebDev Documents]#
 
Old 11-24-2011, 12:48 AM   #6
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7
Posts: 872

Rep: Reputation: 112Reputation: 112
# cat /var/log/messages |grep dhcpd

Last edited by jmc1987; 11-24-2011 at 12:56 AM.
 
1 members found this post helpful.
Old 11-24-2011, 12:56 AM   #7
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Instead of using the init scripts, try starting it from the command line with
Code:
dhcpd -f
 
1 members found this post helpful.
Old 11-24-2011, 01:10 AM   #8
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
The resukt is here.

Quote:
[root@RedLeoWebDev Documents]# dhcpd -f
Internet Systems Consortium DHCP Server 4.1.1-P1
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
Wrote 0 leases to leases file.

No subnet declaration for eth0 (192.168.0.4).
** Ignoring requests on eth0. If this is not what
you want, please write a subnet declaration
in your dhcpd.conf file for the network segment
to which interface eth0 is attached. **


Not configured to listen on any interfaces!

This version of ISC DHCP is based on the release available
on ftp.isc.org. Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.

Please report for this software via the Red Hat Bugzilla site:
http://bugzilla.redhat.com

exiting.
 
Old 11-24-2011, 01:19 AM   #9
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Well there in lies your problem...

Your dhcpd.conf isn't set up correctly.
 
1 members found this post helpful.
Old 11-24-2011, 01:21 AM   #10
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
This is dhcpd.conf.

Quote:
authoritative;
include "/etc/rndc.key";

server-identifier server;
ddns-domainname "myserver.dyndns.org";
ddns-rev-domainname "in-addr.arpa.";
ddns-update-style interim;
ddns-updates on;
ignore client-updates;

zone myserver.dyndns.org {
primary 127.0.0.1;
key rndckey;

default-lease-time 21600;
max-lease-time 43200;

option domain-name "myserver.dyndns.org.";
option ip-forwarding off;
subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.100 192.168.0.200;
option routers 192.168.0.1;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.0.255;
option domain-name-servers 192.168.0.1
zone 0.168.192.in-addr.arpa. {
primary 192.168.0.4;
key rndckey;
}
zone localdomain. {
primary 192.168.4;
key rndckey;
}
}
Please let me know what's wrong.

Last edited by windstory; 11-29-2011 at 12:59 AM.
 
Old 11-24-2011, 01:31 AM   #11
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
How can I tell you what is wrong, when you havent told me what you are trying to do? (other than start dhcpd, which really tells me nothing).

From your config, it would seem you are trying to use dyndns, something I have no experience with. Read "man dhcpd" for info on dynamic dns.

to configure the interfaces dhcpd will listen on, you need to look in /etc/sysconfig
 
1 members found this post helpful.
Old 11-24-2011, 02:10 AM   #12
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
fukawi1/ Thanks for your help.

I'll study man page.
 
Old 11-24-2011, 01:57 PM   #13
tollingalong
Member
 
Registered: Nov 2011
Posts: 42

Rep: Reputation: Disabled
There is an extra "{" in the file I believe to being with.
 
1 members found this post helpful.
Old 11-24-2011, 09:03 PM   #14
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
Looks like he's right about mismatched '{'.
Next time please post using code tags instead of quote tags; that will preserve whitespace and make things line up.
 
1 members found this post helpful.
Old 11-29-2011, 02:14 AM   #15
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
Thanks a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No "connections" tab in network-settings in UbuntuStudio 10.4 getack Linux - Networking 4 08-03-2010 05:17 PM
"Network Settings" problem, KDE Control Center jumapeg Linux - Networking 1 10-13-2006 06:28 AM
Damn Small Linux: network settings "disappear" pelgrimforever Linux - General 0 04-02-2006 03:42 PM
"AMULE" NG :You have a lowid. Please review your network config and/or your settings. j.vilon Linux - Newbie 2 02-12-2005 12:55 AM
all "start\system settings" wont launch anymore. demmylls Linux - General 0 03-12-2004 02:02 PM


All times are GMT -5. The time now is 10:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration