LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-08-2011, 03:01 AM   #1
Sindorius
LQ Newbie
 
Registered: Apr 2011
Posts: 5

Rep: Reputation: 0
Network Problems after each reboot


Hello everyone, just had a quick question that I've been trying to fix.

I just set up ArchLinux on a PC of mine and have been playing around with it learning the ropes. But I seem to have caught an interesting snag concerning my network connection. Just as a note, I'm using DHCP and run my internet through a router.

So everytime i reboot the system, it no longer can connect to the network (pinging websites returns "unknown host" and pinging ip addresses returns "network unreachable"). But once i run "dhcpcd eth0" the network proceeds to work just fine. Do I need to daemonise this or am I doing something wrong in one of my network configuration files?

Any and all help is greatly appreciated.
 
Old 05-08-2011, 03:07 AM   #2
MS3FGX
LQ Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
It sounds like you simply need to configure Arch to use DHCP on your eth0 interface.
 
Old 05-08-2011, 07:49 PM   #3
Sindorius
LQ Newbie
 
Registered: Apr 2011
Posts: 5

Original Poster
Rep: Reputation: 0
Ah yes I had gone through these steps before but executing /etc/rc.d/network restart showed me where I could find the specific problem and solve it. It's working now, thank you for your assistance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
network on reboot qwerty.yp Linux - Networking 2 12-02-2010 12:22 PM
No Network after Reboot patisawsome Ubuntu 3 05-07-2006 11:42 PM
network works only once in each reboot nairnave Linux - Networking 1 09-18-2004 06:15 AM
network down after reboot ZaphyR Linux - Networking 1 08-12-2004 10:00 AM
/etc/sysconfig/network reboot? PlatinumRik Linux - Newbie 3 05-21-2003 03:16 PM


All times are GMT -5. The time now is 03:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration