LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-21-2010, 11:50 AM   #1
hyperbowlingball
LQ Newbie
 
Registered: Jun 2010
Distribution: Debian Lennny
Posts: 5

Rep: Reputation: 0
Network not autoconnecting on boot in Debian Lenny


Hello, all:

I work at a public library, and our OPACs (Online Public Access Catalogs) are running Debian Lenny. They are locked down to loading and visiting one specific webpage through a combination of Kiosktool and Kiosk mode in the Opera browser.

Initially, I had one machine set up with a static IP address, which worked just fine. The static IP is translated at our Firewall to an actual IP address on the outside. However, I had many more machines that I wanted to clone from the working system.

On the cloned machines, the physical network card in the machine shows up in ifconfig as eth1, because it is "remembering" the eth0 network card from the master machine that it was cloned off of.

No problem, I thought, I will just change interfaces to the following:


Code:
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# The primary network interface
allow-hotplug eth1
iface eth1 inet static
	address 192.168.111.5
	netmask 255.255.255.0
	network 192.168.111.0
	broadcast 192.168.111.255
	gateway 192.168.111.254
	
# dns-* options are implemented by the resolvconf package, if installed
	#dns-search srl_public

auto eth1
...replacing eth0 with eth1 in the appropriate places to make it the active card.

Now, however, when I boot these machines, they stick on the boot line

Code:
Starting MTA
for about four minutes, and then loads Debian but does not load a webpage.

I can fix this problem manually, however, by unplugging and then replugging the ethernet cable.

Does anybody know what I might be doing wrong?

Following is the ifconfig output, as well:

Code:
eth1      Link encap:Ethernet  HWaddr 00:60:67:34:09:5f
          inet addr:192.168.111.5  Bcast:192.168.111.255  

Mask:255.255.255.0
          inet6 addr: fe80::260:67ff:fe34:95f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:167431 errors:3 dropped:0 overruns:0 frame:0
      

    TX packets:4443 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:25471107 (24.2 MiB)  TX bytes:614510 (600.1 KiB)
          Interrupt:5 Base address:0x7c00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:129 errors:0 dropped:0 overruns:0 frame:0
          TX packets:129 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8942 (8.7 KiB)  TX bytes:8942 (8.7 KiB)
Thanks in advance!
 
Old 12-21-2010, 06:34 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hi, it seems to be a known issue with Debian that starting the MTA (Mail Transfer Agent) takes a long time (because it fails) if the networkconnection isn't yet established.

As a first attempt I'd try to start the MTA later, after the network has been started.

If you google for "MTA starting" you'll find further iformation (mostly Debian-related).

Markus
 
Old 12-21-2010, 07:58 PM   #3
hyperbowlingball
LQ Newbie
 
Registered: Jun 2010
Distribution: Debian Lennny
Posts: 5

Original Poster
Rep: Reputation: 0
Markus:

Thanks for your response. That partially answers my question, as I wasn't aware about the "known issue" with MTA.

But my problem is still that the network doesn't seem to automatically establish; to get a webpage to load after the boot process is complete, I still have to unplug / replug the ethernet cable.

So how can I automatically start the network? And/or what am I doing wrong that it is not autostarting on computer boot?
 
Old 12-21-2010, 09:02 PM   #4
mahu_mahu
Member
 
Registered: Dec 2007
Location: Japan
Distribution: Debian
Posts: 42

Rep: Reputation: 3
Does the log of your Firewall say anything ?
 
Old 12-21-2010, 10:44 PM   #5
hyperbowlingball
LQ Newbie
 
Registered: Jun 2010
Distribution: Debian Lennny
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by mahu_mahu View Post
Does the log of your Firewall say anything ?
Thanks for your reply. I'll check the logs for sure when I am at work tomorrow. The firewall is actually a Cisco ASA 5505 that covers the entire network. As an experiment (to double check the firewall config) I reassigned the IP address for the master OPAC (the one that functions correctly) to an OPAC that is malfunctioning. The result is that the IP address makes no difference in the functioning of either machine (i.e. all IPs are configured correctly in the firewall), so the problem must source with the particular malfunctioning boxes themselves.
 
Old 12-22-2010, 03:43 AM   #6
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hello hyperbowlingball,

check you startup-scripts. There is any daemonprogram which starts the network. I don't know Debian, but for example with Slackware this is the script /etc/rc.d/rc.inet1.
At first check if you networkscript is executeable and try to find out if this starts automatically or not.
Pay attention to the fact that the network starts as soon as the cable is pluged out and in. It works, but there is an issue with the startscripts. Do you have any additional programs installed, like ifplugd, wicd, networkmanager or other tools for convenient networkmanagement which are actually not used?

Markus
 
Old 12-23-2010, 11:39 AM   #7
hyperbowlingball
LQ Newbie
 
Registered: Jun 2010
Distribution: Debian Lennny
Posts: 5

Original Poster
Rep: Reputation: 0
mahu-mahu:

The log of my firewall does not show anything other than normal traffic. I do not believe it is an issue with the firewall but rather with the configuration of the computers themselves as shown by my IP test above.

markush:

I tried as best I could to check the startup-scripts. My debian does not have an /etc/rc.d/ folder but rather rc.d0, rc.d1, rc.d2, etc. I could not find the rc.inet1 script to which you referred.

I installed rcconf and ran it; all startup options are checked, nothing is left out.

Part of the problem is, I still don't know exactly what I'm looking for. If someone could specifically tell me what to check, I would be glad to do it.

One final thought, it is interesting to note that I'm not the first person on here who has had this problem:

http://www.linuxquestions.org/questi...-lenny-783239/

Keep the advice coming, if you can. Thanks!
 
Old 12-23-2010, 01:04 PM   #8
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Quote:
Originally Posted by hyperbowlingball View Post
I tried as best I could to check the startup-scripts. My debian does not have an /etc/rc.d/ folder but rather rc.d0, rc.d1, rc.d2, etc. I could not find the rc.inet1 script to which you referred.
well, I meant this as an example, I don't have any experience with Debian and don't know how they organize their startup-scripts.
Quote:
...One final thought, it is interesting to note that I'm not the first person on here who has had this problem...
maybe you should post this issue in the Debianforum.

Markus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network doesn't work if cable is plugged in at boot (Debian Lenny) Blue Horseshoe Linux - Networking 1 01-20-2010 06:18 AM
I want the/a newer network manager on Debian Lenny Cyberman Linux - Networking 2 10-03-2009 12:38 PM
ibook G4 - Debian Lenny - Network Manager - ppc BoydRice Debian 2 11-24-2008 09:13 AM
Debian lenny doesn't detect my network card ohadbasan Debian 2 10-23-2008 12:33 PM
debian-lenny install cd1 not seeing network Daveb3 Linux - Networking 1 10-18-2008 03:50 AM


All times are GMT -5. The time now is 04:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration