LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-04-2012, 11:33 AM   #1
ikarus
Member
 
Registered: Jun 2005
Distribution: mandrake 10.1
Posts: 97

Rep: Reputation: 15
network intermittent (linux mint12)


A new install of mint 12 - I first noticed when using firefox often long pauses and delays (several tens of seconds) in acquiring a site, even if it was on my own LAN. After a pause it would behave normally, loading a page at full speed. After more tinkering I noticed similar problems with all network associated activity e.g. accessing the ssh server even from LAN gave similar response and delays.

I had a look at "tail -f syslog which gives me the following over and over:

"Apr 4 20:05:01 z68 CRON[1355]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
Apr 4 20:05:37 z68 kernel: [98116.322039] r8169 0000:03:00.0: eth0: link up
Apr 4 20:10:16 z68 kernel: [98394.409812] r8169 0000:03:00.0: eth0: link up
Apr 4 20:14:58 z68 kernel: [98675.252614] r8169 0000:03:00.0: eth0: link up
Apr 4 20:15:01 z68 CRON[7560]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)"

I'm not sure if this is a clue. Does this indicate that eth0 was in fact down for some reason and then just pops up again?

Can anyone explain these messages and/or point me in the right direction for solving this?

IK

ps z68 is the host name of the machine - it uses a Gigabyte z68 mboard)
 
Old 04-05-2012, 08:09 AM   #2
ikarus
Member
 
Registered: Jun 2005
Distribution: mandrake 10.1
Posts: 97

Original Poster
Rep: Reputation: 15
Further to this on visiting various forums:

Linux Mint 12 and possibly other Ubuntu and derivatives supply the wrong kernel module for the Realtek NIC onboard the Giga-byte motherboard.

The following links apply:

http://unixblogger.wordpress.com/201...ethernet-card/

http://forums.linuxmint.com/viewtopic.php?f=150&t=97619

Hopefully of use to some who have viewed my post - I'll report back with the results on my system.

IK
 
Old 04-07-2012, 06:12 AM   #3
ikarus
Member
 
Registered: Jun 2005
Distribution: mandrake 10.1
Posts: 97

Original Poster
Rep: Reputation: 15
I can confirm that using the correct driver module for the realtek RTL8111/RTL8168 as available now from the realtek download site

http://www.realtek.com.tw/downloads/...etDown=false#2

appears to have solved the networking problem as apparent on the Giga-Byte z68 series main-board.

The module supplied with Linux Mint 12 / 64bit is for RTL8169 and does not work with this board.

IK
 
Old 04-07-2012, 10:23 AM   #4
barnac1e
Member
 
Registered: Jan 2012
Location: Moorhead, Minnesota, USA (birthplace of Slackware, ironically)
Distribution: openSuSE 13.1 - KDE
Posts: 234
Blog Entries: 1

Rep: Reputation: 9
just curious but if that happens again go to terminal as root and type:

# rfkill unblock all

And see if this helps any?
 
Old 04-07-2012, 10:34 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,530
Blog Entries: 2

Rep: Reputation: 4026Reputation: 4026Reputation: 4026Reputation: 4026Reputation: 4026Reputation: 4026Reputation: 4026Reputation: 4026Reputation: 4026Reputation: 4026Reputation: 4026
Quote:
Originally Posted by barnac1e View Post
just curious but if that happens again go to terminal as root and type:

# rfkill unblock all

And see if this helps any?
rfkill is a tool for wireless network devices, this one is wired.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
having problems after doing a dual-boot installation of Linux Mint12 and Windows 7 rvadillo Linux - Newbie 28 03-24-2012 09:58 AM
[SOLVED] About Linux Mint12 Shailendra28 Linux - Newbie 24 01-12-2012 12:40 AM
network has an intermittent fault jcmahne Linux - Networking 4 05-10-2011 04:33 AM
Intermittent Network Connectivity arsci Linux - Networking 1 09-21-2010 02:21 PM
Network connectivity intermittent vaadoo Linux - Networking 11 09-03-2009 08:40 PM


All times are GMT -5. The time now is 11:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration