LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2004, 01:25 PM   #1
ritturaj
LQ Newbie
 
Registered: Jul 2003
Location: New delhi
Posts: 24

Rep: Reputation: 15
network doesn't start at boot


hi,

I had redhat 9.0 and i am facing the problem that the network don,t start at boot but I have to activate the eth0 after boot and I have start the network then.

Everytime I boot i have redo all this stuff .

Can anybody help me and tell me how can i activate eth0 while boot itself.

I shall be very thankful for ur kind help.

ritturaj
 
Old 02-08-2004, 01:32 PM   #2
timmyh33
LQ Newbie
 
Registered: Jan 2004
Location: Minnesota
Distribution: Fedora Core 1, Red Hat 9, Debian 3r2(PA-RISC)
Posts: 6

Rep: Reputation: 0
In redhat 9, you can edit the file /etc/sysconfig/network-scripts/ifcfg-eth0

It should look something like this:

DEVICE=eth0
ONBOOT=no
BOOTPROTO=none
IPADDR=128.???.???.???
NETMASK=255.255.255.0
GATEWAY=128.???.???.???
TYPE=Ethernet
USERCTL=no
PEERDNS=no
NETWORK=128.101.170.0
BROADCAST=128.101.170.255

If you leave everything else the way it is, but change the ONBOOT=no to ONBOOT=yes, then it should start on boot.
 
Old 02-08-2004, 01:52 PM   #3
ritturaj
LQ Newbie
 
Registered: Jul 2003
Location: New delhi
Posts: 24

Original Poster
Rep: Reputation: 15
hi ,

It is already yes in it but it didn't do at the time of booting

here is my file

GATEWAY=??.??.???.???
TYPE=Ethernet
DEVICE=eth0:1
HWADDR=00:0d:60:04:a9:3b
BOOTPROTO=none
NETMASK=255.255.255.192
ONBOOT=yes
IPADDR=??.??.???.???
USERCTL=no
PEERDNS=yes
NETWORK=??.??.???.???
BROADCAST=??.??.???.???

I have to activate eth0 again and agian and restart the network after the boot

ritturaj
 
Old 02-08-2004, 03:38 PM   #4
timmyh33
LQ Newbie
 
Registered: Jan 2004
Location: Minnesota
Distribution: Fedora Core 1, Red Hat 9, Debian 3r2(PA-RISC)
Posts: 6

Rep: Reputation: 0
Hmm..

Check to see that the file /etc/rc.d/rc1.d/K90network (or something with the word network in it's name should be in this directory) is available. If it is there, you can test if it works by typing the command /etc/sysconfig/network-scripts/ifup eth0 (or eth0:1)

If that does work, then there might be a problem with the K90network script.

Also I swear there is a GUI tool in Redhat 9 that you can set if the device starts on boot, but I can't remember where it is. It might just change the ifcfg-eth0 file though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network service start at boot? King of Japan Linux - Networking 2 09-01-2005 11:23 AM
Suse 9.2 network won't start at boot alex2002 Linux - Networking 1 04-21-2005 07:58 PM
how can i start my network card at boot up mio Linux - Networking 1 02-20-2005 01:45 PM
setting network start timeout at boot sayantam Linux - Networking 1 06-10-2004 05:20 AM
Mandrake 10 - Network won't start at boot bluefire Mandriva 5 06-04-2004 08:03 AM


All times are GMT -5. The time now is 05:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration