LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-22-2012, 12:13 PM   #1
whysoserious
Member
 
Registered: May 2012
Location: London
Distribution: Debian and slackware for uni
Posts: 61

Rep: Reputation: Disabled
network config


Hi, I'm using slackware 13.37. I recently installed it and want to get the networking working. If I do ifconfig -a it only shows loopback interface. How do I configure eth0.

The card is atheros 1083.
 
Old 07-22-2012, 12:56 PM   #2
Alchemikos
Member
 
Registered: Jun 2012
Location: Porto Alegre-Brazil
Distribution: Slackware- 14, Debian Wheezy, Ubuntu Studio, Tails
Posts: 88

Rep: Reputation: 6
Quote:
Originally Posted by whysoserious View Post
Hi, I'm using slackware 13.37. I recently installed it and want to get the networking working. If I do ifconfig -a it only shows loopback interface. How do I configure eth0.

The card is atheros 1083.
Are you using the 2.6 kernel?
This kernel not recognize the atheros card automatically.

You have 2 options:

1)Install the kernel module "atl1c"
2) Upgrade the kernel to 3.2 or 3.4

I use the Slack 13.37 and 3.4 kernel

But wiht the newest kernel you must to verify what vga card you use, and made some alterations in case to use nouveau or i915 modules.

Post your:

Code:
# lspci -v
 
Old 07-22-2012, 06:18 PM   #3
whysoserious
Member
 
Registered: May 2012
Location: London
Distribution: Debian and slackware for uni
Posts: 61

Original Poster
Rep: Reputation: Disabled
Hi thanks for the reply. I am using the 2.6 kernel. I loaded the module using modprobe atl1c. Is this right? Lspci shows Ethernet controler : atheros communications device 1083. The other enteries like USB controler show which module or driver is being used but at the end of the Ethernet controler line. There is no mention of a module or driver. Lsmod shows the atl1c module.

Thanks
 
Old 07-22-2012, 08:41 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 12,132
Blog Entries: 14

Rep: Reputation: 3067Reputation: 3067Reputation: 3067Reputation: 3067Reputation: 3067Reputation: 3067Reputation: 3067Reputation: 3067Reputation: 3067Reputation: 3067Reputation: 3067
The Slackbook has a good intro to networking in Slackware: http://www.slackbook.org/beta/#id360936
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot set up network with suse vmware using bridged network config. lxvor SUSE / openSUSE 1 02-08-2009 03:50 PM
REDHAT 6.2 config / modules : usb storage, wired network, x config audan Linux - Hardware 2 02-18-2006 05:23 PM
sendmail for internal network and network config questions RedHat123 Linux - Networking 0 04-06-2005 03:15 PM
how redgat-network-config to windows network arpi Linux - Networking 1 08-10-2004 06:10 PM
possible samba config problem or network config issue? rruffin Linux - Networking 3 06-03-2003 04:04 PM


All times are GMT -5. The time now is 10:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration