LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-31-2008, 02:01 PM   #1
onion
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Rep: Reputation: 0
Network card realtek 8139 big latency and low speed


Hi folks!

First at all, sorry for my bad english...

Problem:
I have old 486amd, 16M ram etc.
AND rtl1839 network card!
At 1rst time i had using slackware 9.1 on 486 like server
But i wonna upgrade in 10.0.
installing...
configuration...
default 8139too driver
bla-bla...

NOW!
I have LAN but I have big latency,
seem to be 1s or more, and speed is about 500b/s
using ssh is almost impossible.
And transfering 1 MB data... Well after 2-3 hours can be done.
I try all, reinstaling system, try to bring back 9.1. recompiling kernel...
But hopeless.
Net Card is OK when is installed on P4 machine.
I just cant figure why is it worked at first time on 9.1.
naturaly i need slackware on this poor machine,
some other distribution is pointless...

Someone can help me?
 
Old 01-31-2008, 03:45 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Hello,

So, you're saying when you first installed slack 9.1 on the i486 the network card worked fine, but then you upgraded to 10.0 and it works but is very laggy. You've also tried to go back to 9.1, but it won't work, not even after compiling a kernel, but the card works ok on a pentium 4 machine. Right ? Just want to make sure I understand.

So, assuming that's true. What's the output of running:
Code:
/sbin/ifconfig
Also, you didn't change anything about the connection except for installing and reinstalling Slackware, right ? (I mean you didn't change some ethernet cables or change a modem or router or change the layout of the network or anything)

Last edited by H_TeXMeX_H; 01-31-2008 at 03:46 PM.
 
Old 02-01-2008, 07:00 PM   #3
onion
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Original Poster
Rep: Reputation: 0
manual:

0x10 16 K..Force Full-Duplex operation (must be used with 0x20 or 0x40)
0x20 32 K..Force 100mbps-only operation
0x40 64 K..Force 10mbps-only

/etc/conf.modules:
Quote:

alias eth0 rtl8139
options options=0x40
486CPU:
Quote:
$ifconfig
eth0 Link encap:Ethernet HWaddr 00:0E:2E:64:DB:93
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20e:2eff:fe64:db93/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:358 errors:63 dropped:0 overruns:0 frame:0
TX packets:295 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:53178 (51.9 Kb) TX bytes:40268 (39.3 Kb)
Interrupt:9 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:871 errors:0 dropped:0 overruns:0 frame:0
TX packets:871 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:58463 (57.0 Kb) TX bytes:58463 (57.0 Kb)
From 7CPU:
Quote:
$ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=1.03 ms
64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=0.726 ms
64 bytes from 192.168.0.1: icmp_seq=3 ttl=64 time=0.958 ms
64 bytes from 192.168.0.1: icmp_seq=4 ttl=64 time=0.714 ms
64 bytes from 192.168.0.1: icmp_seq=5 ttl=64 time=0.940 ms
64 bytes from 192.168.0.1: icmp_seq=6 ttl=64 time=0.768 ms
64 bytes from 192.168.0.1: icmp_seq=7 ttl=64 time=0.942 ms
64 bytes from 192.168.0.1: icmp_seq=9 ttl=64 time=0.543 ms
64 bytes from 192.168.0.1: icmp_seq=10 ttl=64 time=1.12 ms
64 bytes from 192.168.0.1: icmp_seq=12 ttl=64 time=0.920 ms
64 bytes from 192.168.0.1: icmp_seq=13 ttl=64 time=0.744 ms
64 bytes from 192.168.0.1: icmp_seq=14 ttl=64 time=0.974 ms
64 bytes from 192.168.0.1: icmp_seq=16 ttl=64 time=0.904 ms
64 bytes from 192.168.0.1: icmp_seq=17 ttl=64 time=0.664 ms
64 bytes from 192.168.0.1: icmp_seq=18 ttl=64 time=0.859 ms
64 bytes from 192.168.0.1: icmp_seq=19 ttl=64 time=0.934 ms
64 bytes from 192.168.0.1: icmp_seq=20 ttl=64 time=0.759 ms

--- 192.168.0.1 ping statistics ---
20 packets transmitted, 17 received, 15% packet loss, time 19092ms
rtt min/avg/max/mdev = 0.543/0.853/1.125/0.149 ms
WoW impresing only 15%
again...
Quote:
$ ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=4 ttl=64 time=0.755 ms
64 bytes from 192.168.0.1: icmp_seq=6 ttl=64 time=0.747 ms
64 bytes from 192.168.0.1: icmp_seq=7 ttl=64 time=0.934 ms
64 bytes from 192.168.0.1: icmp_seq=9 ttl=64 time=0.925 ms
64 bytes from 192.168.0.1: icmp_seq=10 ttl=64 time=0.703 ms
64 bytes from 192.168.0.1: icmp_seq=11 ttl=64 time=0.941 ms
64 bytes from 192.168.0.1: icmp_seq=12 ttl=64 time=0.681 ms
64 bytes from 192.168.0.1: icmp_seq=14 ttl=64 time=0.909 ms
64 bytes from 192.168.0.1: icmp_seq=15 ttl=64 time=1.03 ms
64 bytes from 192.168.0.1: icmp_seq=17 ttl=64 time=0.861 ms
64 bytes from 192.168.0.1: icmp_seq=18 ttl=64 time=0.741 ms

--- 192.168.0.1 ping statistics ---
19 packets transmitted, 11 received, 42% packet loss, time 18042ms
rtt min/avg/max/mdev = 0.681/0.838/1.030/0.117 ms
486CPU
Quote:
$ping 192.168.0.7
PING 192.168.0.7 (192.168.0.7) 56(84) bytes of data.
64 bytes from 192.168.0.7: icmp_seq=2 ttl=128 time=0.730 ms
64 bytes from 192.168.0.7: icmp_seq=3 ttl=128 time=0.964 ms
64 bytes from 192.168.0.7: icmp_seq=4 ttl=128 time=0.781 ms
64 bytes from 192.168.0.7: icmp_seq=5 ttl=128 time=0.992 ms
64 bytes from 192.168.0.7: icmp_seq=6 ttl=128 time=0.794 ms
64 bytes from 192.168.0.7: icmp_seq=7 ttl=128 time=0.978 ms
64 bytes from 192.168.0.7: icmp_seq=8 ttl=128 time=1.01 ms
64 bytes from 192.168.0.7: icmp_seq=9 ttl=128 time=0.967 ms
64 bytes from 192.168.0.7: icmp_seq=10 ttl=128 time=0.842 ms
64 bytes from 192.168.0.7: icmp_seq=11 ttl=128 time=0.965 ms
64 bytes from 192.168.0.7: icmp_seq=12 ttl=128 time=0.792 ms
64 bytes from 192.168.0.7: icmp_seq=13 ttl=128 time=0.964 ms
64 bytes from 192.168.0.7: icmp_seq=14 ttl=128 time=0.777 ms
64 bytes from 192.168.0.7: icmp_seq=15 ttl=128 time=0.992 ms
64 bytes from 192.168.0.7: icmp_seq=16 ttl=128 time=0.773 ms
64 bytes from 192.168.0.7: icmp_seq=17 ttl=128 time=0.978 ms
64 bytes from 192.168.0.7: icmp_seq=18 ttl=128 time=0.775 ms
64 bytes from 192.168.0.7: icmp_seq=19 ttl=128 time=0.969 ms
64 bytes from 192.168.0.7: icmp_seq=20 ttl=128 time=0.830 ms

--- 192.168.0.7 ping statistics ---
20 packets transmitted, 19 received, 5% packet loss, time 19043ms
rtt min/avg/max/mdev = 0.730/0.888/1.012/0.099 ms
lucky me :)
Quote:
$ping 192.168.0.7
PING 192.168.0.7 (192.168.0.7) 56(84) bytes of data.
64 bytes from 192.168.0.7: icmp_seq=1 ttl=64 time=39.7 ms
64 bytes from 192.168.0.7: icmp_seq=15 ttl=64 time=6191 ms
64 bytes from 192.168.0.7: icmp_seq=16 ttl=64 time=5192 ms
64 bytes from 192.168.0.7: icmp_seq=17 ttl=64 time=4192 ms
64 bytes from 192.168.0.7: icmp_seq=18 ttl=64 time=3191 ms
64 bytes from 192.168.0.7: icmp_seq=19 ttl=64 time=2192 ms
64 bytes from 192.168.0.7: icmp_seq=20 ttl=64 time=1192 ms
64 bytes from 192.168.0.7: icmp_seq=21 ttl=64 time=192 ms
64 bytes from 192.168.0.7: icmp_seq=22 ttl=64 time=0.851 ms
64 bytes from 192.168.0.7: icmp_seq=43 ttl=64 time=2360 ms
64 bytes from 192.168.0.7: icmp_seq=44 ttl=64 time=1360 ms
64 bytes from 192.168.0.7: icmp_seq=45 ttl=64 time=360 ms
64 bytes from 192.168.0.7: icmp_seq=46 ttl=64 time=39.9 ms
64 bytes from 192.168.0.7: icmp_seq=47 ttl=64 time=40.0 ms

--- 192.168.0.7 ping statistics ---
47 packets transmitted, 14 received, 70% packet loss, time 46050ms
rtt min/avg/max/mdev = 0.851/1896.241/6191.708/2009.650 ms, pipe 7
Quote:
$ ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 32
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: d
Current message level: 0x00000007 (7)
Link detected: yes
Quote:
$ lspci
00:05.0 Host bridge: Silicon Integrated Systems [SiS] 85C496 (rev 31)
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0d.0 VGA compatible controller: S3 Inc. 86c868 [Vision 868 VRAM] vers 0
Quote:
$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:0E:2E:64:DB:93
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20e:2eff:fe64:db93/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:852 errors:230 dropped:0 overruns:0 frame:0
TX packets:830 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:106535 (104.0 Kb) TX bytes:117418 (114.6 Kb)
Interrupt:9 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1805 errors:0 dropped:0 overruns:0 frame:0
TX packets:1805 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:123584 (120.6 Kb) TX bytes:123584 (120.6 Kb)
Quote:
$ lsmod
Module Size Used by
ipv6 212064 16
sis_agp 5892 0
agpgart 26920 1 sis_agp
evdev 7168 0
ds 13572 0
yenta_socket 17536 0
pcmcia_core 52676 2 ds,yenta_socket
nls_utf8 1792 1
nls_cp437 5632 1
vfat 10880 1
fat 38336 1 vfat
ext3 106088 1
jbd 47256 1 ext3
8139too 20352 0
mii 4096 1 8139too
crc32 4096 1 8139too
Quote:
$ lsdev
Device DMA IRQ I/O Ports
------------------------------------------------
0000:00:0b.0 6000-60ff
8139too 6000-60ff
cascade 4 2
dma 0080-008f
dma1 0000-001f
dma2 00c0-00df
eth0 9
fpu 13 00f0-00ff
i8042 1
ide0 14 01f0-01f7 03f6-03f6
ISAPnP 0213-0213
isapnp 0a79-0a79
keyboard 0060-006f
PCI 0cf8-0cff
pic1 0020-0021
pic2 00a0-00a1
rtc 8 0070-0077
serial 02f8-02ff 03f8-03ff
timer 0 0040-005f
vga+ 03c0-03df
 
Old 02-02-2008, 02:17 PM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Well, it looks like you're getting many errors for incoming packets:
Code:
RX packets:852 errors:230 dropped:0 overruns:0 frame:0
but not dropped packets or overruns.

It also looks you're getting lots of packet loss and high latency, and this varies greatly with time for some reason.

Now as for this:
Quote:
0x10 16 K..Force Full-Duplex operation (must be used with 0x20 or 0x40)
0x20 32 K..Force 100mbps-only operation
0x40 64 K..Force 10mbps-only

/etc/conf.modules:

alias eth0 rtl8139
options options=0x40
did you add that to '/etc/conf.modules' or was it already in there ? Is it necessary ? Maybe try it without those options.

If you didn't change anything about the connection or network, then the driver could be buggy. You could try a newer version of the kernel and see if that help. What version are you running anyway ?
 
Old 02-02-2008, 09:16 PM   #5
onion
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Original Poster
Rep: Reputation: 0
I currently use 2.6.7 kernel on slackware 10.0; used kernels: 2.4.26 and standard kernel for 9.1 I don't know precisely.

/etc/conf.modules was edited, without that modules I can't start ssh.

I try to download some rtl8139 driver but in compiling process are some errors.
I try to find som rtl8139.o or rtl8139.o , but hopeless.

When card is on P4 there is no problem with a driver 8139too, well I have 1 integated rtl8139 and 1 on pci with same driver.
 
Old 02-02-2008, 10:21 PM   #6
armanox
Member
 
Registered: Sep 2005
Location: Baltimore, MD, USA
Distribution: Fedora, Gentoo, Debian, Slackware, IRIX, OS X
Posts: 192

Rep: Reputation: 32
I didn't know you could have PCI on an 80486. It could be that with the newer version of Slackware that there is just too much system resources in use to handle everything.
 
Old 02-03-2008, 10:53 AM   #7
onion
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
I didn't know you could have PCI on an 80486. It could be that with the newer version of Slackware that there is just too much system resources in use to handle everything.
The beauty of linux (when I say linux I mean slackware) is great performase on poor hardware!
On 80486 You can run apache, mysqld, bind, smbd with no problem.
It have a long time for system up, and can be slow sometime (using swap) but it work.
Trust me!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Realtek network card 8139 under FC4 realcr Linux - Hardware 9 08-18-2005 07:38 PM
Failed detection of "Realtek Semiconductor Co., Ltd. RTL-8139" network card scuffell Linux - Networking 5 06-15-2004 06:34 AM
Network problems - Realtek 8139 The SIN Raven Slackware 14 08-14-2003 06:41 AM
Realtek / Asound 8139 Network Card with Redhat 8.0 jamesonq Linux - Networking 6 04-06-2003 11:44 PM
Realtek 8139 pci network card and RH 7.3 d4u Linux - Networking 6 09-06-2002 10:25 PM


All times are GMT -5. The time now is 04:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration