LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-16-2003, 04:01 PM   #1
Johnnyboy
LQ Newbie
 
Registered: Sep 2003
Posts: 17

Rep: Reputation: 0
Network card problem?


I have two computers. One has windows XP and the other one is running linux RH7.2. Now I'm trying to configure my linux so that my winXP can access internet through it.

I have two network cards on my linux and the other one is working fine and I can access Internet. What doesn't work is connection with my linux and winXP. There's no response when I try to ping my winXP from linux.

When I run ifconfig there's a line in eth1:

TX packets:0 errors:4....

What are these TX packets and could it be the reason why my two computers won't communicate? I think I've made everything right but it still doesn't seem to work. Any suggestions?
 
Old 09-16-2003, 04:35 PM   #2
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 622

Rep: Reputation: 30
Hi

What IP addr are u using between XP and linux? When u type ifconfig does it give u a IP addr or not? It maybe that your interface is down. Is Linux DHCP server or are the IP fixed? Need more info to help......

chow
 
Old 09-17-2003, 01:40 AM   #3
Johnnyboy
LQ Newbie
 
Registered: Sep 2003
Posts: 17

Original Poster
Rep: Reputation: 0
My XP has got 192.168.0.2 and linux 192.168.0.1 and both have 255.255.255.0 as netmask. I don't have DHCP, they are fixed.

When I ping from linux to itself (192.168.0.1) to find out if the network card works it responses. Doesn't that mean that at least my network card works fine?

Do you know what might cause the errors on the TX packets?

And if you might need to know I have a cross over RJ-45 cable between the two computers.

Last edited by Johnnyboy; 09-17-2003 at 01:42 AM.
 
Old 09-17-2003, 05:06 AM   #4
Arenba
Member
 
Registered: Sep 2003
Location: India
Distribution: Red Hat 8
Posts: 51

Rep: Reputation: 16
If you can ping localhost from your XP computer too, there might be a problem with the cable itself.
 
Old 09-17-2003, 06:33 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,931

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Data that is transmitted between computers is called a packet. TX - transmit i.e. the packets that are outgoing by the linux PC. RX - Receive i.e. the packets that are incoming to the linux PC. TX errors would mean they are not be sent correctly.

If you have link lights on your network cards are they illuminated?
If not then check your cable. If yes then check the settings of the card in windows and make sure it is setup for auto mode for link speed and mode.

If the link lights are on then ping the XP box from the linux box. Do you see the transmit lights blink?

In linux the tools are mii-tools or ethtool. Not sure which one RH installs. You should be able to tell what speed and mode the llinux PC is setup for.

Are you running a firewall on your windows PC or linux box? If so try disabling it.

Whats the rest of the ipconfig output for eth0?

Last edited by michaelk; 09-17-2003 at 06:34 AM.
 
Old 09-17-2003, 09:33 AM   #6
Johnnyboy
LQ Newbie
 
Registered: Sep 2003
Posts: 17

Original Poster
Rep: Reputation: 0
There is a green light on the network card in linux, green and orange on the windows network card. the problem shouldn't be the cable because it's brand new.

> In linux the tools are mii-tools or ethtool. Not sure which one
> RH installs. You should be able to tell what speed and mode
> the llinux PC is setup for.

Couldn't find the tool-programs, maybe it's because I don't have graphical interface installed?

> If yes then check the settings of the card in windows and make
> sure it is setup for auto mode for link speed and mode

How do you do it exactly?

I have firewall on my windows but I tried also by disabling it and it didn't work. I'm not so sure about my linux if it has got a firewall program installed. Is there a way to check it?

Here's the whole ifconfig output (note that I've changed the ip address different "192.168.1.1" that I wrote before "192.168.0.1):

eth0

Link encap:Ethernet HWaddr 00:60:97:29:3C:70
inet addr:195.148.188.41 Bcast:195.148.188.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:32
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:1344 (1.3Kb)
Interrupt:5 Base address:0x280 DMA chan:3

eth1

Link encap:Ethernet HWaddr 00:00:E8:41:A5:FA
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:4 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:480 (480.0 b)
Interrupt:10 Base address:0x300

lo

Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:4 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1216 (1.1 Kb) TX bytes:1216 (1.1 Kb)

Last edited by Johnnyboy; 09-17-2003 at 09:48 AM.
 
Old 09-17-2003, 10:55 AM   #7
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 622

Rep: Reputation: 30
The problem u have is that there might be a problem with your ip settings. Your IP on XP 192.168.0.2 and your Linux has IP 192.168.1.1. This will never work as they are both represent diffent networks and will not be able to see one another change the linux IP address to 192.168.0.1 with this cmd: ifconfig eth1 192.168.0.1.

I also noticed that u had a second network card installed eth0 remember to connect the cable to the correct NIC in this case eth1

Good luck

chow
 
Old 09-17-2003, 11:29 AM   #8
Johnnyboy
LQ Newbie
 
Registered: Sep 2003
Posts: 17

Original Poster
Rep: Reputation: 0
Yes sorry, I forgot to tell that of course I also changed my XP ip to 192.168.1.2 at the same time I changed linux ip
 
Old 09-17-2003, 11:36 AM   #9
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 622

Rep: Reputation: 30
When u ping NIC on XP does it respond? When u ping NIC on Linux does it respond? If in both cases yes then your NIC s are fine it might be problem with the cable and remember to check if the cable is connected to the right NIC on your linux box.

Another option try and remove the eth0 NIC on you linux box and see what happens.

Chow
 
Old 09-17-2003, 12:58 PM   #10
Johnnyboy
LQ Newbie
 
Registered: Sep 2003
Posts: 17

Original Poster
Rep: Reputation: 0
Yes they respond in both cases. I'm beginning to think that the problem is in my XP setups, maybe i'm doing something wrong...
 
Old 09-17-2003, 01:09 PM   #11
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 622

Rep: Reputation: 30
for XP to check you ip info type at the dos prompt ipconfig this will display all info for XP and see if everthing is set correctly there as well.

chow
 
Old 09-17-2003, 01:39 PM   #12
Johnnyboy
LQ Newbie
 
Registered: Sep 2003
Posts: 17

Original Poster
Rep: Reputation: 0
OK, this is what I did. I changed the ip on eth0 to 192.168.1.1 and made the eth1 acces the internet. Now the connection between XP and eth0 in linux works fine and they can ping to each other. The problem seems to be the eth1-card!!? In linux I can ping to my eth1 but it still doesn't seem to send or receive any data, any suggestions??
 
Old 09-17-2003, 01:48 PM   #13
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 622

Rep: Reputation: 30
u are now ping eth1 from your linux box and it does not send or receive anything correct. It may be that your eth1 card is not active try the following cmd ifconfig up to activate the NIC

chow
 
Old 09-17-2003, 02:18 PM   #14
Johnnyboy
LQ Newbie
 
Registered: Sep 2003
Posts: 17

Original Poster
Rep: Reputation: 0
Still not working. My eth0 works fine and can ping anywhere on Internet I want to, but eth1 can't ping to winXP.

Here's the ping to my linux eth1 card in linux:

[root@localhost sysconfig]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) from 192.168.1.1 : 56(84) bytes of data.
Warning: time of day goes back, taking countermeasures.
64 bytes from 192.168.1.1: icmp_seq=0 ttl=255 time=846 usec
64 bytes from 192.168.1.1: icmp_seq=0 ttl=255 time=185 usec
64 bytes from 192.168.1.1: icmp_seq=0 ttl=255 time=176 usec

--- 192.168.1.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/dev = 0.176/0.402/0.846/0.314 ms

Why it doesn't work, I'm a bit frustrated!! Is there a way in linux to configure my eth1 card to send/receive data to my inside network (to winXP)?
 
Old 09-17-2003, 02:34 PM   #15
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 622

Rep: Reputation: 30
U said that eth0 has ip 192.168.1.1 and is able to ping XP and everywhere on the internet therefore I assume that it is working the way u want.

what is the ip addr for eth1 ? I remember that in one of the post u said that u had a crossover cable. that means u are only able to connect one NIC at atime therefore if u want to use eth1 then u have to change over your cable from eth0 eth1 for it work please do not flame me for this just trying to help....

chow
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10 network configuration. Problem with 8139 network card drivers ! Padmakiran Linux - Networking 8 03-27-2007 07:48 AM
linux shuts down built in network card then windows tells me network card is unplugge lesmoxhaybaker SUSE / openSUSE 8 08-29-2006 06:10 PM
Problem with setting up network card / network ssmeets Linux - Hardware 3 11-03-2005 04:46 PM
Problem with the network card, I think kermit Linux - Newbie 2 10-23-2003 04:41 PM
Network card problem augu2000 Linux - Hardware 1 08-20-2003 06:18 PM


All times are GMT -5. The time now is 04:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration