LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2003, 01:44 PM   #1
LoRd Of XAoS
LQ Newbie
 
Registered: Aug 2003
Location: Nothern Colorado
Distribution: Fedora Core 2
Posts: 11

Rep: Reputation: 0
Thumbs down Network Card Configuration


Ok....
So i'm new to linux... duh....

I've loaded Redhat 7.1 and it has been working fine.
But then i put in a network card and tried to configure it.
That's when the trouble began.

I don't know what i'm doing wrong... I followed the instruction in a book that I have. Which told me to use ifconfig. Which i did, but that didn't work, it still won't let me on the network.
and i've tried using the network config from KDE and that didn't seem to help at all either...
I have a NetGear FA311 network card and the latest drivers (for they actually provide linux drivers).
Now I'm not sure if installed the drivers correctly or not, but i'm pretty sure the driver was already installed.
But yeah, ever since i've tried to get this NIC to work, it's been giving me troubles. Now there are things that crash on boot up.
And sometimes it says
Initializing interface: eth0
and it sits there and hangs for a long time, then says that the IP couldn't be determined.
and then when do an ifconfig, sometimes it completely locks up and i have to do a hard reboot.
So I don't know.

If anyone can help... That'd be great.
I'm sure I'm going to have to rebuild the kernel, but I'm not quite sure how to go about doing that.

Thanx.
 
Old 08-05-2003, 02:27 PM   #2
zovres
Member
 
Registered: Sep 2002
Posts: 184

Rep: Reputation: 30
have you tried specifying an ip?
 
Old 08-05-2003, 02:28 PM   #3
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
There is support for that card in the kernel. You need to load that modules natsemi.o before the system brins up the NIC at boot.

You should be able to load the driver as a module without recompiling the kernel. I am not sure how to do this with Read Hat, bu in Slackware there is a file /etc/rc.d/rc.modules that you uncomment the line that contains /sbin/modprobe/natsemi. You can run that command from the command line and see if the module is there. If if work you then need to do and ifconfig eht0 192.168.0.10 up to bring up the card.
 
Old 08-05-2003, 02:41 PM   #4
JoeDuncan
Member
 
Registered: Aug 2003
Location: Ottawa
Distribution: Redhat 5.2, 6.0, 6.1, Mandrake 7.2, 8.0, 9.1, 9.2, 10.0, Gentoo, Debian 3.1r0
Posts: 224

Rep: Reputation: 30
Is it an ISA or PCI card? Reason I ask is that I had a lot of problems with old ISA PnP (Plug'n Pray) cards, but any PCI cards I have tried work like a charm.

That said, there are a couple of things you should look into. First of all, do you know if the driver for your card is a *.o module or is it compiled into the kernel? I'm guessing that since you said the driver came with the card, that it's a *.o module file.

You'll want to check that it's installed in the correct directory, it should be something like:

/lib/modules/<yourkernelversion>/net/<drivername>.o

(Replace <yourkernelversion> and <drivername>.o with the appropriate values.)

<drivername>.o should be your driver module file. Make sure it's in the directory specified above, if the directory doesn't exist, get back to me.

If all is fine and the driver is in the correct place, try this:

modprobe <drivername>.o

That should automatically probe your hardware for a card that the driver supports, and if it finds it, load the driver. If that's successful, you should be able to use "ifconfig" to configure the card.

You should probably also to a "man modprobe" and "man ifconfig" just to get a basic view of what they do. When you use "ifconfig" make sure you specify an IP address like so:

ifconfig eth0 192.168.1.1

Of course use your correct IP address (if you are using DHCP get back to me).

If this works, you will need to add a line to your "/etc/modules.conf" file in order to load the module at boot time. You should be able to find exact details on how to do this easily enough.

Also, you might want to look up the commands "insmod" and "lsmod". "lsmod" will tell you what modules are loaded, you can use it after doing a "modprobe" to verify that the module (driver) is loaded. "insmod" is what modprobe uses to actually load the driver, and it can sometimes be used to force the driver to load.

One more thing, make sure that you have "PnP OS" disabled in your BIOS.

If you have problems with any of the above, or need more detail, get back to me.

Now, if you an old ISA PnP card, you will most likely need to download and install the "isapnp" program. Once it's installed, run the "pnpdump" utility from the /etc directory. This should produce a file called "isapnp.conf". Look in this file for an entry for your NIC. If it's there, we should be in business, you will need to make some small edits to you "isapnp.conf" file and then run "isapnp", which should make the hardware available to modprobe and ifconfig....Whew, if you have any problems, get back to me...
 
Old 08-05-2003, 04:35 PM   #5
LoRd Of XAoS
LQ Newbie
 
Registered: Aug 2003
Location: Nothern Colorado
Distribution: Fedora Core 2
Posts: 11

Original Poster
Rep: Reputation: 0
Ok....
Great... Thanx very much for the support....

I checked, the driver is in the right place.

So I ran modprobe natsemi
And the result was:

Not: /etc/modules.conf is more recent than /lib/modules/2.4.202/modules.dep
/lib/modules/2.4.2-2/kernel/drivers/net/natsemi.o: init_module: No Such Device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.2-2/kernel/drivers/net/natsemi.o: insmod /lib/modules/2.4.2-2/kernel/drivers/net/natsemi.o failed
insmod: /lib/modules/2.4.2-2/kernel/net/natsemi/natsemi.o: No such file or directory
insmod: insmod /lib/modules/2.4.2-2/kernel/net/natsemi/natsemi.o failed
insmod: insmod natsemi failed

What should I try now?


Oh yes... I'm also using DHCP on my internal network.... so yeah

Last edited by LoRd Of XAoS; 08-05-2003 at 04:45 PM.
 
Old 08-05-2003, 04:55 PM   #6
JoeDuncan
Member
 
Registered: Aug 2003
Location: Ottawa
Distribution: Redhat 5.2, 6.0, 6.1, Mandrake 7.2, 8.0, 9.1, 9.2, 10.0, Gentoo, Debian 3.1r0
Posts: 224

Rep: Reputation: 30
Hrm... it looks like it's having problems finding the hardware, at least that's what I get from the "No such device" message.

1) have you turned off "Plug and Play OS" in your BIOS?
2) Is it an ISA or PCI card? (Do you know how to tell the difference?)

If it is an ISA card, I have a feeling you will need to get the "isapnp" program.

Either way, we need to find out the correct IO and IRQ settings for this to work. Do you have a windows computer lying around? Sometimes they can be used to find out the IO/IRQ settings as their hardware support is generally better...

Also, take a look at what's in your /etc/modules.conf file, you can do this with

cat /etc/modules.conf
 
Old 08-06-2003, 03:40 PM   #7
LoRd Of XAoS
LQ Newbie
 
Registered: Aug 2003
Location: Nothern Colorado
Distribution: Fedora Core 2
Posts: 11

Original Poster
Rep: Reputation: 0
Ok....

So now progress as of yet.
It doesn't seem to be finding the hardware at all.

it's a PCI card so that shouldn't be an issue - also
I checked to see what was in modules.conf
the result:

alias eth0 tulip
alias parport_lowlevel parport_pc
alias usb-controller usb-ohci
alias sound-slot-0 cs4232
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/nul 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/nul 2>&1 || :
options sound dmabuf=1
alias synth0 op13
options op13 io=0x388
options cs4232 io-0x530 irq dma=0 dma2=0 mpuio=0x330 mpuirq=5

and I checked and I did turn "PnP OS" OFF in the bios...
So that's set.....

I'm not sure....
I think I'm going to swap out this network card with one that I've known to work in other machines, and test this card in a windows box....

If you have anyother Ideas, I'd appreciate the input.....
Thanx...
 
Old 08-11-2003, 10:14 AM   #8
JoeDuncan
Member
 
Registered: Aug 2003
Location: Ottawa
Distribution: Redhat 5.2, 6.0, 6.1, Mandrake 7.2, 8.0, 9.1, 9.2, 10.0, Gentoo, Debian 3.1r0
Posts: 224

Rep: Reputation: 30
I think sticking it into a windows box just to see if it works would be a good idea, if it doesn't work, your card is bunk, if it does work, you have use the device manager to find the correct io/irq settings, then you will need to add lines to modules.conf:

alias eth0 natsemi
options natsemi io=<IOport> irq=<IRQ#>

Of course before doing so you should try inputting those values into your modprobe query to see if all's well.

Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10 network configuration. Problem with 8139 network card drivers ! Padmakiran Linux - Networking 8 03-27-2007 07:48 AM
network card configuration in FC2 RohanShrivastav Linux - Networking 28 12-05-2004 08:26 AM
network card configuration problem amrogers3 Linux - Networking 5 02-24-2004 02:09 PM
network card configuration jmono Linux - Hardware 1 05-06-2003 08:52 PM
Network card configuration JoeySlack Slackware 6 12-20-2002 01:35 AM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration