LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-11-2006, 09:23 AM   #1
wtfn00b
LQ Newbie
 
Registered: Jan 2006
Posts: 24

Rep: Reputation: 15
Unhappy Network


Goodday, I'm young in linux and I hope you will help me with the problem.

In first place I want to tell what i wanted to do:

I wanted to connect with cross-cable two PC,
on 1st PC is Win XP and other PC is Linux Slackware 10.2.

The main problem is that my lanparty don't work.

I tryied reading many post @ this forum and doing many this but nothing worked.

So like the main things I will show:


ifconfig:

lo Link encap: Local Loopback
inet addr: 127.0.0.1 Mask: 255.0.0.0
UP LOOPBACK RUNNING MTU: 16436 Metric: 1
RX packets: 117 errors: 0 dropped: 0 overruns: 0 frame: 0
TX packets: 117 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisions: 0
RX bytes: 7139 (6.9kb) TX bytes: 7139 (6.9kb)



route:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
loopback * 255.0.0.0 U 0 0 0 lo


iptables -L:

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


rc.inet1.conf:

# Config information for eth0:
IPADDR[0]="192.168.0.2"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]="no"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY="192.168.0.1"


Writing "ping 192.168.0.1" and "ping 192.168.0.2"
Showing me: "Connect: Network is unreachable"

And ofcoz that I did netconfig and set IP there 192.168.0.1
gateway 192.168.0.2 and submask 255.255.255.0
The 192.168.0.1 IP is on XP but 192.168.0.2 is on linux.

The XP PC is showing:
Status is connected
Send Packets 1,000
Received 0
Try pining "Request time out."

I can't get what I have mist. Please help me if you see in my files
some errors, please post replays with commands, coz I don't know all of theim, thanks.

Sorry for my bad language.
 
Old 08-11-2006, 10:28 AM   #2
brainiac
Member
 
Registered: Jan 2005
Location: middle of a cornfield, IL
Distribution: Kanotix HD Install, Debian Testing, XP Pro,Vista RC1
Posts: 145

Rep: Reputation: 15
Are you absolutely sure you have a crossover cable? They are configured differently than a standard cable. Without a switch or other device to do translation they are trying to receive on the send wire and vice versa. And I don't think a gateway setting is needed, not sure on that though.
 
Old 08-11-2006, 11:07 AM   #3
wtfn00b
LQ Newbie
 
Registered: Jan 2006
Posts: 24

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by brainiac
Are you absolutely sure you have a crossover cable? They are configured differently than a standard cable. Without a switch or other device to do translation they are trying to receive on the send wire and vice versa. And I don't think a gateway setting is needed, not sure on that though.

I have this:

My home network system
 
Old 08-11-2006, 02:37 PM   #4
pablob
Member
 
Registered: Apr 2003
Location: Madrid
Distribution: RHEL, Kubuntu, Solaris, TRU64
Posts: 382

Rep: Reputation: 31
But according to the ifconfig output, you only have a loopback IP address (127.0.0.1) configured. That one is "not real". You need to get a 192.168.x.x one first if you want to talk to the other computer.

Also, supporting this theory, you can see there is no route to 192.168. network, only 127 as you get from "route" command.

Look, as an example, mine shows:

#ifconfig

eth0 Link encap:Ethernet HWaddr 000:59:26:0E:23
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:122933 errors:0 dropped:0 overruns:5 frame:5
....

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
......


# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
 
Old 08-11-2006, 02:41 PM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Have you tried running "ifconfig eth0 up"?
 
Old 08-11-2006, 03:31 PM   #6
wtfn00b
LQ Newbie
 
Registered: Jan 2006
Posts: 24

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Nylex
Have you tried running "ifconfig eth0 up"?

LOL, so simple, thanks.
 
Old 08-11-2006, 05:19 PM   #7
wtfn00b
LQ Newbie
 
Registered: Jan 2006
Posts: 24

Original Poster
Rep: Reputation: 15


I set ifconfig eth0 up,
tested ifconfig and it's there,
now I can ping my linux IP
with no problems but I can't
ping Windows XP.

In my route -n:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
loopback..........*........255.0.0.0...U.........0.......0.....0......lo
192.168.1.0.....*......255.255.1.0...U.........0.......0.....0......eth0
0.0.0.0....192.168.1.1....0.0.0.0....UG........0.......0.....0......eth0

Hmm, how did that happend ?
How can I edit IP GW Netmask ?
And how can I allow ip_forward ?

Last edited by wtfn00b; 08-12-2006 at 04:52 AM.
 
Old 08-13-2006, 05:59 AM   #8
wtfn00b
LQ Newbie
 
Registered: Jan 2006
Posts: 24

Original Poster
Rep: Reputation: 15
Please, help...
 
Old 08-13-2006, 06:16 AM   #9
restless
Member
 
Registered: Feb 2003
Location: Belgium
Distribution: Debian
Posts: 166

Rep: Reputation: 31
well paste here once again your output from ifconfig.

let's assume that you did:

ifconfig eth0 inet 192.168.0.1 netmask 255.255.255.0 up

which means that your network card will receive the ip address 192.168.0.1 (can't be 192.168.0.0 or 192.168.0.254 those are reserved for uni/broadcast).

that also means that your windows xp needs the address in the same range as your linux box. Otherwise they won't find eachother. so give your windows xp the ip address: 192.168.0.2

normally there is no reason to add a route because both computers are on the same network.
 
Old 08-13-2006, 08:56 AM   #10
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
I like your sketch of how you connected the two PC's together. There is still the question of what kind of cable you used. If it is a regular Ethernet cable, this will not work. It has to be a special crossover cable, otherwise the "transmit" from one PC is just connected to the "transmit" on the other PC, when it should be connected to the "Receive". Go here to see the difference:

http://www.duxcw.com/digest/Howto/ne...ble/cable5.htm

You could make a crossover cable by cutting a regular cable in half and splicing the wires back together with the green/green stripe switched with the red/red stripe pairs.

Good luck.

C
 
Old 08-13-2006, 10:06 AM   #11
wtfn00b
LQ Newbie
 
Registered: Jan 2006
Posts: 24

Original Poster
Rep: Reputation: 15
Well, I have cross-cable 150% already checked twice.

ifconfig output:

eth0 Link encap: Ethernet HWaddr 00:30:4F:10:C4:1A
inet addr: 192.168.1.101 Bcast: 192.168.1.255 Mask: 255.255.255.0
EtherTalk Phase 2 addr: 65280/63
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets: 0 errors:0 dropped:0 overruns:0 frame:0
TX packets: 0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes:0 (0.0 b) TX bytes:2640 (2.5 Kb)


lo Link encap: Local Loopback
inet addr: 127.0.0.1 Mask: 255.0.0.0
EtherTalk Phase 2 addr:0/0
UP LOOPBACK RUNNING MTU: 16436 Metric: 1
RX packets: 6 errors: 0 dropped: 0 overruns: 0 frame: 0
TX packets: 6 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisions: 0
RX bytes: 500 (500.0 b) TX bytes: 500 (500.0 b)

I entered
ifconfig eth0 inet 192.168.1.101 netmask 255.255.255.0 up
nothing changes ifconfig is the same.


 
Old 08-13-2006, 10:08 AM   #12
restless
Member
 
Registered: Feb 2003
Location: Belgium
Distribution: Debian
Posts: 166

Rep: Reputation: 31
and what is the ip address of your windows computer?

it has to be 192.168.1.x then
 
Old 08-13-2006, 01:25 PM   #13
wtfn00b
LQ Newbie
 
Registered: Jan 2006
Posts: 24

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by restless
and what is the ip address of your windows computer?

it has to be 192.168.1.x then

It is, but network don't work
 
Old 08-14-2006, 08:48 AM   #14
pablob
Member
 
Registered: Apr 2003
Location: Madrid
Distribution: RHEL, Kubuntu, Solaris, TRU64
Posts: 382

Rep: Reputation: 31
What about Windows XP Firewall.

Please turn it off.
 
Old 08-14-2006, 10:26 AM   #15
wtfn00b
LQ Newbie
 
Registered: Jan 2006
Posts: 24

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by pablob
What about Windows XP Firewall.

Please turn it off.

Windows XP FW was off and is.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora C2 - Wireless network drivers? Broadcom 802.11g Network Adapter FragTek Linux - Wireless Networking 7 01-22-2010 01:10 AM
Debian 3.1r0a, Realtek RTL-8169 network controller slow on network mvr853 Linux - Networking 0 07-21-2006 09:20 PM
3c905C network card in docking station. Cannot activate network device eth0. pathelms Linux - Networking 4 04-12-2006 03:55 PM
Bridge simulating Network Lag, for developing network code for games intripoon Linux - Networking 18 10-27-2005 06:04 PM
Newbie wanna setup up a linux network on existing home network... marvc Linux - Networking 3 03-19-2003 10:02 PM


All times are GMT -5. The time now is 08:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration