LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-04-2014, 01:45 PM   #1
randyvh
Member
 
Registered: Jun 2014
Posts: 95

Rep: Reputation: Disabled
netflix


hi
I get an error message when opening netflix saying must have ms true fonts installed. When in terminal it appears they are already there. now netflix won't even open. Can some one help.
I am running lubuntu 12.04 on ibm t42.
 
Old 08-04-2014, 02:10 PM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Are you using Wine or running netflix in a VM?
jdk
 
Old 08-04-2014, 02:44 PM   #3
randyvh
Member
 
Registered: Jun 2014
Posts: 95

Original Poster
Rep: Reputation: Disabled
no. The idea here is to be completely free of ms. i'm almost there. this is the last hurdle.
 
Old 08-04-2014, 02:54 PM   #4
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,116

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
Up until recently there wasn't a way to run Netflix in Linux because it requires Microsoft Silverlight. It is unsupported and broken in Wine.

There is a Linux version of it called 'pipelight' though, and that is probably what you are missing.

Last edited by szboardstretcher; 08-04-2014 at 02:56 PM.
 
1 members found this post helpful.
Old 08-04-2014, 02:55 PM   #5
randyvh
Member
 
Registered: Jun 2014
Posts: 95

Original Poster
Rep: Reputation: Disabled
I'm sorry, that answer was unclear. I'm using wine. I downloaded ehoovers ppa. That got nexflix working but with buffering problems.
I just did an update that included a wine update. After that I got an error message telling me to install ms true fonts only I can't figure out how to do that. I'm not even sure thats the problem. Any ideas?
 
Old 08-04-2014, 03:43 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,989

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
Microsoft released there "truetype" fonts

they should be installed by default or in the OS's repos

also they are on sourceforge
http://corefonts.sourceforge.net/
http://sourceforge.net/projects/core...?source=navbar

for Debian based distros
https://packages.debian.org/stable/x11/msttcorefonts


you need to use "pipelight" for netflix
https://launchpad.net/pipelight
http://www.webupd8.org/2013/08/pipel...our-linux.html

or
a install of windows 7 or 8

Last edited by John VV; 08-04-2014 at 03:46 PM.
 
Old 08-04-2014, 03:44 PM   #7
randyvh
Member
 
Registered: Jun 2014
Posts: 95

Original Poster
Rep: Reputation: Disabled
OK I reinstalled netflix and tryed to install ms fonts in terminal get this sudo apt-get install ttf-mscorefonts-installer latist vertion but when I try to open netflix it still is asking for ms true fonts.
 
Old 08-04-2014, 03:53 PM   #8
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,989

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
The information at Hoovers site below might explain that in the second paragraph. Using wine-pipelight handles the MS fonts during the installation. I've got Netflix on Ubuntu 12.04 working using wine-pipelight. There are several links on that page which explain how to install for different distributions.

http://www.compholio.com/netflix-desktop/
 
Old 08-04-2014, 04:38 PM   #9
randyvh
Member
 
Registered: Jun 2014
Posts: 95

Original Poster
Rep: Reputation: Disabled
went to the site you suggested but at the bottom (for older computers) in terminal when I entered sudo gedit /etc/fstab, got gedit command not found.
 
Old 08-04-2014, 04:55 PM   #10
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,989

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
gedit is the Gnome desktop default text editor

if you are using KDE it would be kate or kwrite
or
nano or emacs or vim
 
Old 08-04-2014, 05:26 PM   #11
randyvh
Member
 
Registered: Jun 2014
Posts: 95

Original Poster
Rep: Reputation: Disabled
ok thanks john, I used nano and got this not sure what to do now.
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda5 during installation
UUID=75ba74ca-69b0-43e3-88a6-f8c21da0314d / ext4 errors=remoun$
# /dos was on /dev/sda1 during installation
UUID=7C70D7F870D7B75C /dos ntfs defaults,umask=007,gid=46 0 $
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0






[ Read 13 lines ]
^G Get Help ^O WriteOut ^R Read File ^Y Prev Page ^K Cut Text ^C Cur Pos
^X Exit ^J Justify ^W Where Is ^V Next Page ^U UnCut Text^T To Spell
 
Old 08-04-2014, 08:02 PM   #12
randyvh
Member
 
Registered: Jun 2014
Posts: 95

Original Poster
Rep: Reputation: Disabled
I tried installing piplight as instructed and got this

Length: 9597 (9.4K) [application/pgp-signature]
Saving to: `/tmp/tmp.0GiM2m4PYp'

100%[======================================>] 9,597 --.-K/s in 0s

2014-08-04 16:52:17 (80.5 MB/s) - `/tmp/tmp.0GiM2m4PYp' saved [9597/9597]

gpg: directory `/home/randy/.gnupg' created
gpg: new configuration file `/home/randy/.gnupg/gpg.conf' created
gpg: WARNING: options in `/home/randy/.gnupg/gpg.conf' are not yet active during this run
gpg: keyring `/home/randy/.gnupg/secring.gpg' created
gpg: Signature made Mon 14 Jul 2014 10:44:15 AM PDT using RSA key ID 1C3B0533
gpg: /home/randy/.gnupg/trustdb.gpg: trustdb created
gpg: Good signature from "Pipelight Dev Team <webmaster@fds-team.de>"
gpg: WARNING: This key is not certified with a trusted signature!
gpg: There is no indication that the signature belongs to the owner.
Primary key fingerprint: 3978 8ABB 0402 FC31 D4FB 22AA 0B6B 817C 1C3B 0533

Script dependency-installer has been updated to version ff8773801f16d07ec57cd9a5cf77d8dfa28e81e916857ca521758d8ded8d90a6
randy@randy-ThinkPad-T42:~$ sudo pipelight-plugin --enable pluginname
ERROR: Plugin pluginname is unknown
randy@randy-ThinkPad-T42:~$

What shoul I do?
 
Old 08-04-2014, 11:50 PM   #13
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,989

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Quote:
randy@randy-ThinkPad-T42:~$ sudo pipelight-plugin --enable pluginname
That's just an example you are being to literal about. Try: sudo pipelight-plugin --enable silverlight5.1

The page below to install wine-pipelight on Ubuntu:

http://pipelight.net/cms/install/ins...on-ubuntu.html

The page below has a little more detail. Near the bottom there is an explanation on additional add-on requirement for firefox, to use User Agent Overrider or User Agent Switcher. The User Agent Overrider seems to work better, your choice.

http://www.webupd8.org/2013/08/pipel...our-linux.html
 
Old 08-05-2014, 02:04 AM   #14
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I use the wine-comholio version & it works well.
Also you need the user-agent-switcher.
 
Old 08-05-2014, 02:33 AM   #15
Germany_chris
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Arch
Posts: 1,027

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
netflix

You need to use user agent overrider in Firefox if you don't you will get an error
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Netflix on Debian? Ryanms3030 Linux - Newbie 6 05-04-2014 11:20 AM
Netflix No Video scorpioofthewoods Ubuntu 6 03-05-2014 02:08 PM
Netflix access rlthorn Linux - Newbie 9 07-16-2013 02:30 PM
Netflix mrdave100 Linux - General 3 10-29-2011 11:13 AM
Damn you Netflix! trxdraxon Slackware 1 10-10-2011 06:31 PM


All times are GMT -5. The time now is 03:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration